Hello Guest it is August 19, 2022, 03:17:05 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - curtisturner

Pages: 1 2 »
1
General Mach Discussion / HELP! My Z axis is moving in chunk steps
« on: May 24, 2011, 10:41:08 AM »
Here is the problem.
I have a 4th axis machine where A is the chuck X moves the length of the object being machined and Z is the depth.
The A axis keeps a perfect continuous RPM and the X axis is moving constantly at say the rate of 128th of an inch per second and the servo motor for the X has a constant smooth rotation. However the Z axis servo is not moving except every few seconds and it then moves about 10deg instead of much smaller say 1/2 deg steps. Is there a setting I am missing or is my G-Code wrong?

A Few Facts
All 3 axis are Yaskawa Servos
Z axis is a ball screw driven by a 10:1 gearhead

Here are a few line of G-Code
N000035     A1440 X0.077 Z-0.00281176075414713;
N000036     A1440 X0.077 Z-0.00285099436525282;
N000037     A1440 X0.077 Z-0.00288965724492307;
N000038     A1440 X0.077 Z-0.00292777388626453;
N000039     A1440 X0.077 Z-0.00296536717817242;
N000040     A1440 X0.077 Z-0.00300245854969372;
N000041     A1440 X0.077 Z-0.00303906809810783;
N000042     A1440 X0.077 Z-0.00307521470288652;
N000043     A1440 X0.077 Z-0.00311091612742498;
N000044     A1440 X0.077 Z-0.00314618911008591;
N000045     A1440 X0.077 Z-0.00318104944591235;
N000046     A1440 X0.077 Z-0.00321551206015691;
N000047     A1440 X0.077 Z-0.00324959107459355;

Thanks in advance
Curtis

2
SmoothStepper USB / spindle hookup
« on: March 18, 2009, 11:34:01 PM »
I have a 2.2K spindle from china and am using the smooth stepper board, I can not find any where exactly how to wire the spindle control to the SS board for speed control and on and off


Thanks in advance
Curtis

3
Screen designer tips and tutorials / Visual cycle data
« on: December 20, 2008, 10:37:39 AM »
Is there any way to get at the canned cycle data ?
For instance I would like to display the current position in a canned cycle.

Please help?

Thanks
Curtis

4
SmoothStepper USB / USB connection problem
« on: August 11, 2008, 10:24:14 AM »
Every once and a while I will get an error saying the smoothstepper has lost comunication with USB and you must unplug and replug in the board in and restart mach 3

I switched computers and it still does it ?
I have 2 boards and both are doing it ?

HELP!!

Thanks
Curtis

5
General Mach Discussion / Output control ? Parrallel or Grex or ?
« on: May 03, 2008, 04:40:21 PM »
Ok I have been using Mach 3 for a few years currently on 3 machines.
2 of the machines are running printer ports and the other a Grex

Is there a better solution as most new PC's do not come with printer ports and the Grex is loosing intrest with the developers.

My current Grex system need a very fast pulse rate and works great with the Grex
Except every once in a while it will start acting crazy like in the middle of running a file it will start jogging different directions and stop running the file.

Is there any new (relatively cheap<$500) solutions that do not use a printer port like the Grex?

Thanks
Curtis

6
I have several hubbard relay boards and I can not seem to get them working at all.
I set it up for pin 16 and pin 17 and then set up the outputs 1 and 2 for pin 16 and pin 17.
Set the spindle relay on for output 1 and the flood for on for output 2

I have tried all 3 boards so there seem to not be a board problem.


HELP?

Thanks in advanced
Curtis

7
General Mach Discussion / Canned cycles counting ?
« on: January 31, 2008, 07:52:46 PM »
Is there any where I can see what iteration my canned cycle is on ?


Thanks
Curtis

8
Mach3 and G-Rex / External Jog speed ?
« on: August 23, 2007, 07:08:16 PM »
Can you hook up a pot to an analog input for variable jog speed? If so how?

Thanks
Curtis-

9
Mach3 and G-Rex / Mapping digital inputs to jog
« on: August 22, 2007, 09:35:17 AM »
Is there a way to use use a digital input from the grex to jog and axis.
Mabee using keystroke emulation or whatever?

Thanks
Curtis

10
Mach3 and G-Rex / Axis not responding
« on: August 22, 2007, 09:09:52 AM »
I am having a real weird problem.
I switched from parallel port to grex and can not get my A axis to respond to gcode
My other axis are responding as should
I can the A axis to jog with no problem but when I run gcode it just passes right over it like it is not even there.
The same gcode worked just fine when I used the parallel port.

BTW, this is the latest version of everything, HELP


Thanks
Curtis

Pages: 1 2 »