Hello Guest it is May 28, 2020, 07:50:28 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - bicycleguy

Pages: 1
1
Using the latest Mach4 and Pokey57CNC.  Can move motors and home/limits work but can't set Counts Per Unit, Velocity and Acceleration or anything in the Configure/Mach.../Motors dialog.  The axis checkboxes and weirdly the Enable Delay(ms) can be changed.  Also can't seem to invert an axis motion anywhere.

Mach4 Hobby Version 4.2.0.3390

PoKeys plugin - Polabs  8.21.0.3344






2
PoKeys / Pokey57CNC connection to G320 driver
« on: June 20, 2017, 11:27:40 PM »
What is the best way to handle the error/reset pin on the Gecko Drive G320 step direction driver?  This pin is both an input and output so always needs special attention.  Surely it must have been delt with b4 but I only see old stuff for other controllers and none of them look very good.

Besides the pin question above how can I invert the error signal on the Pokey57CNC so that it can do an estop on error.  I'm using the plugin for Mach3.  I get the error state on the plugin status but its inverted.

Thanks

3
Mach3 and G-Rex / How to change output voltage to 5v
« on: February 23, 2017, 07:59:18 PM »
First what with all the negativity these days, I want to say that over the last 9 years I have been using my G100 for hundreds of hours and still don't understand why the various parties gave up on it.  I run Mach3 on XP on Bootcamp on a Mac PowerBoook.  I run 2000 line (4000 quadrature) encoders on 1/3hp dc motors.  Not sure if anything today comes close to some of the specs of the G100.

Now to my question.  I'm trying to make this G100 brained Shoptask Mill/Lathe also able to 3D print.  To that end I need the 16 digital output pins to be 5V max instead of ~9V.  The specs and schematic indicate the outputs can be 5-24V.  Unfortunately, I can't figure out how to change this.

Any ideas?

4
General Mach Discussion / can a Mach3 macro toggle an output pin?
« on: February 16, 2017, 02:40:27 AM »
The following code toggles when stepped through in the Mach3 VB script editor but not when run or when the macro runs.
Code: [Select]
ActivateSignal(OUTPUT4)
DeactivateSignal(OUTPUT4)
ActivateSignal(OUTPUT4)
DeactivateSignal(OUTPUT4)
End
Viewed with an oscilloscope hooked to OUTPUT4 it moves when single stepping but never triggers when running.  Only the last state happens.  What am I missing? 

Pages: 1