Hello Guest it is February 23, 2020, 05:46:26 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - ekocakaya

Pages: 1
1
General Mach Discussion / Delta ASD-B servo pulse problem (please help)
« on: September 25, 2008, 10:05:36 AM »
Helloo,

I have very big problem.I have 400 watt delta ac servo .I setup my system 1000 pulse for 1 mm and when I write G0 X+1 then G0 X0 .The servo dont get back start position.The servo company said that the mach3 not produce same pulse count.And I looked the servo online watch system when I said go +1 mm  produce 982 pulse then go the 0 (start point) it produce 943 pulse so 39 pulse miisng?

What is the problem? Ground problem or what? I am using shermil 1/2.I have direct parallel interface card for direction and step

Please give me advice

2
General Mach Discussion / Tool Height Macro Problem Help
« on: November 15, 2007, 05:04:45 PM »
I want to change my tools and make the height control with this macro but When I run this macro my computer freezing.What is the problem with this code.I get this code from this forum



ChX = GetUserDRO(1200)
ChY = GetUserDRO(1201)
ChZ = GetUserDRO(1202)
Swposx = GetUserDRO(1203)
Swposy = GetUserDRO(1204)
SwError = GetUserDro(1205)
CurrentFeed = GetOemDRO(818)

If GetOemLed (23) Then DoOemButton (119) 'Turn soft limits off

Code "G20" 'Set to inch units

Code "G53 G00 Z" &ChZ 'Move the tool all the way up
While IsMoving()
Wend
ZOld = Getdro(2)

Code "G53 G00 X" &Swposx & "Y" &Swposy 'Move to the switch position
While IsMoving()
Wend

MsgBox ("Jog Z axis down close to switch then hit Cycle Start to resume")
SystemWaitFor (Start) 'Pause macro to jog the Z axis close to the switch

Code "G31 Z-7 F10" 'Move Z down until switch is triggered
While IsMoving()
Wend
Code "G4 P0.1"
HitOld = GetVar(2002) 'Get the position where the switch was triggered
Code "G53 G00 Z" &ChZ 'Z move all way up
Code "G53 G00 X" &ChX & "Y" &ChY 'Move to change tool position
While IsMoving()
Wend

MsgBox ("Insert the new tool")

Code "G53 G00 X" &Swposx & "Y" &Swposy 'Move to the switch position
While IsMoving()
Wend

MsgBox ("Jog Z axis down close to switch then hit Cycle Start to resume")
SystemWaitFor (Start) 'Pause macro to jog the Z axis close to the switch

Code "G31 Z-7 F10" 'Z move down until switch is triggered
While IsMoving()
Wend
Code "G4 P0.1"
HitNew = GetVar(2002) 'Get the position where the switch was triggered
Code "F" &CurrentFeed

Diff = HitOld - HitNew
DiffABS =Abs(Diff)

If DiffABS=0 Then
Code "G53 G00 Z" &ChZ
Code "G53 X0Y0"
While Ismoving()
Wend
DoOemButton (119) 'Turn soft limits on
Code "(New tool is now ready for use)"
Exit Sub
End If

ZNew=0

If HitOld < HitNew Then ZNew = ZOld - DiffABS :A=1
If HitOld > HitNew Then ZNew = ZOld + DiffABS :A=2

Code "G53 G00 Z" &ChZ
While IsMoving()
Wend
Call setdro(2,ZNew - SwError)
Code "G53 X0Y0"
While Ismoving()
Wend
DoOemButton (119) 'Turn soft limits on
Code "(New tool is now ready for use)"
End   

3
General Mach Discussion / Loosing steps and stalling Help Please
« on: October 20, 2007, 04:34:37 AM »
Dear Friends I am using Mach 3 v1.98 and I have 8NM Nema 34 Motors.My power supply is 65V and I am using Leadshine microstep drivers , my leadscrew is 5mm/turn.I set up my driver to 800 microstep.

In Motor tuning screen I adjust

160
velocity : 3000 mm
250mm s/s
and pulse time 5

when I move the motor 20 cm then I starts freezing and lose steps.I use Driver test program but I dont know how should it look?

my computer p4 3.0 512 mb ram 256 mb X550 graphic card.


Pages: 1