Hello Guest it is July 03, 2022, 08:19:17 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - M250cnc

Pages: 1 2 3 4 5 6 7 8 »
1
PoKeys / PoPendant pdf help
« on: December 28, 2010, 01:44:49 PM »
In the popendant pdf pin 5 says connect to N.C.

What pin is that please.

Phil

Sent from my HTC Desire using Tapatalk

2
VB and the development of wizards / More VBscript woes
« on: September 02, 2010, 06:16:56 AM »
This is copied from RayL's VB ref guide

RefCombination
Sub RefCombination(Axes As Integer)
This function allows any combination of axes to be simultaneously referenced (homed). Which axes will
be referenced is determined by the Axes argument, which is a bit-mapped variable, with the bits mapped
as defined below.
Arguments:
Axes is a bit-mapped value the defines which axes are to be referenced. The value of Axes can be
calculated by adding the values corresponding to the individual axes to be referenced. The axis
values are:
X = 1
Y = 2
Z = 4
A = 8
B = 16
C = 32
So, for example, to reference the X, Z and B axes, Axes = 1 + 4 + 16 = 21.
Return Value:
None
Example:
‘ Define some constants
RefX = 1
RefY = 2
RefZ = 4
RefZ = 8
RefB = 16
RefC = 32
‘ Reference Y, Z and C axes
RefCombination(RefY + RefZ + RefC)

So my code is

RefX=1
RefZ=4
RefCombination (5)

Only one axis moves (X) this on a lathe, current stable release i have individual home switches on different pins using a SS

So what the hell is wrong.  ???

3
General Mach Discussion / VB Code On A Button Help Required
« on: August 27, 2010, 12:00:10 PM »
Mach version 3.42 on a lathe

I think these newer Mach versions are all Boolean and Double Bubble Trouble  ;D

I think anyone who knows what they are doing "Unlike Me" should be able to sort this mess out.

When i press the BUTTON nothing happens

X_Distance = GetUserDRO ( 2011 )
Code "G04 P.25"
Code "G01 X_Distance F.10"

Pretty Please

4
CVI MachStdMill (MSM) / Disappointment
« on: July 18, 2010, 07:41:05 AM »
Disappointment yes, the screens look great but i just don't get the fact that you have to use the latest development version to use the screenset.

Sorry but i will not be bug testing the development version "Mach3 R3.043.10 "

Maybe someone can explain ?

5
Apparently there is some free software to allow forums to be easily read with an Android mobile phone "TapaTalk"

I know the Zone has it, any chance of getting it here please ?

Phil

6
General Mach Discussion / Tool Numbers In Lathe
« on: May 31, 2010, 01:19:16 PM »
What is the maximum amount of tools you can use in lathe

The tool table has 250, i don't have that many but want to make it easier to use the tools with different inserts.

So for instance tool 03 would be .4mm Radius tool 103 would be .8mm Radius

If i put tool 103 in the tool number DRO it gives that detail on screen

I lack the courage to try it in code.  ::)

Phil

7
General Mach Discussion / Bit of help needed with VB code
« on: April 24, 2010, 05:40:58 AM »
Scott S posted some VB parameters and i need help in understanding it a bit.

I want to find the Z offset in lathe for the current tool, Z offset would be parameter 4

Here is the code

GetToolParam(SHORT toolnum, SHORT param)
param { 1 = tool diamter, 2 = ZOffset, 3 = xwear, 3 = zwear )

So that zoffset=(Insert correct VB code here)

Thanks
Phil

8
I am using this macro below and have need of some more functionality.

The problem is the Z length offsets are taken into consideration when it moves to the trigger point "NOT GOOD"

So i need to have the script use the current tool number in use and remove the Z length offset when it does the line

Code "G1 Z" &ZProbePos

The macro works only if the tool has a zero Z offset value stored in the tool table

CurrentFeed = GetOemDRO(818) 'Get the current feedrate.
PlateThickness = GetUserDRO(1152) + GetUserDRO(1153) 'Tool is 15.04 thick comp is .072 approx. 15.076
Code "G94"
ProbeFeed = 100 'You could put a probing feedrate here instead.


Code "G90 F" &ProbeFeed
Code "G49"

If GetOemLed (825)=0 Then
DoOEMButton (1010) 'zero the Z axis
Code "G4 P2" ' this delay gives me time to get from computer to hold probe in place, 2 seconds
Code "G31Z-5 F" &ProbeFeed
While IsMoving()
Wend
ZProbePos = GetVar(2002)
Code "G1 Z" &ZProbePos
While IsMoving ()
Wend
Call SetOEMDro (802, PlateThickness)
Sleep 150 'Pause for Dro to update.
Code "(Z Axis Is Now Zeroed)"
Code "F" &CurrentFeed
Code "G90"
Else
Code "(Z Setting Tool Is Not Working, Check Connection And Try Again)"
End If
Exit Sub


Thanks

9
PoKeys / Pokeys Disabled ?
« on: March 01, 2010, 06:15:03 AM »
When i have focus on the MDi line

The Pokeys is disabled "Spindle Button at least", is this fixable. ?

Phil

10
Machscreen Screen Designer / Best Screen desinger poll
« on: February 19, 2010, 02:34:56 AM »
Yes there really is a poll over on the general section

The link is here http://www.machsupport.com/forum/index.php/topic,14196.0.html

Come on guys we are losing at the moment  :o >:(  :'(

Phil

Pages: 1 2 3 4 5 6 7 8 »