Hello Guest it is August 08, 2020, 02:59:47 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - fxMach3

Pages: 1
1
VB and the development of wizards / code - while ismoving
« on: December 08, 2018, 02:35:12 AM »
Sorry for asking this, but the forums search only returns an error each time I search.

I have a script running with multiple code statements following each other, like (just a sample code)

code "G1 X200"
code "G1 Y300"

now it appears, that sometimes the milling path behaves unexpected and is not following the GCode, and I have no clue why.
I am assuming that this might happen because there is no while...ismoving loop between the commands.
The strange part is that in most cases everything works fine even with very long machine movements like 3000mm (5 seconds move)

So, my question would be, how MACH3 handles multiple "code" statements following each other. Means: what happens if I would fire eg 1000 "code" statements from a script. Will MACH3 handle the correct execution ? Do I need to take care about buffer size, or when do I need to place a while ismoving loop inbetween code statements with no other script statement between them ?

2
General Mach Discussion / feedrate 0 during program run
« on: August 26, 2018, 02:36:17 PM »
Hi guys,
i just read through a bunch of topics, but ... probably I am just too stupid :-) ... couldn't find anything regarding my problem:
We have 2 Mach3 driven wood cnc machines and a DMG and a HAAS for metal works.
At both metal machines I can do 2 things while a program (G-Code) is running:
1: Set the feedrate to 0, so the program "stops" but the spindle runs
2: Press pause, which causes an IMMEDIATE pause.

So I tried to setup any of the both options with Mach3, but somehow I do not find a proper solution.
If I override the feed rate in the feedrate DRO to 0, I get an error saying (cannot perform move with 0 feedrate) or similar
If I press pause, Mach performs the buffered moves before it stops (our wood CNC is 3m long...)
I know I can it the STOP button for an immediate stop, but there is no simple way to "restart" as (I assume) the path precalculation will also be interrupted and....there seems to be not option to automatically restart the spindle.

Hope this is written understandable enough :-)
Thanks for any help I can get.

3
General Mach Discussion / CSMIO / IP Probing fails
« on: June 11, 2018, 11:26:23 AM »
Hi all,
I just converted a shopbot CNC to MACH3. I am on the latest MACH3 version and running a CSMIO /IP as IO/Module.
So far everything works pretty well, except one issue, I am not able to solve.

I have a probe setup. It is active High (Just a simple touch plate which shortcuts via the tool). I have set up the Input for the probe in Input Pins. If I short the probe, I can see the diagnostic LED in the diag screen correctly. So far so good.
Now I added a button with a script to start touching off.

After some calculations of current Z, touch plate thickness and so on I get to move the Z-Axis:
Here is the simplified code:

Code "G1Z-20" (In reality this is a bit more sophisticated but to keep things simple...)
While IsMoving()
Wend

The issue I am having, is that Z is ALWAYS moving to -20, no matter if the probe becomes active or not. I can see in the diag screen that the probe becomes active while Z IsMoving, but the While/Wend loop is never interrupted.

Am I missing something ?

I read somewhere that this might be an issue when using the CSMIO.
There is a setting in the CSMIO plugin saying probe protection....no clue what this does

Appreciate any help :-)
Thanks guys !!!

Pages: 1