Hello Guest it is December 02, 2021, 02:52:01 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - davidimurray

Pages: 1 2 3 »
1
Modbus / Brains, Modbus & Spindle VFD challenge
« on: November 13, 2017, 04:15:14 PM »
I'm new to Brains and in the process of fitting a new VFD to my mill, which I would like to control with Modbus. I've got an USB to RS485 which I've successfully got working with Mach 3, both in test mode and also writing simple brains to send single commands to the VFD.

The challenge I've got is how I EStop/reset the drive.
1) - ESTOP
I've written a brain, that uses ENABLE 1 as an estop single, when enable 1 is false - the code 0002 is sent to the cmd register. This shows on the drive, but then changes to 0000 immediately. I don't understand why 0000 is sent as I don't reference it anywhere.

2) - Reset
To reset the drive, when the estop is cleared, I need to send 0080 (fault reset), then 0006 (drive ready), then 0007 (drive activated), all to the same cmd register in the drive, in sequence one after the other - the sequence being triggered by the estop reset. I've tried a few things but cannot work out how to send a sequence.

Any help would be greatly appreciated.

Cheers

Dave

2
Brains Development / Brains, Modbus & Spindle VFD challenge
« on: November 09, 2017, 04:12:47 PM »
I'm new to Brains and in the process of fitting a new VFD to my mill, which I would like to control with Modbus. I've got an USB to RS485 which I've successfully got working with Mach 3, both in test mode and also writing simple brains to send single commands to the VFD.

The challenge I've got is how I EStop/reset the drive.
1) - ESTOP
I've written a brain, that uses ENABLE 1 as an estop single, when enable 1 is false - the code 0002 is sent to the cmd register. This shows on the drive, but then changes to 0000 immediately. I don't understand why 0000 is sent as I don't reference it anywhere.

2) - Reset
To reset the drive, when the estop is cleared, I need to send 0080 (fault reset), then 0006 (drive ready), then 0007 (drive activated), all to the same cmd register in the drive, in sequence one after the other - the sequence being triggered by the estop reset. I've tried a few things but cannot work out how to send a sequence.

Any help would be greatly appreciated.

Cheers

Dave


3
General Mach Discussion / Shuttle Pro Jog Speed
« on: March 28, 2017, 08:02:57 AM »
Couldn't find any info in the search so apologises if this has been asked before.

Is it possible to set the speeds for each increment of the outer handwheel rotation. Currently it just seems to be a default %age with each move, but I would like to make it non-line - e.g. 5mm/min, 10, 25,100, 500, 1000

I can see how to change the increment for the inner wheel but not the outer.

Thanks

4
Have had a CNC Mill and Lathe that I converted to mach 3 / parallel port operation for getting on for 10 years. Mach has always been great and done everything I wanted. I am now looking at adding a few extra features and 4th axis to my mill and a toolchanger to my lathe so need some extra I/O. At the same time it would also seem an opportune moment to try and move away from the Parallel Port - but is there a solution that will do what I want?

Minnimum 4 axis stepper outputs
Plenty of digital I/O
Supports Lathe Threading
Support probing / tool setting.

USB or ethernet would be fine.

Any thoughts on what is out there. Had a look at Pokeys, UC100/300 Smooth stepper etc - but they all seem limited on what they can do.

Cheers

Dave

5
Hello

Having been running Mach for years one of my CNC PCs threw a wobbly (well windows to be precise!) and I've had to complete a fresh install of windows and Mach 3. I've now hit a problem that has got me banging my head against a brick wall! When I run the drivertest I get a good constant pulse and the system is described as excellent. However when I start Mach the first thing is it takes about 10 seconds before the screenset appears. Thne if i go into diagnostics the pulse timing i get a couple of seconds of timing at abround 25000 then a few seconds down at about 30, then back to 25000, then 30 ish and so on.

I've done a fresh install of WinXP following the optimisation guide on a clean drive, changed the graphics card and the ram, removed everything bar the essentials. The PC in question has happily run my mill for the past couple of years.

Any help would be much appreciated.

Cheers

Dave

6
Flash Screens / Flash Screens & Wizards
« on: October 23, 2008, 03:29:18 PM »
I'm just starting to get into flash and have just completed the tutorial videos and have been looking through the Mach Nation screens. Looking for somewhere to start, the idea of a few wizards came to mind so , as you may have guessed, my question is can you make Flash wizards?

Cheers

Dave

7
General Mach Discussion / Mastercam X Lathe Post Processor
« on: February 07, 2007, 03:30:03 AM »
Has anyone used Chris Krstanovics V9 post processor in mastercam X. Its behaving very oddly as for roughing work it is fine, however when I put a finish path in, all the arcs are in the wrong direction (but not in the roughing pass!!!). Anyone else had this problem or got a post that wrosk?

Cheers

Dave
 
 

8
G-Code, CAD, and CAM discussions / Mastercam X Lathe Post processor
« on: February 06, 2007, 04:51:38 PM »
Has anyone used Chris Krstanovics V9 post processor in mastercam X. It behaving very oddly as for roughing work it is fine, however when I put a finish path in, all the arcs are in the wrong direction (but not in the roughing pass!!!). Anyone else had this problem or got a post that wrosk?

Cheers

Dave

9
Feature Requests / Variable soft limits ???
« on: January 08, 2007, 09:08:51 AM »
Hi guys

Quite often I will turn up a one-off on the lathe, then part off and turn it round for facing. I will want to turn to a particular length, but I want to use jog as it is quicker than writing a program.

Would it be possible to have a variable limit that you could drive the machine against and it will stop without tripping any limits or anything like that.

e.g. I want to remove 34 thou
set 'soft limit' to Z-0.034
Jog to first cut e.g. Z-0.06
Jog to second cut Z-0.016
Jog to Third cut Z-0.029
Jog to fourth Cut Z-0.034 - machine won't go past this point.

Cheers

Dave

10
Feature Requests / Turn Graphics Stock Control
« on: December 15, 2006, 06:59:29 AM »
Hi Guys

Quick thought. Any chance that two controls could be added to control the stock definition in turn graphics? If possible it would be useful to control the two values of stock diameter and stock length independently and also to turn them to manual /auto automatically.

For example -
Currently the stock adapts itself to the toolpath.
For a turn wizard it would be useful to be able to control the stock diameter so it is the same as the parameters set by the user.
For some jobs it would be useful to be able to set the stock length to represent how much is sticking out of the chuck.
Some times you would want to do both above.
Other times you want it on auto, i.e. as it is now.

Cheers

Dave

Pages: 1 2 3 »