Hello Guest it is April 11, 2021, 07:05:31 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - jetrebel

Pages: 1
1
VB and the development of wizards / Help with a macro issue please
« on: June 15, 2017, 06:03:37 PM »
I have a macro working a 8 position ATC on a Boxford 160 lathe. The problem is that sometimes maybe every 8th change or even every 2 changes the X and Y fail to move to the safe position prior to the change but the change still takes place :o In the message screen it shows " cannot use G53 incremental Block = G0G53Z0.0000

I can't see this G53 code anywhere in the macro (below) Can someone offer up any suggestions to why this is happening?

thanks
Jason

'This macro drives an 8 position stepper driven ATC.
'It drives forward past a ratchet, then backwards a little to stall the motor
'The Y axis is setup for 20 steps per mm, my ATC requires 900 steps per index
'of 45 degrees.
'Because of the stall, steps are lost. So, we switch to INC mode for the ATC,
'then back to ABS mode before we exit.


'OEMDRO(1200) is utilized to store the last used tool (OldTool) and is updated
'upon final execution of the macro. This is resorted to as the Txxyy will overwrite
'the "CurrentTool" DRO.
'The Y axis is zeroed if tool is Number1, to prevent an overflow of the DRO after
'multiple changes.


'M6Start.m1s
Message ("macro running")

OldTool = GetOEMDRO (1200)
Tool = GetSelectedTool()
MaxToolNum = 8 'Max number of tools for the changer

If OldTool = Tool Then
Message ("Selected Tool already loaded")
Exit Sub
End If

While Tool > MaxToolNum
Tool = Question ("Enter New Tool Number up to " & MaxToolNum)
Wend

xval= getoemdro(800)   'get x
zval= getoemdro(802)   'get z
Call Dooembutton(138)
While IsMoving()
Wend


moveto = Tool- OldTool

If moveto<1 Then moveto=8+moveto

code "G91"   'inc mode

code "G00 Y"+Str((moveto*45)+5)
While IsMoving()
Wend


code "G00 Y-5"
While IsMoving()
Wend

code "G01 Y-2 F100"
While IsMoving()
Wend

code "G90"   'abs mode

NewTool=Tool
If NewTool=1 Then
Call DoOemButton (1009)      'zero Y
End If


Call SetUserDRO (1200, NewTool)
SetCurrentTool(NewTool)
code "G0 Z"+Str(zval)      'return to initial position
code "G0 X"+Str(xval)      'before tool change
While IsMoving()
Wend


2
General Mach Discussion / ATC won't move to safe position
« on: June 14, 2017, 05:00:37 AM »
I am using a macro from this site to work my ATC and I seem to be able to reliably change the tools using the T commands. The problem is that although the macro seems to show code to move the X&Y axis to a safe position nothing seems to happen. Could someone offer up any reasons to why this isn't happening?

I have cut and pasted the macro in it's entirety below.

thanks
Jason

'This macro drives an 8 position stepper driven ATC.
'It drives forward past a ratchet, then backwards a little to stall the motor
'The Y axis is setup for 20 steps per mm, my ATC requires 900 steps per index
'of 45 degrees.
'Because of the stall, steps are lost. So, we switch to INC mode for the ATC,
'then back to ABS mode before we exit.


'OEMDRO(1200) is utilized to store the last used tool (OldTool) and is updated
'upon final execution of the macro. This is resorted to as the Txxyy will overwrite
'the "CurrentTool" DRO.
'The Y axis is zeroed if tool is Number1, to prevent an overflow of the DRO after
'multiple changes.


'M6Start.m1s
Message ("macro running")

OldTool = GetOEMDRO (1200)
Tool = GetSelectedTool()
MaxToolNum = 8 'Max number of tools for the changer

If OldTool = Tool Then
Message ("Selected Tool already loaded")
Exit Sub
End If

While Tool > MaxToolNum
Tool = Question ("Enter New Tool Number up to " & MaxToolNum)
Wend

xval= getoemdro(800)   'get x
zval= getoemdro(802)   'get z
Call Dooembutton(138)
While IsMoving()
Wend


moveto = Tool- OldTool

If moveto<1 Then moveto=8+moveto

code "G91"   'inc mode

code "G00 Y"+Str((moveto*45)+5)
While IsMoving()
Wend


code "G00 Y-5"
While IsMoving()
Wend

code "G01 Y-2 F100"
While IsMoving()
Wend

code "G90"   'abs mode

NewTool=Tool
If NewTool=1 Then
Call DoOemButton (1009)      'zero Y
End If


Call SetUserDRO (1200, NewTool)
SetCurrentTool(NewTool)
code "G0 Z"+Str(zval)      'return to initial position
code "G0 X"+Str(xval)      'before tool change
While IsMoving()
Wend

3
Hi, I'm new here and new to CNC. I have a Boxford 160 TCL with a ATC. I have managed to, with help from here, get the spindle and steppers working but I'm completely stuck on the tool changer. This is the exact same lathe and tool changer as shown in the Mach3 Turn manual so I'm guessing there must be a macro out there somewhere I can use at least as a starting point to get this ATC working?

Also is there a tutorial on how to do this? I have watched the video on the Artsoft site but it doesn't really relate my lathe.

thanks in advance!
Jason

Pages: 1