Hello Guest it is February 26, 2021, 11:42:39 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - fatmanming

Pages: 1
1
Mach4 General Discussion / Spindle Issues
« on: November 25, 2020, 12:22:11 PM »
Hi,

I've got Mach 4 set up with the ESS Smoothstepper. 've got build 4517 and ESS build 260.
I created a new profile from the MachRouter with the wxRouter.set. I set everything up and encountered an issue with the VFD spindle.

If I try and start the spindle with the MDI or G Code using M3 it starts and then immediately stops. The green M3 button lights up. If I click the M3 button the green indicator goes out. If I then hit the M3 Button again the spindle starts at the correct speed as per the MDI M3 command entered.
Also if i start it with the MDI and change the spindle speed percent the spindle starts !!
Entering M3 or M5 then freezes the console.

I created another new profile and set up the ESS and just set up the spindle, it worked fine ? I then entered the rest of the inputs and outputs and it started the odd behaviour again.

I'm totally baffled as to why entering the rest of the settings would make the spindle behave in this manner, any ideas ???

2
Mach4 General Discussion / Motor position alarm
« on: July 27, 2019, 10:01:12 AM »
I've got servo's from DMM with the DYN2 driver. I'm using an ESS with a C25 breakout board. I've got the motors set up and working fine.
In the documentation I got sent it tells me to use Pin 8 of the DMM Driver connected to an input of the ESS to trigger an Alarm.

I've connected the Pin 8 Alarm output to Port 2 Pin 9 of the C25. I've set the pin to Active Low and named it MOTOR ALARM in the ESS pins config tab.

I'm not sure what to set after that to map it to an alarm in Mach 4.

Could someone please help me out ?

3
Mach4 General Discussion / Step pulse duty cycle
« on: April 19, 2019, 10:06:41 AM »
I'm running Mach 4 with an ESS smoothstepper. I'm having issues running a closed loop Nema23 at anything like a speed I expected. I've been advised by the supplier to change the duty cycle to 1:1. Can anyone advise how to check / change this in Mach 4 ?

4
General Mach Discussion / xbox controller joysticks wont step
« on: January 07, 2017, 11:50:15 AM »
I'm new to Mach 3.  :)
Got it set up with an Xbox controller. X,Y and Z jog on rapid with the Joysticks, no issues.
I've set the yellow button to change the Jog Mode from Cont to Step, which it does. If is use the keyboard when it's on step, it moves the amount I've set the step to, 0.1mm, which is great.
When I have it set in step mode, the joysticks on the Xbox controller still Rapid Jog.
Is this a setting I've missed or is that normal ? I've seen vids of people using the Step mode with the Xbox controller though !
I've looked through the forum and was not able to find an answer.

Pages: 1