Hello Guest it is July 30, 2021, 10:57:51 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Myk3

Pages: 1
1
General Mach Discussion / ISEL 3020 Conversion
« on: June 18, 2018, 01:47:20 PM »
I am fairly new to the build your own controller field.. I am converting a ISEL 3020 to Mach3 and I have the X and Y running but am unsure on how to calculate the microstepping and the section for motor tuning (Steps per, velocity, Acceleration, and Pulse). Is there a formula to use to calculate these?

The ISEL 3020 has  these motors installed.

I installed these drivers and this BoB.

video of the thing moving





Thanks for any advice..

2
General Mach Discussion / PWM Control of Laser
« on: March 01, 2017, 04:55:37 PM »
I got the laser install working with simple on / off, but now I want to get PWM functions to work.. I don't completely understand how PWM is supposed to be configured, I followed the instructions on the JTEC site to get it configured, but I do not think it is working right.. as when i enter M3 s1 I am still getting a high powered laser.

For some reason I could only upload 4 screenshots.. so i removed them and put everything in google drive and shared them below..

This is all my setting, that i think are required to enable PWM.. Thanks for the help.. Also in its current state the Laser does turn on / off with the M3 / M5 commands from MDI  / gcode, but in gcode i use the M11p and M10p commands to remove the delay..

https://drive.google.com/drive/folders/0B24uz5OgchgLQ0E1T0dla3FPdGM?usp=sharing

Instructions from JTEC..

https://jtechphotonics.com/?page_id=1436


3
General Mach Discussion / Mach 3 slows down at each point
« on: February 27, 2017, 11:22:51 AM »
I have just installed a jtec photonics laser on my machines and everything seems to be working well in some cases.. At first there was a delay with the M3 / M4 and M5 commands to start / stop the laser, I overcame that by using the M11p and M10p commands in the post processor. Now I am having an issue where mach 3 slows down at each point and I am getting over burn since it pauses ever so slightly at those points..

Setup:
Windows 10
Mach 3 R3.043.066
Ethernet SmoothStepper
Xylotex Controller with bob
ESS version ESS_Mach3_160630_u4f1b (when looking for the proper version ESS recommends MACH3 version R3.043.062 so I might install that version and try it)

I have the constant velocity turned on, and only the look ahead set to 200, as per a thread I found searching this issue.

Video of the issue
https://www.youtube.com/watch?v=oj1cRrwStDQ


Anything anyone can think of while I test the other version of Mach3?

EDIT: I just looked at a picture I took last night of the config screen and it looks like the only other CV setting I currently have the "stop CV on angle set to 0 degrees" 

4
I have one of these USB pendants, but I never use the "Spindle On/OFF" buttons and rather map it to a different function from within Mach3. I couldn't find it anywhere and I even went as far as trying to create a application to capture the F5 button press and then auto press the home button, which is from what I can tell happens.

Any advice on configuring the buttons on the device? There aren't any instructions that come with this thing..

Pages: 1