Hello Guest it is May 26, 2024, 11:44:05 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - cnc many

Pages: 1
1
Newfangled Solutions Mach3 Wizards / No tool table in nfl wizard
« on: March 10, 2016, 04:25:27 PM »
When clicking the select tool from table button in thw nfs wizard nothing happens.  I have an extensive list of tools including drills listed which works with g code programs but in the wizard I have to manually type the tool number and diameter.  When the code is uploaded into mach 3 the tool length  and diameter offsets work.  Any ideas about how to get it to work?

2
G-Code, CAD, and CAM discussions / Strange motion error
« on: December 29, 2015, 06:19:30 AM »
Hi
Well I was happy. Machine set up and motors tuned. Well thinks i. Let's test it
Clamp a stop, bring a dti up to it, zero move x 100 away bring it back. Still zero, great
Now to test for missing steps as in the manual ( same program as in the manual)

Set up a loop
Move x 100 move it back
Do it 5 times for a start. Will do more  loops later coz I'm new to mach 3

Curious when run the dti only makes contact at the beginning and end of the program!
Slow feed rate, look again. Yup, the x changes direction about 4-5 mm away from the stop, oh same at the other end of the gauge block
 Grrrr it shouldn't do that.
Hmmmm how much?  lets find out Do it in single step mode
Uh???  Very STRANGE. DTI NOW REGISTERS ON THE  STOP ON ALL REPEATS

this is all strange I went through the configs taking off anything which could affect it and run the program again and again to no avail

Any ideas, or am I doing somthing daft? 

3
General Mach Discussion / M3 M4 M5 spindle relay solved
« on: December 18, 2015, 08:38:29 AM »
Iv had a lot of problems getting m3,4,5 to work with the relay on my bob working on pin 14
And from the forums im not the only one

Output 1 activated
Pins set up and configures

It will trigger the relay with the screen button on main Mach 3 page and in the diagnostics screen etc
But nothing from MDI or g code files

Solution is so basic I could cry!
when setting up Mach 3 you are asked to set up profiles and not alter the generic profile
If you check c: mach3/ macros in the new profile they are all empty. But the mach 3 profile has a tiny bit of vb script in them
So you meanly copy these and paste into your own profile

Eg in M3 macro you need
DoSpinCW()

AND IT WORKS,!!
Ridiculously simple.   I struggled for hours on this and viewed 20 pages in this forum with no real solutions and found a few bits ov vb script solutions to a plethora of spindle problems wtih no simple solutions  but it's so simple

Have fun. Now the machine is truly finished!
So if Amy other Mcodes don't work you now know what to do!

Manny


4
FAQs / Missing pulse engine and drive test
« on: December 16, 2015, 07:41:33 AM »

HI ALL
Im new to this game
I had to upgrade from vista to windows 7 as it was impossible to get a lpt which would work most seem to be jumped up usb cards but its old technology
so i got a uc100 motion controller to work with it. The automated set up with this did not install the pulse engine and the drive test.
when i installed mach 3 under vista both were there

question is are these needed with the uc100
ta
Graham   ???

Pages: 1