Hello Guest it is February 07, 2023, 01:00:37 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - highpockets

Pages: 1
1
General Mach Discussion / ReConfguration EStop
« on: April 17, 2019, 03:02:25 PM »
I've had my CNC (running Mach3) for a couple of weeks (been traveling). All was fine the last time I used it.
Today I cranked it up, everything started as normal, but when I click on the reset button nothing happens. I'm not showing any abnormal light on the diagnostic page, when I press an EStop switch the Emergency light comes on and turns off when I reset the switch. I've also tested the limit switches, but no luck. I even ran Mach3 with a saved copy of the setting file just in case it got corrupted some how, but no joy.
I'm out of things to try HELP!!!!

2
General Mach Discussion / No Axis control on keyboard!
« on: January 15, 2016, 07:17:29 PM »
This one is strange, I need help!

I'm running Mach3 on a windows 10 computer. I've been running code all day with no problems, on the last project while running the first cut the two pieces of material I was cutting started to de-laminate (I didn't let the glue dry long enough). I hit the emergency stop switch to stop the run. I reset the emergency stop and now I have no keyboard control of the X,Y or Z axis on the keyboard or my CNC 4 axis USB remote control. If I pull up the jog shuttle in Mach3 (tab key) I can use the mouse and click on the axis + - buttons and the axis will move so I know I have motor control.

I've tried turning off the controller and computer and restarting, but no luck. I even tried installing a backup of the Mach3 configuration file, but again no success.

I'm at a loss on this one.


3
General Mach Discussion / Z axis Home?
« on: April 04, 2015, 04:08:23 PM »
I have my new CNC router up and running, it's a PDJ 2626 running Mach3.
I have ref home on X and Y working just as they should, but Z is another story. If I turn on Z Home in Port & Pins Inputs when I click on Ref All Home the Z axis goes down instead of up. If I reverse the motor then it zeros to the top but in operation the Z axis moves in the wrong direction. I've tried every setting I can think of I'm just missing something and need help....

Here are my configuration settings.





4
General Mach Discussion / UPS Power Backup
« on: March 31, 2015, 02:30:54 PM »
I've read through past posts about handling power glitches and outages some options seemed a bit complicated to me.

I've come up with a very simple solution to the UPS Backup issue that also takes care of the spindle.

Use a UPS backup to take care of the computer and control box. To prevent the Mach3 from continuing to run if the power goes out and the spindle isn't running I'm going to use a 12V transformer AC/DC converter plugged into a surge protected only outlet on the UPS. The transformer will be hooked to the coil of a normally open relay. The normally open switch of the relay will be in series with the other estop switches. When power is lost the relay will de-energize releasing the switch to open causing a estop in Mach3. To prevent very short power glitches from causing an estop you put a capacitor on the relay coil to hold it up for a brief time after power is lost (the 12V transformer I used has a built in capacitor that holds the relay up for about a second and a half). If power comes back before the capacitor bleeds down then the relay doesn't de-energize. See the attached schematic.




Pages: 1