Hello Guest it is December 07, 2021, 01:23:48 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - patface

Pages: 1
1
General Mach Discussion / Problems communicating with CNC
« on: July 19, 2014, 07:18:22 PM »
First things first I am a newb but not clueless and have tried a number of things to solve my issues but now I come to you for help.

So I bought a homebuilt CNC from a yard sale and everything seemed to work well.  I declined to purchase the computer they had hooked up to it because I already have several "beater" systems at home.  I get it home and find I have to use a parallel port, no biggie I go to newegg and purchase one.  Few days later it comes in I install it and hook everything up.  Now I can't get mach3 to communicate with the motors or the computer to communicate with the breakout board.  To be honest I'm not sure which.

Did some reading and figured out I need to assign the port and pins inside mach3 and I do so, after I search and search for info on my breakout board which had no markings of any kind.  I eventually find what I think it is, photo attached, and assign pins as directed by it's documentation, no dice.  I triple check my newly installed pci parallel card to confirm the port and it seems to check out.  I checked the bios and could not find any options there.  So now I am clueless and coming to you guys.

I will note I did watch the machine run at the yard sale so Im fairly confident that nothing is broken but who knows.

Windows 7 64bit
mach3, was given to me on a flash drive.  I am not confident it was not a pirated copy so after I hit post here I am going to uninstall and reinstall the demo version from this site and give it one more go.  I fully intend to purchase the full version once I get up and running.

Ask any questions you need

Photo I took of the actual Breakout board


Documention I found for the breakout board after exhaustive googling.


Parallel Info my Device Manager


Basic settings


Port and pins settings



Thank you in advance for any assistance.

Pages: 1