Hello Guest it is November 27, 2020, 06:39:35 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - HobieCat

Pages: 1
1
General Mach Discussion / CandCnc 5 axis (really a 4 axis) system problem
« on: October 28, 2013, 01:21:40 PM »
Hello,

I bought a 5-axis Bladerunner/MP3000 servo system recently to control a gantry system with a rotary feature on the head. Unfortunately their 5-axis system is not really a 5-axis system, it's a 4 axis system with a 5th motor driver that is connected to the same pulse output as the y-axis, so only 4 axis can be independently controlled by Mach3, the problem is that the Y and A(the slaved gantry axis) axis cannot be controlled independently so squaring up the gantry is my problem, they can't be homed(referenced) independently so any squaring has to be done manually, like by manually trying to loosen the pulley or power down the motors and move into place, then power it back up and hope it stays, each time the machine is turned on.

The people and CandCnc said that if I "used my head" I wouldn't have to square the gantry, or do it twice anyway, so the manual process shouldn't be a big deal, and none of their other customers have needed to square their systems, so that's their answer. Their manual points out the reasons why it's a good idea to have independent home switches on the gantry axis(to square the system), but when you buy their 5-axis system apparently the reasoning for having independent homing goes away and smart people don't need it, but I need it.

Does anyone have a workaround for this? Tom at CandCnc said that if I wanted a system that was a true 5 axis system I needed to buy a system from someone else, I will certainly accept his advice for the next machine but I'm hoping to use their system for this machine,  I'm hoping someone smarter than me or Tom has figured out an easy way to address this less than 5 axis homing problem.

Thanks!

2
VB and the development of wizards / VB macro runs when regenergating path
« on: October 09, 2013, 10:15:22 PM »
Hello,

I have a macro that has some JogOn commands called by my Gcode, each time I edit the Gcode and close/save it Mach3 regenerates the path and the macro runs, moving the tool around, but since the previous Gcode did not actually execute, it was just scanned for the path regen, the macro does weird/bad stuff.

Is there a way to inhibit the macro when the Gcode is just being scanned to regenerate the path? Is there a way to inhibit path regeneration?

Thanks,
Hobie

3
Hello all,

I have a few different computers running Mach3, they work pretty well. One is not working like the others though, but I can't see why. I have a process where I want to run a program that calls a macro and  the macro jogs around a little bit detecting various edges, but this won't work. Also, in single step mode I can jog the x-axis while the program is running, so after various lines are executed I want to hit the manual jog button (the arrow keys on the keyboard) and jog to a new x position. Two systems we have do this just fine, one Mach3 system won't allow this, on this one whenever the program is running (but paused) jog does not work, with the keys or with JogOn() in VB script. I think I set all the config setting that have something to do with jogging the same, no luck. I used the same XML file on different systems, the jog feature works on two of them but not the ONE.
I can't find any settings that seem to affect this feature on any of the systems, the systems that will jog while running always will, the other one won't, ever.

Thanks in advance for any info.

Hobie

Pages: 1