Hello Guest it is November 28, 2021, 04:58:52 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - robjeffking

Pages: 1
1
General Mach Discussion / Setting up a touch plate in mach
« on: September 29, 2013, 11:00:54 AM »
I have a 4848 zenbot that using 4 stepper motors (2 motors on the x axis)  The motor controller  a gecko 54 is using a db9 cable wired to 3 limit switches for homing.  Shaun over at zenbot set it up for me I would like to setup a touchplate but Im unsure how to proceed.  Im assuming the 3 limit switches are using 6 of the 9 wires.  With a continunity tester I can find the 3 unused wires
How do I proceed from this point in the mach 3 config screens Thanks Robert

2
General Mach Discussion / Importing gcode changes format
« on: September 26, 2013, 07:04:52 PM »
Im running all week making a owl project suddenly today all the previous code that ran fine yesterday is bad.  Im using VCP and Cut3d.  Zero the machine all manual jogging reflects the correct movement in scale everythings ok.  Load up some new gcode from VCP and the numbers in mach 3 DRO jump to 300 moving the axis manually the 300 numbers stay in that scale feedrates jump to 2000. (Im thinking Im losing steps) I load up some old gcode from last summer and the numbers and DRO's jump back to normal single and double digital numbers.  The machine cant be losing steps.  Ive restarted rebooted everything removed replaced good mach3 config file.  Thinking of reinstalling VCP and Mach 3 What is causing this software glitch?

3
General Mach Discussion / Jog/step shortcut key
« on: May 04, 2013, 12:28:32 AM »
I recently purchased this 33 key silcone keyboard to jog around while Im in my cnc room.  I know tab brings up the jog/step menu but I cant see the monitor is there a keyboard shortcut to toogle between jog and step for fine adjustments?  Will ctrl J toogle modes can kestrokes be edited in the config screens?

4
General Mach Discussion / port 1 pin 5 light on
« on: April 27, 2013, 06:51:39 PM »
I just got my zenbot 4848 up and running good.   Shaun (zenbot creator) installed my limit switches and sent my xml  lcustom  config file he wrote for my machine  he used a db9 cable for the connector between the switches and g540 controller.  When I start up mach3 I ref all home
it zeros out and everthing was great until I installed a longer db9 cable between the switches and g540.The cnc now goes to all three homes zero out but the x,y,z zero lights stay green.  I switched back to the shorter db9 cable but still have the same problem.I uninstalled reinstalled mach replaced the xml config file but nothing has fixed the bug.  In the diganotics screen port 1 light 5 led stays green.  If I disconnect the db9 cable the cnc works fine jogs around and zeros anywhere I tell it to just no limits.See attachements below for screen shots.  Everything is new cables, switches, g540 and cnc.(  Summing up  When I received my cnc Thursday everything worked and homed.  10ft db9 switch cable was too short replaced with new  25' db9 now port 1 light 5 stays on.  Switched back to orginal 10 ' db9 same problem  Start mach3 ref all home machine moves to zero  with x,y,z lights red untill they home  turn green stay green jog machine away from home but cant zero any new position.  Disconnect db9 everything works fine zero's anywhere I put it.

5
General Mach Discussion / Getting started config file
« on: March 21, 2013, 12:03:44 AM »
I have a zenbot 4848 and Shaun has sent me a config file for the 4848 in xml format Ive read the other post about xml but not sure it answers my question.  The config file I have is huge is there a way to import it to mach 3 for automatically configuring all the parameters?

Pages: 1