Hello Guest it is June 20, 2021, 08:44:14 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Kenneth

Pages: 1 2 »
1
Mach4 General Discussion / spindle pause
« on: February 19, 2019, 12:21:31 PM »
hi all,    i'm having trouble with the spindle starting and at about 20% it starts making the first XY movement
before spindle fully starts. if i start at Z zero, it scratches the stock. and it has a Z movement BEFORE XY
in the control configuration, spindle, checked = wait on spindle to stabilize to 95 percent. (was 90%)
spindle override delay; 1500ms ... (was 500ms)
THANKS for any help !

Mach4hobby ver. 4.2.0.4082

%
O0100
(PROGRAM NAME - SQUARE.NC)
(DATE - WED. 02/13/2019 ,TIME - 12:18PM)
(POST -  Mach3 )
(TOOL LIST)


T1 (1/8 FLAT ENDMILL - STANDARD)
G90 S4200 M03
G00 Z.2
G54 X0.1875 Y-0.1875
M08
Z0.2
Z0.1
G01 Z-0.1 F4.
Y-1.0625
X1.0625
Y-0.1875
X0.1875
G00 Z0.2
Z0.25
M05
M09
G90 Z0.2
G00 X0 Y0
T1
M30
%

2
Mach4 General Discussion / Mach4 SRO
« on: February 13, 2019, 09:53:39 AM »
i hope i'm in the correct discussion.
in mach4, the spindle area. is the SRO(bottom right in Mach4Mill) what i can set the spindle
RMP to or is that what the spindle is running as it goes thru the gcode ?
if i set an RMP, nothing happens and no readout is shown while code is running.
THANKS for any help !

3
Mach4 General Discussion / Buttons and the script/gcode
« on: February 11, 2019, 01:42:17 PM »
Hello all,
i'm new to mach4(fourth day) and looking to make a button that will make Z go to 0.2 and then
X and Y go to 0. that's it. i tried gcode but it doesn't like dat. and i'm even newer to script.
any help or point in direction would be greatly appreciated.
THANKS



Mach4hobby
win 10
64g
3.4g processor
24 ram

4
Mach Screens / Probe
« on: February 04, 2019, 12:45:01 PM »
Below is a script i made with machscreen v1.7. but it tells me the the command is too long and points to the block(first line).
hope someone can help me. Thanks


'probe on Z axis 
Probe = 1.89  'probe height
Depth = -1.5   'z negative travel 
Feed = 4
Code "G20 G31 Z" & Depth & " F" & Feed
While IsMoving()
Wend
SetOEMDRO(802,Probe)
While IsMoving()
Wend
Code "G91 G00 Z.2"
While IsMoving()
Wend
Code "G90"
End
 
 

5
Share Your GCode / Probe Script
« on: May 21, 2015, 05:50:36 AM »
below is the code i use to probe IDs. i like to know how to
use feed move. i want to be able to change the feed at the top instead
throughout the script. is this possible ? i tried Ffeed, but it laughed at me.
Thanks for any help !

NegMove = -10
PosMove = 10
Feed = 6


'probing = XY ID
'probe dia. = tapered till tip - - tip .104"
NegMove = -10
PosMove = 10
Code "G91 G31 F6 X"&NegMove            'X axis
While IsMoving()
Wend
SetOEMDRO(800,0)
Code "G00 X.2"
While IsMoving()
Wend
Code "G31 F6 X"&PosMove
While IsMoving()
Wend
Xdro = GetOEMDRO(800)
SetOEMDRO(800,Xdro/2)
While IsMoving()
Wend
Code "G90 G00 X0"
While IsMoving()
Wend                                   
Code "G91 G31 F6 Y"&NegMove            'Y axis
While IsMoving()
Wend
SetOEMDRO(801,0)
Code "G00 Y.2"
While IsMoving()
Wend
Code "G31 F6 Y"&PosMove
While IsMoving()
Wend
Ydro = GetOEMDRO(801)
SetOEMDRO(801,Ydro/2)
Code "G90 G00 Y0"
End
 

6
General Mach Discussion / plot not showing
« on: February 23, 2015, 02:26:10 PM »
i'm running mach3 R3.043.066 and can't get the plot to show on EITHER computer.
when it was before(i changed nothing). i tried different versions to the same effect. shows the table
but no trace whatsoever.
Thanks for any help !

7
General Mach Discussion / - fixture save...
« on: August 14, 2014, 11:27:46 AM »
i'm using mach3 r3.043.066.
it never ask me to save fixture. i tried with the option "optional offset save"
checked and un-checked. i created a button(122) so i can save it but would like
to make a safety so it would ask when i close.
 Thanks !

8
VB and the development of wizards / IsMoving
« on: January 21, 2014, 08:57:35 AM »
not sure i understand IsMoving. doesn't that mean when
ANY axis is moving ? i'm trying to get a ticker going and
the below only does the Else, not the If :)  hope that explains it.
i want the ticker to say something while the machine is motionless
and not say anything while any axis is moving.
Thanks


If IsMoving() Then
SetTicker(1 , "  Moving  ")
Sleep 2000
Else
SetTicker(1 , "       Raven Research")
Sleep 2000
End If

9
Brains Development / Pause Timer DRO
« on: November 27, 2013, 07:20:31 AM »
hi, is there a way to pause the run time DRO(814)? so if I pause the g-code, the clock
pauses as well. so I can get a better time length on a file.

also, I have movement LEDs for xyz. but they are slow to respond.
where do I save scripts so mach3 see em?
Thanks

kenneth

10
General Mach Discussion / machine coor dro not working
« on: April 30, 2013, 09:26:40 AM »
I had mach coor(83) and work offsets(178)dro working before.
now they don't change while running program. mac coor 84,85
and offset 179,180 work as should. upgraded to 1.57 Monday(29)
I fixed the strange reading on dro(83) by deleting and inserting again.
Thanks

mach3 Ver. R3.043.062
machscreen ver. 1.57

Pages: 1 2 »