Hello Guest it is April 17, 2021, 12:50:55 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - riphet

Pages: 1
1
General Mach Discussion / Spindle Setup Special Funtions ?
« on: March 26, 2014, 07:15:07 AM »
Hello,

About Spindle Setup Special Funtions with PWM Control:


1.-
Reading the manual 5.3.6.7 Special Functionm say:
"Use Spindle feedback in sync mode should be unchecked."

That's all, nothing more.
So I can not understand the purpose of that function,
I would like to know about this


2.-
About "sync mode"

look for this, and did not find.
I can not understand the sync mode,
I need a glossary with Mach3 terminology
I would like to know about.

3.-
About Special Function: "Closed Loop Spindle Control"
I seek to know the frequency, the time between each pwm update.
how often the pwm is updated?

How do I calculate the time (frequency) of PWM updates ?
I would like to know about.


4.-
Reading this forum, I found something opposite:

http://www.cjh.com.au/PWM%20Spindle%20Control%20using%20Mach3.pdf

Say:

"Do not use Closed Loop Spindle Control.
 
Selecting “Use Spindle Feedback in Sync Modes” tells Mach3 to expect feedback pulses from the spindle.
Selecting this effectively puts Mach3 into a closed loop mode."


Thank related information.
I appreciate your time and attention.

2
General Mach Discussion / Limit switch triggered. Which axis???
« on: September 15, 2013, 09:15:59 PM »
About this message "limit switch triggered"

I have the limit switchs NC.
Debounce interval 500 (then increments 250)
My last setup Debounce interval is 2750. Is that enough?

Something I want to know is:
Specifically. Which axis is the trigger?

The message "Limit switch triggered",
NOT SAY to me, the switch triggered.

That I can do to know the trigger axis?

I appreciate any related information.





3
Hello,

I want to know that is all that is needed to make a Smoothstepper with Arduino Mega2560 with ethernet shield.

PC with Windows XP and Mach3 working fine. Check.
Arduino Mega 2560 board, cables and connectors. Check.
Mach3 SDK.2.62.zip Check
Microsoft C++ Check
Library.h to drive step motors with acceleration and deceleration, multiple simultaneous steppers, etc. Check.

Know how to do it,  -NO CHECK-

Found sample code?

I appreciate any related information.

4
General Mach Discussion / Keygrabber deafult.grab file
« on: May 02, 2013, 07:42:55 PM »
Hello,

I lost my "installation file default" of keygrabber.

I need see the file Default.grab (Default).

I not have other PC to install the Mach3 and get the file default.

You can send me this one?

I appreciate your time and attention.

5
General Mach Discussion / Spindle PWM acceleration and deceleration time?
« on: February 13, 2013, 08:57:06 AM »
I setup the Spindle PWM and work.

But I wonder.
Why PWM signal does not accelerate or decelerate?

When I switch to M3,
immediately sends pulses of "S" (speed), without accelerating.

When I turn to M5,
immediately turn off the pulse train.

Mainly I'm interested in accelerating the switch.
for example with M3S15000

When I change M3S12000 speed, M3S14000, M3S16000 ... changing the pulse train without acceleration.

It is normal that sends Mach3 PWM signal without acceleration?

What I look for is a soft start motor.

6
General Mach Discussion / Accuracy in Ref All Home
« on: January 08, 2013, 02:21:14 AM »
Hello,

I have practiced repeatedly some tests with AutoZero macros.

He concluded that:
Ref All home, in relation to the probe gage block,
presents a random error up 0.0150" / 0.381mm (+/-)

This happens when I turn off the step motor
and Ref All Home, before running the macro AutoZero.

My question is:

With limit switch and Ref. all Home,
How I can get maximum accuracy in Z axis?

1. - Some settings?
2. - Some macro / script especially for Ref all home?


7
General Mach Discussion / Define location of zero in Z axis, in milling.
« on: January 05, 2013, 05:03:37 PM »
Hello,

I'm a newbie and I just made all the limit switch work to perfectly,
thanks to the valuable support received in this forum (thanks Hood).

My machine is milling type, three axes, MDF table below, router above.

I purchased the system Craftman QuickRout (Router Bit Connector/Adaptor Kit),
and like update the compensation tooltable for bits of varying heights.

I do not want to destroy my bits.
I do not want to damage my machine.
I do not want my bits drilled base table.

I think about security,
and let me know your experience,
Where it is recommended to define the machine location of the zero z axis?
Limit up or limit down?

So also would like to know why up or down.
I have intention to cut materials of various heights.
My prejudice tells me zero down is better, I not sure.

I appreciate any related information.



8
General Mach Discussion / Ref all home details with reset and auto zero.
« on: January 02, 2013, 07:59:01 PM »
Hello people,

I'm a newbie, using the demo version R3.043.066
I'm wiring a CNC machine limit switches.
The machine is three-axis.
The X axis with one motor
The Y axis with two motors (A slave)
The Z axis with one motor

The input signals:
X++,     enabled, port 1, Pin 10, Actived low X, Emulated, HotKey 0
X--,       enabled, port 1, Pin 10, Actived low X, Emulated, HotKey 0
Xhome, enabled, port 1, Pin 10, Actived low X, Emulated, HotKey 0
Y++,     enabled, port 1, Pin 11, Actived low X, Emulated, HotKey 0
Y--,       enabled, port 1, Pin 11, Actived low X, Emulated, HotKey 0
Yhome, enabled, port 1, Pin 11, Actived low X, Emulated, HotKey 0
Z++,     enabled, port 1, Pin 12, Actived low X, Emulated, HotKey 0
Z--,       enabled, port 1, Pin 12, Actived low X, Emulated, HotKey 0
Zhome, enabled, port 1, Pin 12, Actived low X, Emulated, HotKey 0
A++,     enabled, port 1, Pin 13, Actived low X, Emulated, HotKey 0
A--,       enabled, port 1, Pin 13, Actived low X, Emulated, HotKey 0
Ahome, enabled, port 1, Pin 13, Actived low X, Emulated, HotKey 0

In the diagnostic screen: I see the Input Signals current state all work fine.

Then when I click the "Ref all home" button.

...Press Reset... Emergency Mode Active...
Limit Switch Triggered


After that.

I proceeded to disable the Z++ and Z--
...and hurrah, the "Ref all home" continued with the Y axis.

Then the Y axis work very well with the three signals
"Y++", "Y--" and  "Y home".  All signals enabled.

...and the "Ref all home" continued with the X axis.

Then the message again:

...Press Reset... Emergency Mode Active...
Limit Switch Triggered


I proceeded to disable the X++ and X--
...and hurrah, the "Ref all home" continued until completion.

In the home/soft limits: I check enabled the Auto Zero in all axis.

Then the questions:

1.- Why not run the X and Z axis auto zero returning?
(M3Home and M1Home is on in diagnostics screen)

Note:
The Y axis work fine with the three signal Y++, Y-- and Yhome
and not active the Emergency Mode y run the autozero returning.

The only thing I find different is that the "Y" axis has slave "A".

2.- For safety on my machine. Like the Y axis.
I want to activate the signals Z++, Z--, X++, X--.

without triggering Emergency mode active, like the Y axis.

How to configure this?


I have thought that it is a software error Mach3

I can fix with wiring, but sought a solution with Mach3



Any case appreciate any related information.

I appreciate your time and attention.

Pages: 1