Hello Guest it is March 04, 2021, 07:41:03 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - turmite

Pages: 1 2 3 »
1
Hello all,

I now have a good stable working M6 macro and need to start using it. To do this I need to be able to see the tool length offsets and have discovered there are several different methods.

I could use some guidance in this area. 

Mike

2
Mach4 General Discussion / Trouble with M3 and spindle speed
« on: January 31, 2018, 11:52:55 AM »
Is anyone using the Mach 4 6 axis screen and having trouble with turning the spindle on using M3 and a speed number, ie,

M3 S5000

I have that in my code and have placed it as the first line and also the second line after the initial move. The spindle will not come and the gcode will not advance until I hit the start button again. Spindle still doesn't come on but the code runs and I can start the spindle by hitting the M3/M5 button.

I will post the actual code as soon as I get to the shop!

Mike

3
Mach4 General Discussion / M03 yes, but no M05
« on: November 04, 2017, 02:25:21 PM »
I am about finished with the retrofit to my Onsrud router using Mach 4 and the Vital Systems Hicon controller! I have a problem and do not know how to fix it!

I can use MDI with the command s2500M03 and the spindle comes on like it should! I then enter M05 and the spindle will not stop! I have to hit my disconnect
to get the spindle to stop!


4
When trying to home my tool carousel, the Mach 4 dro's show the process, but the carousel itself does not move!

I can jog and move the carousel by mdi input! The home sensor shows up on my Hicon controller as well as in the Hicon diagnostics page!

I have 6 sensors used in the tool changer on this machine......carousel in position....home.....tool index, (reads each tool position as the carousel
rotates, tool in position, drawbar up and drawbar down! None of these sensors lite up in the Diagnostics screen when they are active! They
show up on the Hicon controller and on the Hicon diagnostics page.

My other axis's home sensors and overtravel limit switches all show up on the Mach diagnostics screen when they are active!

I am at a loss!

Mike

5
HiCON Motion Controller / Mach issue or Hicon??
« on: August 12, 2017, 06:45:24 AM »
I am very close to having my retrofit done but have encountered a problem that I cannot find the answer to and do not know if it is Mach related or Hicon related While doing the Mach 4 config, I did not set any of my homing offsets and on searching, cannot find a place to set them in Hicon! When I jog, mdi or reference individually or ref all, every axis except the tool carousel offsets and the only one I have really paid attention to is the y axis since it is the only axis that is used other than the carousel to do a tool change!

I made sure the home on index pulse tic box was unchecked to take that out of the loop for now. I still get offset on homing and the home offsets have not be set in config@ Now we are not talking offset enough to get off the sensor! The y axis measures  -.178"

Anyone?

Mike

ps I have other issues but will post each separately!

6
Mach4 General Discussion / Mach 4 6 axis screen set
« on: May 30, 2017, 05:01:45 PM »
Is there a Mach 4 6 axis screen set available anywhere?

7
Hi all,

My name is Mike Turner, a long time member but just now getting back into cnc work. Shut my business down to care for my wife who was battling cancer and she lost that battle in Feb of 2011. Took some time off but now trying to start the business up again with better equipment. Bought a used Onsrud router, moved it to my shop and the controller died on me.

I have been battling this retrofit for two years and I need some help to get this finished.

1. I need an electronics guru specializing in cnc that can me with a couple of schematic problems.

2. I have several questions about Mach4 and it's intregration with Vital Systems Hicon Integra controller!


Mach questions to get started.

1.  I know from having used Mach3 for many years that you can use all the limits wired in series on a single pin and that saves some input spots. Can you do the same with       homing sensors and then home the machine one axis at a time, or maybe some other sequence. I will always want to home the Z axis first!!!!

2. When using the Hicon controller to control the spindle, is Mach still involved in the process, i.e. setting speeds, changing tools etc

3. Hypothetical question.......would it be possible to use 3 separate safety circuits all wired in series but not connected on the single E-Stop pin? This would include overtravel limits, edge switches on the tables, both front and rear, and vacuum loss? Would any one of the circuits being tripped constitute an E-Stop situation?

8
there is always that except isn't there? I was finally forced to move to Mach3 and am now using an Ethernet SmoothStepper. This has been a saga of failure upon failure and I won't go into them except the one.

I have my 4th axis set up as angular and motor tuned with correct units per to get a correct 360 rotation with mdi  !!! My problem is I cannot get Mach to recognize my reference switch set as a home only, or even if I set it as a limit. I have tried the switch as hi and lo, the switch as nc and no. The bob led blinks as the switch is activated when the shaft moves by it, but that is all. Is does not stop to reference nor does it stop if I set the switch as a limit switch.

I am homing/reffing in the negative and have to move a touch in the negative to get off the switch. I have not thought to home in the positive. Would that help me with this?

Mike

9
General Mach Discussion / G31 probing via array macro.
« on: November 04, 2007, 03:36:20 PM »
Calling Terry Parker.

Hey Terry here is the thread for digitizing. I will post the image of the guitar in a little while, but wanted to get this up and started.

Mike

10
General Mach Discussion / Screen 4 for Mach3
« on: November 01, 2007, 11:29:11 AM »
Hi all,

Art, Terry Parker and I have been having a discussion over on the Yahoo group about 3d probing in Mach3 with me being the guy that needs help. Terry has given a discription of a screen that he has made in the past that would be of great use to me, immediatly, but I believe to many others as well. He offered to give the screen to me but said that the screen designer is scrambling his screen when he tries to save them.

Is anyone having success with saving screens? Art just posted that he had updated Screen 4 and hopefully this will solve the problem.

Now my begging begins. :'(  Below is a cut and paste from the Yahoo thread with the description of the screen Terry is telling me about:

"Mike another trick we use is to set up a page in mach for probing.

Place 4 buttons on the page and assign a directional probe move(macro
starts from the current position, probes in the direction assigned
and then returns to the starting position) in each primary direction
IE: n s e w

Place two more buttons on the screen one to open the points file and
one to close the file.

Then you can open a file, jog around to get into position and push a
direction button to probe in that direction. Then jog into the next
position and press the proper direction button again. When you have
collected enough points then close the file."

Anyone want to take a shot at this screen? I promise you if I had the ability/knowledge I would not ask.

Mike

Pages: 1 2 3 »