Hello Guest it is January 20, 2021, 09:51:58 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - jasminder

Pages: 1
1
General Mach Discussion / Mach3 VS Other motion controller for stability
« on: September 02, 2012, 02:56:07 PM »
Hi guys,
Long time since my last post. I need a suggestion from the experienced here (hello Hood)

Well, i have been using mach3 for the past 2 or 3 years on my DIY lathe (but it hardly ran for ~500 hours or a month if calculated precisely)
I love mach3 for its ease of use, simplicity and features except the stability (the unknown error triggers, system hangs etc)
but i am now going to make another CNC for commercial use and need a more stable control that won't crash or hang all the day long.
Should i go with some commercial CNC controls like Fagor or GSK (i want to keep the price low) or these new CNC lathe software + hardware combo are of any use? (planet cnc, USB cnc , Probotix USB CNC etc) They don't use Mach3 and have their own brains.
I want to know if you have any experiences with any of these (i was thinking about Mach3 + smoothstepper but i read that the setup is still not stable enough).
I contacted Mach3 support and the reply was "Mach3 is what it is for now".
I am double minded about this controller thing. Please put some light (i am afraid i will spend 2000$ on a commercial control and end up frying it's inputs and outputs maybe) I just need to control 2 axes and a turret. No fancy features are needed.

Jasminder Singh

2
General Mach Discussion / mach 3 going mad. Should i try turbocnc?
« on: November 19, 2011, 01:14:08 PM »
hello folks,
this mach3 thing is bugging me now. My pc was restarting without giving any errors or beeps so i got a new one that worked well for a couple of months and now the same situation. It is also restarting automatically when running mach. It behaves strange sometimes. For example, it automatically starts the spindle or the cycle start button even if i haven't touched their external buttons. When i saw the diag screen i see that the spindle output is not active still the spindle relay was on.

I think that too much conductive dust is shorting my pc's board or lpt ports. But i regularly use air blower on it when i am going to turn on the machine. BTW i am planning to give turbocnc a try. Mach3 is just bugging me. I want a very stable cnc controller that should keep working as it is configured (at least for a couple of months) could it be the  noise from the electronics like PSU, stepper drivers etc??

jasminder singh

3
ok,
i got my new pc wired up. The jog keys are working, the inputs/outputs everything is okay. Spindle runs good, flood, mpg is also fine.
But my new pc goes mad sometimes.
1--When a tool is called, it doesnot give the output signals to the turret controller board sometimes.
2-- it sends the two output signals pin 14 and 16 sometimes when not needed. (i have used the pin 14 and 16 for jog mode indicators and two leds are driven from these ie: mpg or continous mode) usually one of them should light up. when it happens, i have to reset mach to get it to work again.

what's wrong with my new pc?
Hood, where are you? ::)

with thanks.
jasminder singh

4
hello friends, (again)
the problem started yesterday when my PC restarted automatically and the same is happening randomly. I guess it is a thermal trip.
okay i know what to do. I opened up the heat sink, and there wasn't any thermal paste. I cleaned the things then put the heat sink back on the processor.
Now it ran for around 2 hours then again a thermal trip and restart. i touched the heatsink and it was warm. (i guess that processor was too hot that time because the outer fins were warm and i am sure it was more hot on its center.
 
my question is "how much ram does mach3 turn can eat and how can i get rid of this thermal trip" It has a P4 2.5ghz processor and 512 mb ram.

thanks in advance,
jasminder singh

5
General Mach Discussion / mach3 turn icon opening the mach3 mill everytime
« on: September 05, 2011, 12:23:55 PM »
hello friends,
i was running my lathe for days and suddenly my pc restarted and after that whenever i open mach3turn.exe icon on my desktop, it always launches the mach3 mill.
I have tried using the mach3 loader also but i am failed to launch mach3 turn. what's wrong with the system. Do i need a reinstall of mach3? i am feared of loosing my settings.

jasminder singh

6
Hello friends,
i want to control mach3 totally from external switches so obviously, the inputs and outputs of 2 ports are not enough. The one solution is modbus i guess.
I know a little bit of uC programming and use of their i/O and want to know where should i start with mach3 modbus. I want to know how it works and what are the limitations of using it. Can just two pins on the port can create a way between 20 switches and mach3?

i don't have any prior knowledge about serial communication. I don't even know if there is any difference between modbus and serial com.
Any help from there?

regards.
jasminder singh

7
General Mach Discussion / mach3 estop external switch issue
« on: August 03, 2011, 01:11:37 PM »
hello friends,
i just added external switches to my lathe (mach3) including an estop. Everything just works fine. When i push the estop button, the mach enters into reset mode but when i twist or unlatch it, the mach still remains in estop mode and i have to click the reset button on mach3 screen using my mouse to get to the normal mode.
Where is the problem? I have wired estop as active high and my switch is NO.

hope someone has an idea out there.
regards,
jasminder singh

8
General Mach Discussion / mach 3 turn thread pitch changing
« on: April 23, 2011, 01:18:57 PM »
hello friends,
i am a beginner to mach 3 threading. i am using g76 thread cycle to cut 0.750 inch long thread 1/4 bsf type.
Internet says that the pitch for the thread is 0.039 inch. But when i began to cut thread, 0.052 pitch matches the taps i have of 1/4 bsf thread.
i am running the spindle at 900rpm.

The problem begins after a couple of hours of run when the spindle looses some rpms due to thermal expansion. it reads 890 now and the pitch of the thread changes.
Whrere is the problem? a friend at cnczone said that it is longitude gain problem and i should use cut/rev mode. But i am already using it in the beginning of the program.
ex:
t0101m6
gox1 zo
g95
m3s900
g76 x0.950 z-1 blah blah blah

where could be the problem?
I am scraping a lot of parts that i make after an hour of run of the machine.
thanks hood in advance for the previous and future help.

jasminder

9
General Mach Discussion / mach3 turn lathe spindle stalls
« on: March 16, 2011, 02:47:58 PM »
friends,
i am having a very old problem i am fed up of. My lathe's spindle stalls when using a parting off tool. I can set any rpm using the s word in mach3 turn But it seems that mach3 is not synchronizing the speed with its output. i think that the freq on the VFD shud increase when load is put on the spindle and mach should regain the rpms it is set for. Am i right?

thanks in advance for your help,
jasminder singh

10
hi,
i am jasminder singh from india. i just built a cnc lathe running mach3 with a pci parallel port. here is build log on cncnzone:
http://www.cnczone.com/forums/mini_lathe/107017-10x7_home_made_cnc_finish.html
 
i am getting a strange problem.The spindle dro is not working in mach3 turn. the index led blinks in the diagnosis screen when moved with hand slowly it means that mach is receiving the index pulse. but why no rpms are show (just 1 is displayed)
The spindle speed is chaning when jogging the z and x of my lathe. Spindle slow downs when axis moves towards the chuck ( same is with both x and z axis). Please suggest. I have tried reinstalling mach3 (2.0somthing version) and changing the debounce and index delay too.

many thanks,
jasminder singh

Pages: 1