Hello Guest it is August 06, 2020, 08:34:56 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - rickinbeachcrest

Pages: 1
1
So I have been using Klaus's camera plugin v 2.14b for years now.  I decided to upgrade to ver 3.09.  Things are working good except for one issue.

 How long does it take to bring up the video window?  At the longest, it can take up to 8 seconds.  Sometimes it will take only one second.

 I'm using a Logitech webcam.  I have updated to the latest drivers.   Using Logitech's webcam software, the video window only takes about 1-2 seconds to pop-up.

Klaus has written a great tool for Mach users.  I have really come to depend on it in all my cnc work.  Thank you Klaus.

Thanks everyone for any insight into this.
Rick


 

2
Mach Screens / Basic Screen
« on: April 14, 2018, 01:53:28 PM »
I started a couple of years ago by cobbling some buttons on the original 1024 screen, removing a lot of the things I didn't need and adjusting the DRO's.  The screen was functional, but not much to look at.  I wanted to wait a while to make sure there wasn't anything I was forgetting, before designing a new screen.   This screen is just for my use, so  I didn't need to clutter it with things I didn't need.  It is used on a router I made using 8020 type extruded aluminum.  The cut envelope is about 18" X 18" X 5". 

I designed this screen in Photoshop CS (old, but very functional).  In the upper left is the G code window and in the upper right is the toolpath window.  I used Screen4 and Klaus's video plug-in.  Thank you Klaus, I use your plug-in every time I use the machine. 

The Step/Cont.(continuous) button toggles between jogging by step or continuous and the LED will switch from side to side. I have the space bar set as the hot key to toggle between step and continuous.   The increment button will toggle between .005" and .01" per step.  Most times I will have it set to .01", but sometimes I will toggle to .005". 

The Camera ON/OFF  button turns on Klaus's video plug-in.  The Set button will only set the off-set when the camera is on.  After pressed, the red LED on the button is turned on.  This way I know that the button was pressed. 


Hopefully this will give some ideas to anyone thinking of making their own screen. 


3
General Mach Discussion / Underlined DRO's
« on: March 25, 2018, 03:14:53 PM »
This is kind of a strange one.
Just finished a new Screen and all of the DRO's are underlined.  But on the computer I was designing and testing the new screen, there are no underlined DRO's.  And on the computer running the CNC, the old screen set did not have any underlined DRO's. 

I'm using R3.042.040

I can live with it, but the rest of the screen looks so good.

Thanks for any help.
Rick

4
I do a fair amount of wood working and many times I need a simple cut, that is not doable on the table saw or radial saw.  The router is the tool of choice for these occasions.  What I normally do is clamp a straight edge (piece of wood, generally) for a guide and use a straight bit with a bearing.  And then it occurred to me that it would be so much easier doing this on the CNC router.  I just need a wizard to make this happen.  I feel reasonably confident that I could make a wizard, but want to make sure that one does not exist, before putting the time into making one.

Does anyone know if a wizard like this is out there?

Thanks.
Rick


5
Mach Screens / Where are button scripts stored?
« on: December 20, 2016, 09:50:22 PM »
I edit and create screen sets on one computer and then copy the screen set to the cnc controller computer.  I have to copy and paste the button scripts from a text file that I copy over to the cnc controller computer.  This is faster than re-typing  the code into the individual button script editors.  If I knew the file that contained the button scripts,  I could just copy this over with the .set file for the screen set.

Thanks for any help.
Rick


6
Screen designer tips and tutorials / Where are button scripts saved?
« on: February 06, 2016, 04:12:56 PM »
Can someone please tell me the relationship between button scripts and  the .set file?

I have made a new button script on one computer and want to migrate it over to the cnc machine.  I copied the .set file but the script did not move over.  In this case I just retyped the script since it was only 5 lines. 

Thanks.
Rick


7
General Mach Discussion / OffLine quesiton
« on: December 29, 2015, 10:34:35 PM »
I think I know the answer, but I would like to know for sure.

Will I loose my position if I press the off-line button?

The job finishes, I jog the spindle out of the way, then press the off-line button,  remove my part.  I will usually go to the other side of the shop to get ready to run another part,  examine the part just finished, or clean up the part I just took off the machine .  So I get back to the machine, load the next piece, press the off-line button (putting it back on line) and cycle start.

Some thing tells me this is not the correct use of the off-line button.

Thanks.
Rick




8
Mach Screens / Odd behavior with jog button
« on: May 05, 2014, 01:29:00 PM »
Maybe someone can tell me what is happening with this screen set.  In the interest of stream lining my screen I am removing some of the buttons and making other minor modifications.  One of the things is that I only use from the Tab (MPG mode) is the jog step and continuous.  Occasionally I will change the step distance, but not often.  So I thought I would put these couple of items on the program run screen. 

I also wanted to reduce a little more of the screen clutter, so I removed the Jog ON/OFF button on the program run screen.

So everything worked (or at least looked like it did) until I tried to run it on the router.  As soon as I pressed the Step/Cont. button I placed on the program run screen, the jogging stopped working. 

I found the Jog ON/OFF button on the Offsets screen and toggled that off and on, and the jog worked again.  If I pressed the tab from the program run screen and used the  Jog mode button, it worked as it should.  But if I pressed my new button, Step/Cont., the jog stopped working.  Going to the Offsets screen and press the Jog ON/OFF, everything worked again.

My solution was to move the Jog ON/OFF button back to the program run screen.  Now my new button on the program run screen works just as it should.

Now why does not having this button on the program run screen, inhibit the Jog Mode (OEM code 245) from working?

Thanks
Rick

9
VB and the development of wizards / toggle camera plugin on and off
« on: March 15, 2014, 05:18:42 PM »
I have a button for turning Klaus's camera plug-in ON. (Call SetUserLed(1102,1) ).  And this works great.  What I would now like to do is use the same button to turn the camera plug-in OFF. (SetUserLED(1103,1) )

I could use a simple IF/THEN/ELSE if I had a way of determining if the camera plug-in was OFF or ON.  I could set a variable to "ON" when the camera plug-in was ON and set it to "OFF" when it was OFF.  But I would need a way of setting this variable at the start-up of Mach3. 

Thanks for any help.
Rick

PS.  This is a great camera plug-in,  by the way.  It's supper easy to set-up and works real well.  A big Thank-you to Klaus.

10
General Mach Discussion / PCI parallel port problems
« on: February 07, 2011, 06:49:20 PM »
Well I am pretty sure I am having problems with the pci card.  It is the same one mentioned in this post (the Roswell RC304)
http://www.machsupport.com/forum/index.php/topic,11300.0.html

I have downloaded the latest drivers for it.
I have got the port address set in Mach to E800.  I have set the e stop to active low and have the e stop jumpered to ground on the Gecko g540.  When I go into Mach, the reset will not clear the e stop error condition. 

When I go to the diagnostics screen in Mach, on the port 1 pins current states, Pins 5,6,7,8 are high (led is on).  If I jog, nothing changes on these pins.

I have not tried connecting the steppers, since I think it would be unproductive at this point.

Any help would be appreciated, as I am out of ideas.  Short of getting another pci parallel card.



Thanks.
Rick

Pages: 1