Hello Guest it is October 16, 2019, 01:25:43 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Aidan

Pages: 1
1
General Mach Discussion / Encoder input for Mach 3
« on: September 06, 2010, 10:09:55 AM »
Hi all,
I hope someone could kindly provide instructions on how to setup an encoder input in Mach 3 Mill.
I have searched the forum, but am still unclear on how to do this.
The encoder I'm using is a 1 ppr Hall effect encoder (http://radionics.rs-online.com/web/search/searchBrowseAction.html?method=searchProducts&searchTerm=715-134&x=25&y=14) on the end of my spindle shaft.
It outputs 1 pulse per rev (a/b =50+/- 20%)....Shaft speed is generally 500 - 3000 rpm.
Motor speed is controlled by an external dc drive with a pot setting the speed.
I am unsure of the steps to take for the DRO to indicate the true speed.
Many thanks,
Aidan

2
Hi all,
I hope someone can offer me some advice. My Heiz Microstepper controller failed 20 mins into a g-code routine - back and forward x axis translation, repeat 50 times.
I am running Mach 3 with an opto-isolation card and the system has been working fine to date.
The main power indicator is lit and Mach 3 responds when I press the E-stop buttons, so the stepper driver board is apparently okay.

The fans aren't turning & no power to my stepper motors so it appears that the issue lies with the supply voltage circuit board.
The circuit diagram is located at this link: http://cnc-step.de/images/attachments/Downloads/Betriebsanleitungen/stepcontrolhy_eng.pdf

On closer inspection two Vishay BY500-800 Soft Recovery Fast-Switching Plastic Rectifiers were lying loose on the supply voltage board.
Not connected. The solder on them appears to be melted. Any ideas what could have caused this? I'm not an electronics expert unfortunately, but hope to get the assistance of one next week.
I'm waiting to hear back from Heiz support - they're a German company and I own a S-700. However their forum isn't very active.
Any input would be fantastic!
All the best,
Aidan

3
General Mach Discussion / Opto isolation / frequency query
« on: April 23, 2010, 01:15:45 PM »
Salutations all!
This is my first post...though I've searched the forum lots for a similar issue that I'm facing. Mach 3 is pretty awesome - using it to interface with a Heiz S-720 and the supplied microstepper motor controller.
Anyhow, working fine so far, but I'm having problems setting up a opto-isolation BoB..which I got shipped from Sunrom: http://www.sunrom.com/index.php?main_page=product_info&products_id=81
So the issue, I think (the board is working fine), is that its optocouplers has a max clock input speed of 20 khz. Is it possible to configure Mach 3 to run at this frequency or is there a workaround?
In hindsight I should have opted for the model 1117, which maxes out at 10 Mhz, but it'd already just shipped. My application doesn't call for very fast speeds, but a BoB is a must.
Cheers,
Aidan

Pages: 1