Hello Guest it is December 03, 2021, 09:11:59 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - LongRat

Pages: 1
1
SmoothStepper USB / Config problems - FTDI USB Driver Error
« on: November 18, 2011, 10:44:10 AM »
Tried configuring my SS with the lockdown version of Mach (3.043.022) and the latest dev version (3.043.053) with the same result each time.
When I try to OK the SS configs in Mach (setting controller freq and axis step freqs etc) I get an error:

SmoothStepper_v17efb
Error returned from USB function FT_Write.
Error: FTDI USB Driver Error

Error = FT_INVALID_HANDLE

Bytes requested: 64
Bytes written: 26

This looks to me like the driver isn't correctly installed.  Also, I'm never getting anything other than a solid power light and solid INIT light on the SS.  Nothing to confirm the firmware has been successfully uploaded to it.

I'd appreciate any ideas anyone might have.  Thanks.

2
General Mach Discussion / Second parallel port enable makes 1st one slow
« on: October 21, 2011, 12:10:37 PM »
This is a strange one.
I just put a StarTech PCI parallel card on my system as a second parallel port.  I haven't yet confirmed that it is working.  However if I enable the second parallel port in the Mach ports and pins screen, the motion of my machine through the 1st port becomes jerky, slow and useless.  As if all the pulse timing has been screwed up by enabling a second port.  Anyone seen this before?

Pages: 1