Hello Guest it is June 13, 2024, 10:26:16 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - farasien

Pages: 1
1
Post Processors / Mastercam X/Mach3 post-processor issues
« on: July 12, 2009, 06:36:38 PM »
Hi all-

I just got done building a Seig X2 machine using a G-540 controller and I use MACH-3. I'm having some really strange issues... Firstly, I tried using the basic FANUC postprocessor when trying to run a simple test part (piece of wood 2X4 with simple pocket cuts- a circle, a line and a few drilled holes). When I put the toolpathing through, everything looked ok for drilling and linear interp, but circular interp was acting strange. I keep getting a warning saying that my arc endpoint is lining up ending where the arc starts on a later line. I have no idea how to fix this, so I just deleted the line to see how the rest of the program runs, and when run again, the circular toolpath tries to make a circle larger than the envelope of the machine.

I tried downloading the m3/mcx postprocessor on Artsoft's site. I ran the updater.dll application on it to make sure it was up to date, and had the program make a machine definition for me to go with the post. After doing it, I checked it, and it seemed to be OK. I re-toolpathed the part, posted it out and tried to run it, but got the exact same issue with the error warnings and with the huge circle. I've been looking everywhere online and have found nothing out there that seems to overcome the issue.

Does anyone have any useful advice on this? I'm going out of my mind on this...

-Farasien

Pages: 1