Hello Guest it is July 28, 2021, 07:00:25 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - thosj

Pages: 1 2 3 »
1
Bargain Basement / Gecko G320X/G320
« on: November 22, 2018, 08:37:03 PM »
I have 7 Gecko G320X Servo drives for sale.

I have 5 Gecko G320 Servo drives for sale.

All in great shape, all working when removed. None used a lot but all probably over 7 years old.

G320Xs $50 each shipped to US addresses only.
G320s $30 each shipped to US addresses only.

Shipping from Greenville, WI, USA, PayPal OK or ??

2
Mach4 General Discussion / Macros folder?
« on: September 07, 2018, 10:38:21 AM »
I have files in my profile's macros folder I don't know what they are and don't know if I need them. They are NOT in the Mach4Mill profile in a new install of Mach4 so did they follow along in my profile from an older install or???

Anyone know what they are and if I need them?

The M6 and M43 macros are mine, in the attaches screenshot of the folder contentns.

Tom

3
Mach4 General Discussion / Keryboard Jog won't save between sessions
« on: April 08, 2018, 07:03:42 PM »
Mach4 3481. Everything works great EXCEPT..........I setup keyboard jog buttons, all work, X/Y/Z/A jog and rapid jog with shift, all work. Can enable and disable on the Jog tab, everything just works great. Shut down Mach, restart, all the settings are GONE except X/Y/Z/A are still setup, keys selected, but functions all empty so no keyboard jogging. Set it all up again, works, shut down Mach, gone. I did a clean install of Mach4 and copied my profile/screenset in, same. Keyboard plugin is enabled, obviously, because it works until shut down. The machine.ini file seems to not have the jog info saving, or...........something. What am I missing here? I don't use keyboard jog a lot, so I don't know how long this has been like this, just discovered it today when I tried to keyboard jog and couldn't. I thought, OK, maybe I didn't set it up, so I DID set it up and it worked great. Shut down Mach, come back a few hours later, no keyboard jog.

Tom

4
Mach4 General Discussion / Jog a Linear A with Keyboard
« on: January 22, 2018, 12:56:03 PM »
Seems I remember this from the past, but.....I have a linear A axis, in my case the knee of my BP clone. I cannot jog A with any keyboard key selection. Is this by design, or perhaps there's something I need to set somewhere to get it to Jog A with keyboard keys? Maybe something with how I have it set in the Keyboard Plugin config? It jogs fine with my VistaCNC P2-S pendant. And in Mach3 it jogs with keyboard keys.

Thanks,
Tom

5
Mach4 General Discussion / Touch button Hobby vs Industrial
« on: March 26, 2017, 05:07:46 PM »
Man, I'm telling ya!

As you all know by now, I have a Mach4 Industrial license and a Mach4 Hobby license. I have both installed, both working with the same screen and same profile, copied to the proper place in each, of course.

In Industrial the Touch button did NOTHING, much like MDIing T1M6 from my previous post today. I quit, start Hobby, it works. Hmmm..... Much sleuthing, screen editor, check button script, same. I see it's calling mcTouchOff.lua. File exists in both Modules folders, but the size in industrial is like 7k, the one in hobby is 292k!! I open them both in NP++, they're VASTLY different belying the 285k file size difference ! Hmmmmm.....again. Rename file in Industrial, copy in Hobby version, run Industrial, Touch button opens the interface.

So now, of course, I'm wondering, will it work or does it require other stuff that isn't there? And isn't the ONLY place to set the probe tip diameter in the Touch interface, it can't even be set in the Probing tab, right?? So I NEED the Touch module?

And I'm wondering why use Industrial at all, thanking my lucky stars I own Industrial thanks to Brian's early offer to us Mach3 users. If I'd paid $1400 I'd be more than simply perplexed.

If my Industrial license entitles me to support, I'd sure like to know why it's so different from Hobby, other than the places it's SUPPOSED to be different, like MACRO B and a fancier screen editor. And what do people who actually paid $1400 think? Or don't any users use Industrial other than a purchased OEM machine that's all configured for them? If I hadn't had Hobby to fall back on/compare, I'd have never figured out this Touch button thing.

Tom
0 days since last modification!

6
Mach4 General Discussion / Mach 4 M6
« on: March 26, 2017, 11:00:08 AM »
So I'm pretty new to Mach4. I have both an industrial license and a Hobby license. I have Industrial all setup on my machine and for two weeks have worked thru getting everything all setup, motors, limits, soft limits, screen, PoKeys buttons and analog pots, on and on. Never tried a tool change!! Now I think, time to figure out how tools work. Did T1 M6 in MDI, NOTHING except the dialog telling me to change tool and hit cycle start. Nothing. I have Hobby installed on another PC also, licensed, running Sim Mode. T1 M6 works there. Hmmm....started digging around, read configuration manual, operation manual, forum, and discovered the Macros directory in my profile has nothing but mcLua.mcc. This profile was originally created by packaging a Hobby profile and loading it into Industrial. Apparently the Macros folder for that profile, or at least all the stuff, didn't make it.

I've added two screenshots of the folder contents of my profile/macros folder and the default. Do I copy all the stuff that's in there over to my profile? I imagine so, but what is all that stuff other than m6.lua?

I guess one just has to KNOW to look in all these locations, plugins, profiles, profiles/macros, screens, others (?), and make sure they made the trip!! And yes, I watched the video about updating Mach4, but that's all manual copying, which in the end, might be a better way than packaging.

Like someone told me long ago, it's all intuitive if you know how to do it!!!

Tom

7
PoKeys / PoKeys 57E buttons, MACH4
« on: March 08, 2017, 06:20:48 AM »
I have a new PoKeys 57E. I need to get 5 buttons working before I can move on with my Mach4 learning experience. Well, actually 5 buttons and two analog pots. I downloaded the script for FRO on a pot with inputs 41/47 on the PoKeys, but out of the box it doesn't work. Someone on the Mach 4 thread is helping me there, so maybe.....

So I need 5 buttons to do:

Cycle Start
Cycle Start
Feed Hold
Coolant on/off (M8/M9)
Mist on/off (M7/M9)

I can't find anything in the documentation for a simple button in Mach4. I guess they think I just know how to do that. I find examples for all the complicated stuff, matrix keyboards, lcd's, but nothing for a simple button and how to make it work in Mach4.

Can anyone help me or point me? I need to get these 5 buttons and two pots working before I can confidently keep my painful transition to Mach 4 going.

Thanks, Tom

8
Mach4 General Discussion / LUA Script error in PLC, PoKeys
« on: March 07, 2017, 05:05:11 PM »
I am trying to get my PoKeys 57E working with my analog FRO pot. I downloaded a LUA script from PoKeys, followed their instructions, and get an error exiting the screen editor after editing the PLC.

Saved downloaded script in C:\Mach4hobby, edited it with script editor only for Pokeys device name and pin number, saved.

Added line to PLC to run the file.

Get error: Syntax error during pre-compliation [string ""]:511: unexpected symbol near char(226)

My first attempt at customizing and trying to get my PoKeys 57 working my buttons. Not a good first attempt, so far!!

I tried to upload screenshots but can't seem to do it.

Ideas?

Tom

9
Mach4 General Discussion / Spindle Pulley Recall
« on: March 05, 2017, 06:18:12 PM »
I saw it somewhere on here but can't find it now.

I want Mach4 to remember the selected Spindle Range (Pulley for us Mach3 types!) and have Mach4 startup the next time with the same range selected.

DaztheGas explained this somewhere but where....??? I'm sure as soon as I post this I'll remember what I used to search and find the durn thing!

Thanks!

Tom

10
Mach4 General Discussion / Hobby/Industrial and Profiles
« on: February 27, 2017, 07:00:03 PM »
So I am new to Mach4, long time Mach3 user. I have a hobby license and have my mill all setup and working with an ESS. I also have an industrial license. I'd like to use the profile from the hobby version and not have to reset everything up, same machine, same ESS. Can I do that? If so, is it as simple as copying the profile or do I need to package it in hobby and restore it in industrial? Or do I have to suck it up and start from scratch?

While I have your attention!

Are *.m1s macro files usable in Mach4 or do I need to start from scratch with those, in Lua?

I have an old PoKeys 55. In Mach3 I wrote brains to access the buttons and SRO/FRO pots wired to the PoKeys 55. No brains in Mach4, so does the Pokeys Plugin just let you use the PoKeys as Inputs in Mach4 or what? I haven't tried yet, working up my courage. Just thought I'd ask.

Feeling pretty dumb again, it's a lot different here!


Pages: 1 2 3 »