Hello Guest it is October 26, 2020, 06:27:31 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - sshneider

Pages: 1 2 3 4 »
1
Modbus / is it possible to call Modbus commands with G or M Codes?
« on: March 12, 2020, 05:59:39 PM »
I would like to be able to turn on/off a few devices (via PLC/Modbus) by using G or M Codes.  Does anybody know of this is possible?  If so... any info/tutorials would be much appreciated!

THANK YOU!

2
VB and the development of wizards / How to create a simple toggle button?
« on: November 26, 2019, 03:04:49 PM »
Can anyone explain how to create a simple toggle button (code/script) that I can use to turn on/off an output or trigger a Modbus command?  Thanks much for any replies/guidance/links/videos/etc.

3
Hey All,

I've been away for a while and finally had a chance to update to the new 3.042 version.  It seems that a change has taken place in the way that the GoTo Zero command is being executed. 

Previously when one selected Goto Zero was selected the X & Y axis would trundle off to their respective positions and then Z would drop on in.  I found this to be exactly what I wanted since it kept my Z retracted (clearing clamps, Jigs and such) whilst X & Y did their thing.

Now in the new & improved version, Z moves down first and then X & Y rip across my table.  The first time I tried this I promptly broke my Bit by slamming into one of my Destaco Clamps  >:( . Am I crazy to think that moving the Z first is backwards?

So... I've looked in the config for an option to select which axis moves first and can find none.  Am I missing something or do I need to create a custom Macro to do this?   Thanks in advance for your help/advice.

Regards,
Sid

4
Video P*r*o*b*i*n*g / Post your Point Clouds Here!
« on: April 19, 2008, 02:39:23 AM »
Though I would start a new thread just for Clouds.

Here are a couple of some of my latest results.  Both of these scans were done with both Y & X passes.  Stitiching/striping courtesy of MachCloud!  I wish I knew more about how to mesh accurately and/or add surfaces.  I can see a lot of detail in my clouds but it would really be nice to see an accurrate fully 'surfaced' rendering.  One must crawl before they walk.

Sid

5
Hey All,

I am trying to cut 2 different shapes/paths on the same piece of stock using one program and work offsets written into the program. 

G55 =  X10 Y10 Z0
G56 = X10  Y5 Z0

First cut referenced to G55 offset.  Cut and toolpath display are fine.  When machine cuts the cutting path is followed/displayed correctly.

Second cut referenced to G56.  Toolpath displays OK, cut is exactly where it should be (starting @ Y5) However, the cutting path shows it is cutting in the area of the first (G55) offset.  It's weird.  Is this Operator error?  Am I missing some setting/checkbox somewhere?    Or maybe a bug?

Thanks in advance for any replies!

Sid

6
Things are humming along nicely and all of a sudden-machine stops moving and this pops up in the statust window ...

Wed - 13:35:05 ---command killed due to buffer error.

Anyone know how to fix this?

Thanks!

Sid

7
I'm Runing Ver 2.61.  Between parts I'll drag out the shop vac and clean up the table.  Somehow while wrestling with the hose I'll trigger a limit switch. No Biggie- I hit reset and all is OK except I get a "abnormal condition" alert= Machine axis not referenced.  I already referenced.  Is this just me?  If not, anybody know a 'workaround'?

Thanks in advance for any/all replies.

Oh, BTW- Happy Kwanza!

Sid

8
Feature Requests / New Shuttle Pro feature?
« on: January 12, 2007, 02:10:08 AM »
Any chance of getting another option added?  How about a "Cycle Jog Step" Function that can be assigned to a button?

Thanks,
Sid

9
General Mach Discussion / Soft Limits w/ Machine Coords?
« on: January 02, 2007, 09:20:13 PM »
Maybe this should be under the "Features" category but, after my last post there I was afraid maybe no one would take me seriously...

Is there a way to make the Soft Limits look at the Machine Coordinates instead of Work Coordinates?  When using work offsets sometimes it is nice to be able to go Neg (to move the cutter away from the Jig to load a new part for example).  Well, with the Soft limits active of course this won't work not to mention that with a new reference work Coord the Max limit is WAAAAAY off the table.

In other words (unless I am missing something) the whole Softlimits system kinda becomes irrelevant when using a work offset.

Am I missing something obvious?

Thanks in advance for any replies!

Sid

10
Feature Requests / Well, it IS X-mas ...
« on: December 23, 2006, 09:16:43 PM »
OK, How about....

Whenever a Tool Change comes up, Mach can send a text message to my cell phone telling me to get up from the (nice, quiet and warm) front office computer and go back into the bowels of the shop to change the tool?   ;D

Sid

Pages: 1 2 3 4 »