Hello Guest it is August 10, 2022, 10:28:55 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - dfurlano

Pages: 1 2 3 4 5 6 7 »
1
General Mach Discussion / Spindle Override
« on: July 05, 2013, 10:44:28 AM »
Is there a command I can place in the gcode file that will reset the spindle override? 

I sometimes adjust the override and I the sometimes forget to reset it,  thinking I can resolve this by just adding a command to reset the spindle override at the beginning of each program.

TIA

Dan

2
Mach3 under Vista / Win 7 port monitor
« on: February 08, 2013, 08:00:20 PM »
Original system is xp been running it for a very long time here is a screen shot of the port monitor (about in the middle of the screen) and the diagnostics page in Mach.



With Win7 32bit same picture.  Notice he port monitor is fine but the Mach diagnostics page is not correct.


3
General Mach Discussion / Cheap PC
« on: January 29, 2013, 10:28:44 PM »
Bought this PC on Newegg:

http://www.newegg.com/Product/Product.aspx?Item=N82E16883157147

Added a second hard drive and parallel port.  Had to take out the 3.5 drive to add the ard drive and cut down the parallel port to be half height.

$144 with Win7 pro is a great deal.

4
General Mach Discussion / Toolpath Highlight
« on: February 17, 2012, 06:21:04 PM »
Isn't there a way to have the path highlight as you scroll through the gcode in the toolpath window.  i look for settings but could not find anything.  Thought I did it before but it was a long time ago.

TIA

Dan

5
General Mach Discussion / LPT2
« on: November 18, 2011, 04:43:03 PM »
Can the flood and mist outputs be triggered from LPT2?

I would think under the outputs tab I can use;   Output 1  port 2 pin 17

That look right?

 I have a cnc4pc c15 relay board that I want to use for my solenoids.

http://www.cnc4pc.com/Store/osc/product_info.php?cPath=24&products_id=148

I want to eliminate using LTP1 which is a Gecko540

6
Tangent Corner / World Maker Faire NY Hall of Science
« on: September 20, 2011, 09:34:04 AM »
Spent last weekend at the Maker Faire in NY.  My first time and I would HIGHLY recommend going.  It is also a great family event so you can bring the significant other and there is a lot for kids to do.

Here is a great video: http://www.bbc.co.uk/news/technology-14970879

And my photos are on my facebook page.  I made them public so let me know if you cannot see them.

http://www.facebook.com/media/set/?set=a.2309669392162.131529.1562177030

http://makerfaire.com/

7
VB and the development of wizards / Marco gone wild.
« on: July 05, 2011, 06:10:20 PM »
Been struggling all weekend  trying to figure this out.

If I go to the offset menu and click the ref all home the Z,X,Y,A home with no problems.

If I click the button on my home page to run the macro below I get random behavior.  Mostly the Z rapids down but once in a while the Z will rapid up and then about half the macro will run.

If I open the macro using the edit button script command and run the macro line by line it runs flawlessly.

This system has been running with no issues for a few years.  It all started with a dumbass move on my part that crashed the system. The only difference is that I added the DoOEMButton command to the macro.

I also tried reinstalling Mach.

CurrentFeed = GetOemDRO(818) 'Get the current feedrate to return to later
CurrentAbsInc = GetOemLED(48) 'Get the current G90/G91 state
CurrentGmode = GetOemDRO(819) 'Get the current G0/G1 state
PlateThickness = GetUserDRO(1151) 'Z-plate thickness DRO
Code "G54"
Code "G90"

DoButton( 24 )

DoOEMButton 1010

DoButton( 23 )
DoButton( 22 )
DoButton( 25 )

Code "G90 G0 Z-2.75"

While ismoving()
Wend

Code "G90 G31 Z-4 F4" 'probing move, can set the feed rate here as well as how far to move

While ismoving()
Wend

ZProbePos = GetVar(2002) 'get the axact point the probe was hit

While ismoving()
Sleep 100
Wend

Code "G90 G0 Z" &ZProbePos 'go back to that point, always a very small amount of overrun

While ismoving()
Sleep 100
Wend

Zoffset = getvar(5223)
Cline = (ZProbePos+-3.2395) '-3.2395 Distance between center line of rotary and probe

SetVar(5243,(Cline+PlateThickness))'Set G55 Z
While ismoving()
Wend
SetVar(5263,(Cline+PlateThickness))'Set G56 Z
While ismoving()
Wend
SetVar(5283,(Cline+PlateThickness))'Set G57 Z
While ismoving()
Wend

Code "G91"
Code "G0 Z 0.1" 'retract

While ismoving()
Sleep 100
Wend

Code "G55"
Code "G90"
While ismoving()
Sleep 100
Wend
Code "G0 X0 Y0"   'move to start position
While ismoving()
Sleep 100
Wend

Code "(Z axis is now zeroed for G55, G56, G57)" 'puts this message in the status bar

Exit Sub                                                                                              

8
General Mach Discussion / Zeroing Z
« on: June 30, 2011, 09:46:17 PM »
I want to go to the Z limit switch and then set G54 Z to zero.

It does not consistently work.  If I run the macro twice it sets zero, just once it will not set zero.

I added the dwells figuring it needed time. Still does not work.

In desperation I post. ???


DoButton( 24 )
Code "G04 P2"
SetVar(5223,0)
Code "G04 P2"
DoButton( 23 )
DoButton( 22 )
DoButton( 25 )


TIA,

Dan


9
General Mach Discussion / Z offsets
« on: March 18, 2011, 01:37:26 PM »
I have a setup where I cut a lot of different diameters on my rotary axis.   What I have been trying to do is set up a macro to create Z offsets and I must say I am struggling big time.   I am not sure if I fully understand how offsets work.

Here is a graphic of my set up:



1) I was thinking that the Z home position should be G54 zero.

2) I would then touch off on the probe.

3) I know what the distance is between the rotary center line and the probe (Cline = x).

4) I would then read a userdro where I would have previously entered the radius of the stock material.

5) I would then calculate Zoffset=(Cline - userdro)

6) I would then setvar (5243, Zoffset)

Well I get every number but the one I want.  Somehow it is taking the actual offset from the home position and doing all kinds of weird stuff.

Is this thinking flawed?  How should I do this.  I need Z zero to be the top of the stock

TIA Dan

10
General Mach Discussion / Zeroing Multiple Z Offsets
« on: March 15, 2011, 05:57:03 PM »
I use the tool macro to set the Z offset:

Call setdro (2,platethickness)

This sets whatever offset you have enabled which is usually G54.  But I would like to set multiple offsets at once like G54, G55, G56, and G57.

Is there are command that I can use to do this?

TIA

Dan.

Pages: 1 2 3 4 5 6 7 »