Hello Guest it is October 20, 2021, 05:24:39 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mgamber

Pages: 1 2 3 »
1
For Spindle feedback, can you use ENC2 on J6 or must you use ENC1 on J11?

2
PoKeys / Re: Pokey57CNC connection to G320 driver
« on: June 25, 2017, 11:06:59 PM »
CNC4PC has what he calls a master control board that is specifically made for this function. I just purchased one and will be setting it up in the next few weeks. I have long been frustrated with this "feature" of the gecko's and wish geckodrive would themselves make a very simple add-on device that simply separated the function for a number (say 6 max) of drives. Drive enable that looks for 5v or (24v preferrably) on the enable input, and has a 5 or 24v output that you wire into your estop.

3
I purchased the AMT102 encoder and attached it to my spindle motor shaft.
It has settable resolutions.
What will be the best option for using in this application? It seems that to get the best performance I should set this to the maximum of 2048 ppr.
Or should I go the other way and go with 48 ppr? Or anywhere in-between?

2048     1024     1000     800
512       500      400       384
256       250      200       192
125       100      96         48

4
ok, thanks for the quick response. That's kind of what I figured but thought I would ask. The KBMM has an Inhibit function that I will use, already tested this with a jumper wire and it brings motor to zero.

5
Followup;

Issuing MDI of M03 S0 does turn spindle speed "off"

???

6
Experimenting with analog spindle speed. I have the Hicon connected to a KBMM DC motor controller with the isolator board. It takes 0-10v

Turning on spindle in MDI with M03 S500 etc. works great. But when issuing M05 the spindle does not turn off. Mach4 shows it thinks the spindle has turned off but it hasn't

Any help?

7
HiCON Motion Controller / Re: Connecting a 5 Volt Probe
« on: June 02, 2017, 07:06:22 PM »
Sorry pin12 is not mapped in the software.  however you can use other pins on J10, eg 6,7,8, and 9.  These are already mapped to HiCON port 14 pins 4,2,0, and 6.


I noticed that pin12 is actually showing in the diagnostics screen when I sink that pin as well. Is there any reason that I can't use this as an input in my pendant construction? it appears to be mappable.

8
HiCON Motion Controller / Re: Connecting MPG's
« on: June 01, 2017, 11:24:53 PM »
So you can operate the digital io on these pins by pulling the state to 0 because internally they are pulled up to 3.3v state? So a simple switch connected to any of these pins and to 0v will register a low state (and therefore a digital state change?

9
HiCON Motion Controller / Re: Connecting a 5 Volt Probe
« on: June 01, 2017, 03:45:18 PM »
How do you access the state of J10 pin12? This is listed as "reserved" in the manual and there is no description of how to access the state?

10
HiCON Motion Controller / Re: Connecting MPG's
« on: June 01, 2017, 03:35:21 PM »
Rufi, is this true on ALL integras shipped or are there older versions without those resistors? The manual mentions the board WILL be damaged if 5v is used on those pins on J10. Please confirm.

Pages: 1 2 3 »