Hello Guest it is November 24, 2020, 04:24:13 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - LazyBee

Pages: 1 2 3 »
1
Hallo,
danke für die Antwort. Ich verwende den ESS von Warp9TD.
Gestern habe ich mich nochmals damit beschäftigt und da hat es funktioniert. Ich glaube mittlerweile auch, dass das nicht am Code liegt.
Gruß

2
German / In Schleife "while is moving()" Stop-Button bzw. ESC abfragen
« on: March 24, 2020, 04:56:23 AM »
Hallo,
das Problem, das ich habe trifft bestimmt auf viele Macros zu, die "while is moving()" verwenden.
Im Speziellen habe ich ein Macro zum Bestimmen der Nullpunkte im Web gefunden, das ich nutzen möchte. Mein Problem ist, dass wenn ich den Stop-Button bzw. die ESC-Taste drücke dann wird die Schleife nicht sauber beendet. Anscheinend läuft sie im Hintergrund weiter (und wartet wahrscheinlich immer noch auf den Kontakt mit dem Sensor) und ich kann das Makro nicht neu starten.
Irgendwie müsste in die Schleife noch eine Abfrage reinkommen? Aber welche Abfrage.

Hier mal ein Ausschnitt aus dem Code:
Code: [Select]
'----- X AXIS SUBROUTINE -------------------------------------------------------------------------------------
Sub RunXCenter()
 SetOemDRO(800,0)               'ZERO X AXIS DRO
 Sleep 200                      'DELAY TO ALLOW DRO TO CHANGE
' Message VarStatusMsg &"     X Center Running..."
 Message VarStatusMsg & "     X Nullpunktsuche aktiv..."
 Code "G90 G31 X" & VarMaxDistance & "F" & VarFeedRate  'MOVE IN X POS DIRECTION
  While IsMoving()              'WAIT UNTIL MOVE IS COMPLETE BEFORE PROCEEDING
   Wend
Danke

3
Machscreen Screen Designer / Re: Screen 4 freezing
« on: August 04, 2019, 04:24:26 AM »
hello,
you can try the win compatibility mode.

look here:
https://www.groovypost.com/howto/run-old-software-windows-10-compatibility-mode/

4
German / Re: Bauteil ausrichten
« on: July 31, 2019, 06:28:19 AM »
Danke für die Info.
Ich habe jetzt alles am Laufen. Ich habe nun doch in die Winckler-Version reingebaut bekommen.

Gruß

5
German / Re: Bauteil ausrichten
« on: July 21, 2019, 12:00:04 PM »
Was bedeuten denn Vorsilben "si" bei siwi und "hy" bei hywi?

6
German / Re: Bauteil ausrichten
« on: July 14, 2019, 03:15:02 AM »
Danke für den Hinweis. Ich hätte mich totgesucht.

7
German / Re: Bauteil ausrichten
« on: July 13, 2019, 10:40:35 AM »
So, der Code läuft nun durch.
Mit der F8-Taste mache ich normalerweise eine Referenzfahrt über alle Achsen. Das funktioniert jetzt nicht mehr. Kann das an den Macros liegen?
Ich bekomme die Fehlermeldung: "Nothing to Feedhold"

8
German / Re: Bauteil ausrichten
« on: July 13, 2019, 06:52:29 AM »
Ich habe eine neue "TouchG" mit dem neuen Code erstellt. "WaitforMove" ist ja in der "ProbeFunktionen", die ja nun nicht mehr aufgerufen wird, da in "TouchG" nicht mehr vorhanden.
Meine "TouchG" im Anhang.

9
German / Re: Bauteil ausrichten
« on: July 13, 2019, 04:32:54 AM »
Eine Ergänzung noch zum obigen post.
Das Programm stoppt immer noch mit der gleichen Fehlermeldung wie Anfangs geschrieben nach Durchlaufen des ersten Punktes.

10
German / Re: Bauteil ausrichten
« on: July 13, 2019, 04:00:43 AM »
Hallo,
ich habe die neue Datei getestet. Es gibt folgende Fehlermeldung aus:
Siehe Bild.

Die Eingaben für DeltaX, DeltaY und den Durchmesser habe ich in das Screenset eingearbeitet. Das funktioniert soweit.

Pages: 1 2 3 »