Hello Guest it is May 06, 2021, 03:42:26 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - WDussault

Pages: 1
1
Thanks,

I have looked around but do you know of a good source for Example LUA scripts in Mach4? or a reference for functions available?


2
Would it be possible to write a LUA script to handle homing the Y Axis to square the Gantry?

Thanks

3
Mach4 General Discussion / Re: Mach4 is already Running message
« on: August 05, 2020, 12:17:54 AM »
I've found that even after I end the process from the task list I have to wait about 1 minute for a clean reboot. Thank you!

4
Thanks Steve,

I found them.. By scrolling all the way down. It's my fault. I appreciate your time. I got my X axis to home but my Y axis is being a bit more difficult. I believe it might be because I have two motors, 1 a slave of the other. The machine will home the x axis and then claim to be homed.
Here is what I have so far  and and finally

Could the fact that I have the motor 1 reversed and the motor 2 not-reversed be meddling with the homing? They are unchecked for home in place

Thank you very much!

Bill

5
Greetings,

I have a PMDX-424 controller and inputs 1-6 are Proximity sensors that are logic low when triggered. How do I map these inputs to the homing sequence? I do not see anywhere I can register the inputs with a particular axis for homing.  I watched a video on homing but it did not explain this point. Can someone help me figure this out?

Thank you

6
Mach4 General Discussion / Mach4 is already Running message
« on: July 29, 2020, 10:35:17 PM »
Greetings,

A lot of times I'll need to restart my Mach4 hobby profile and it will tell me that "Mach4 is already running" I'll check my current processes and nothing resembling Mach4 is running. People have claimed that a LUA script is running in the background, and that it is keeping mach4 from restarting. Does anyone have a workaround for this?

A member posted a powershell script  that I tried but it does not work

Get-Process | Where-Object { $_.Name -eq "Mach4GUI" } | Select-Object -First 1 | Stop-Process

This just does not work. Anyone else have something that works?

Thank you

Bill

7
Greetings all,

My name is Bill, I have been assembling a AVID CNC crp4824 in my basement for a small furniture and fabrication business I run. I am an electrical engineer and university lecturer in my normal life but am obsessed with CNC machines. I ran an older Shapeoko2 machine for about five years and outgrew it. I am trying to get Mach4 setup but having some troubles.

Thanks

Pages: 1