Hello Guest it is November 30, 2021, 08:10:38 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - john11668

Pages: 1 2 3
1
Mach4 General Discussion / Re: UC100 not found.....check connections
« on: March 22, 2021, 03:06:56 PM »
There were tales of cheap chinese copies

2
Mach4 General Discussion / Re: UC100 not found.....check connections
« on: March 22, 2021, 02:08:20 PM »
So you have ticked the box here


3
Mach4 General Discussion / Re: code conversion Mach 3 to Mach 4
« on: February 09, 2021, 06:00:40 AM »
What are you running for a plugins? And are you trying to do Modbus and not getting the communications? Something is not allowing the core to shutdown.
Please upload a gcode file and I will tell you what is wrong. Mach3 is way more mill and 4 has a full on turn Gcode interpreter.

I want to help but I need you to help me help you. I wish I could see what your seeing because I could do more.

Hi Brian
Sorry I have not been around for a few days .
The only plugin AFAIK is the UC100 one ,  I have never tried anything to do with modbus.  I saw it in the config memory  but I am going one step at a time so was not tempted to anything new . 

I find this is a nuisance though.

Do you get involved in problem solving by screen sharing

4
Mach4 General Discussion / Re: Mach 4 configuration manual
« on: February 04, 2021, 05:36:45 AM »
That is fair comment Brian
I will  spend some time this week following the advice I have been given and see where that gets me.


With regard to the "ranges" which  thosj speaks about  i can see them on the top of my screen.  But can barely read some of the labels , so for example I could not make out the word range .
Along with other issues I have mentioned in my configuration manual thread  makes me wonder if maybe I have problems with my download and what if any options I may have  .
I am running windows 10  on a 64 bit machine

5
Mach4 General Discussion / Re: code conversion Mach 3 to Mach 4
« on: February 04, 2021, 04:59:20 AM »
Lathe ,
Runs code happily in mach 3 but that same code jut gives me crop circles in mach 4  regardless of abs or inc  arc settings in control page .


I am also finding that when I exit from Mach 4 there is a copy of Mach4 gui left running in the background  which prevents me from reopening "Mach 4 lathe" so I have to go into application manager and delete before I can open mach again. or restart the whole computer.
There are other strange happenings   too ..  left arrow on keyboard now jogs right. It was fine a couple of days ago .
When I go into Diagnostics/ keyboard settings  I cant change it back.  The screen has a flicker .
I presume these latter issues are not connected to the crop circles , but all adding to my initial experiences of Mach 4 .


6
Mach4 General Discussion / Re: code conversion Mach 3 to Mach 4
« on: February 03, 2021, 06:54:32 PM »
Doesnt really help me to overcome the problem Brian.

7
Mach4 General Discussion / code conversion Mach 3 to Mach 4
« on: February 03, 2021, 08:20:02 AM »
So I have a piece of code  produced as an exercise in Mach3.
I try to load it into Mach 4 as a test routine .
An error comes up saying unrecognised code in line 1   which is   "G18 G64 G80 G90 G40 G49 "
Now not  being sure of all the codes I just deleted line 1 to see if it would work presuming there would be  defaults in there which would work anyway.
So now when I load  into Mach 4 it is happy to load and run  but with crop circles on the display and the machine happily follows these in run mode .
I have had these before in Mach 3  and I seem to remember it being to do with the absolute or incremental modes
Can anyone remind me how to change these in Mach 4

Which piece of code in line one is upsetting mach 4  and why?
It surprises me that code is not portable between on and the other

8
Mach4 General Discussion / Re: Mach 4 configuration manual
« on: February 03, 2021, 05:56:33 AM »
Thanks for that Brian.
 I am also in camp 2 having added a "Heath Robinson" style 3 axis conversion to a venerable Deckel mill  and I found there is tremendous satisfaction in doing something like that.  This was during the UK lockdown early last year.

Late last year I bought a small school type lathe to do similar.  X and Z did not give me any major headaches but Mach 3 spindle control  did  and hence the reason  I tried mach4 and came for advice .   
Not having vast experience on M3  lathe software (a few months at best),  I am finding Mach 4 very different and without some form of manual it is a steep hill for me to climb.

I am slowly getting there step by step , muddling through in a way,
I have started these projects relatively late  in my lifetime , never having had much time earlier .   So my learning rate is not what it would have been forty years ago.
I do have difficulty with the jargon that goes with computer software which does not help.

But step by step I will get there . 

thanks again

John

9
Mach4 General Discussion / Re: Mach 4 configuration manual
« on: February 02, 2021, 05:22:27 PM »
Let me do this for you ... put the Mcodes in the macro's directory (need to be taken out of the zip file)

M41 in MDI will put you in range 0 M42 will do range 1

Thank you for that Brian but you may as well have been speaking chinese there. What do I actually do with those files?
I cant open them .
Can you translate that into something that a dummy like me can  take on board .

Coming back to my OP,  Mach 4 really does need a Manual. 
Surely you will sell more if you make Mach 4 user friendly.   Maybe you need to have someone write a "Mach 4 for dummies" book.  I am sure it would sell.

Having said that I have made progress today, partially as a result of your invaluable advice above  (many thanks)  but in a great part through trial and error and  finding my earlier cockups . Please do not take this as criticism . It is intended as constructive advice as well as appeal for help..

10
Mach4 General Discussion / Re: Mach 4 configuration manual
« on: February 02, 2021, 03:29:11 PM »
I am not seeing pulley ratios on the diagnostics page .
Would have expected to see a number of otions for pulley ratios .
???

Pages: 1 2 3