Hello Guest it is June 20, 2021, 09:21:23 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - blue-v

Pages: 1
1
Digging out this thread while searching for a convenient MDI usage in Mach4 I'd like to say:

The most important MDI behavior in Mach3 for me was the command history.
Just browsing through the last entered lines using the arrow up/down key and editing the
commands if necessary.
That was sooo nice!
If find myself closing Mach4 and starting Mach3 just to use the convenient MDI of Mach3 quite often.

Please, NFS, bring back the MDI functionality of Mach3! 

Btw: It's not <Crtrl>-<Enter> to execute the MDI in Mach4, but <Shift>-<Alt>-<Enter>.

2
Mach4 General Discussion / Re: Surface map Wizard not working
« on: June 24, 2020, 06:39:36 AM »
Same here.
Spent about 3 hours now to get this to work, but surface map seems to have no effect at all.
I tried it on .4300 (demo) and .4517 (licensed)

Also I found the map file contains a lot of "noTouch" entries even though during probing everything went fine.
The machine recognized every single probe point.
Well after having no success loading the map file, I edited it by hand inserting plausible values instead of the "noTouch" data.
But that did not change anything.
The map file is just not recognized by Mach4. No hint in the logging window either.
I'll attach my (edited) map file from a "sloped" machine bed.

I'd really appeciate that feature working!

Lothar

3
Mach4 General Discussion / General error opening gcode file - fix
« on: March 07, 2020, 04:38:35 PM »
Hi!

I had a problem here on my setup switching from Mach3 to Mach4.
After some experimenting I found the reason for the problem and I thought I'd share the solution here.
Maybe it helps someone.

I store my gcode files on a NAS.
The CNC computer mounts the NAS share as a nework drive to access the gcode files.
That worked perfect with Mach3.
Mach4 however refuses to open these files. I get a "General error opening file" (or similar - I have a non-english Windows installation).
Copying the file to the desktop or a local drive works fine and Mach4 is able to open the copied files without any problem.

My NAS shares files read-only and that is obviously the problem.
Mach4 needs write access to gcode files in order to open them.
Exporting the directory read-writeable fixed the problem.

Maybe NFS could brush up the error message a bit. Something like "Gcode file needs write permission to open!" would be nice.

Well, hope that helps someone.

Cheers
  Lothar

4
Mach4 Plugins / Re: XHC WB04 plugin
« on: March 06, 2020, 04:46:10 AM »
I was very happy finding this thread, since I'm missing the WB04 very much after upgrading to Mach4 recently.

Unfortunately Mach4 (Version 4.2.0.4300) does not start anymore when I put XHC04.m4pw and
XHC04.sig (V 1.0.19) into the M4 plugin folder.
I'm running Win7 32bit

What might have gone wrong?

Thank you!
  Lothar

Pages: 1