Hello Guest it is February 28, 2021, 02:37:49 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - saurabhsaurc

Pages: 1
1
General Mach Discussion / Re: Changing pin outputs for axes
« on: October 25, 2018, 12:37:56 AM »
Yup, I think you are right. I messed around a lot and no matter what I set the pin numbers to they work only for x-axis.

One more question, what is the difference between a 'port' and a 'pin' .

2
General Mach Discussion / Changing pin outputs for axes
« on: October 24, 2018, 07:49:34 AM »
Hi there,

I have a Mach 3 USB breakout board. When I connect it up with stepper and driver to the x-axis (XP and XD) and give x-axis jog commands/GCODE commands, it works fine. I have set the ports and pins setting at 2&3.

Now here's the thing. If I disable X axis and instead put the Y-axis port/pin setting at 2&3, then give y-axis commands, then the same stepper should move, right? But it doesn't! Worse, the x-jog command still works as before ( even though it is disabled in ports and pins ). Though g-code command doesn't work.

Is there something I am missing about the setting of ports and pins?

What I really want to do is use 2 translational and 2 rotational axes, eg. X,Z,A,B, rather than X,Y,Z,A

3
General Mach Discussion / Re: Help a noob to wire up Mach3 USB board
« on: October 24, 2018, 01:28:21 AM »
Hi again,

So I've managed to set up my stuff just fine mostly. Only one thing is there which is the spindle setting. I want to use STEP/DIR to control the spindle.
I have set up the spindle control to step/dir, and then set the pins ( in Ports and Pins ) to 2 & 3 ( where the x-axis was connected ). However, nothing happens!

I cannot get the spindle to work. Even more annoyingly, the MPG (displayed on the screen ) is able to jog the 'x-axis' motor, even though I have disabled the x-axis in ports and pins and set those pins to 0. What is the actual concept of 'pin numbers' in Mach 3?

Edit: Now I am even more confused with this 'pin number' thing. When I set y-axis pins to 2 & 3, it doesn't respond to y-axis commands either! So are the pin numbers hard-wired to the particular axis?

4
General Mach Discussion / Re: Help a noob to wire up Mach3 USB board
« on: October 10, 2018, 07:41:48 AM »
Success!

I managed to get it to work by following instructions on this site
https://buildyourcnc.com/Item/electronicsAndMotors-electronic-component-breakout-Mach3-USB-Board

Even though I didn't buy it from them and my board looks a little different from theirs.

5
General Mach Discussion / Re: Help a noob to wire up Mach3 USB board
« on: October 10, 2018, 06:40:06 AM »
Their knowledge is not that much honestly.. that's why I'm posting here  :)

6
General Mach Discussion / Re: Help a noob to wire up Mach3 USB board
« on: October 10, 2018, 06:17:11 AM »
Okay!

I connected the power supply to 24V and DCM. The board is now active, and holding torque is being provided to the stepper motor.

But in the software, I cannot get the motor to move, still. When I click cycle start, it does nothing. Sometimes when I click reset, it says RnR control board not found!

Pin configuration is given in image. Is there any other config I need to do?

Here's the sample g-code, it's really simple.

G00 G90 G94 G40 G54 G80
T1 M06
M07

G01 X30 F200
G01 X10 F200

M09
M05
M02

7
General Mach Discussion / Re: Help a noob to wire up Mach3 USB board
« on: October 10, 2018, 05:20:32 AM »
So, where should I connect it? On the 10V/Gnd terminals on the right side or somwhere else?

8
General Mach Discussion / Help a noob to wire up Mach3 USB board
« on: October 10, 2018, 03:56:09 AM »
Hi Folks,

I'm a complete noob to Mach3, although I have extensive experience in CNC/robotics. I need help in setting up my USB Mach3 board to work with my stepper motors.
Now I'm not talking about the parallel port breakout board since my laptop doesn't have a parallel port. I'm talking about boards like this

https://robokits.co.in/automation-control-cnc/controller/usb-cnc-controller-mach3-4-axis-100khz-interface-board-mk1

The documentation provided is extremely limited so I am having trouble wiring and operating the software. I got this far (see image attached )

XP and XD ( pins 2 & 3? ) are connected to stepper driver's CLK+ and CW+. EN+, EN-, CLK-, CW- are all connected to ground through a terminal block.

This ought to send step signals when I give CNC codes, but it doesn't do anything at all.

I read somewhere that I ought to wire up the left side with 12V connected to 10V and Gnd to that Gnd. Why would the Mach3 board need external power supply? It doesn't run the motors, all it does is send step and direction signals. I'm also mystified as to why 12V should be connected to 10V.

The other problem is that my Mach3 software doesn't seem to be able to process G-Codes.
It loads up fine, even detects my board, but when I click 'cycle start' it just goes to the first instruction and sits there. Sometimes it has trouble generating toolpath too.
I have set the pins for X axis to 2 and 3 in the configuration.

Thanks for you help!

Pages: 1