Hello Guest it is April 17, 2021, 03:00:12 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Tronn

Pages: 1
1
Im seeing similar behavior with a G31 sent via MDI. When running these from MDI it will do one of three things:
1) Probe successfully and halt motion when the probe contacts the part. Motors remain enabled.
2) Fail to probe and issue "cant transition from MDI running to stop" message.
3) seemingly probe successfully, but motors are disabled after probing cycle. Mach 4 reports that a limit switch is triggered and disables the outputs. The limit that it is reporting is one that I have my motor faults hooked up to. This fault output is triggered whenever motors are disabled though, so I am unsure if the motors are causing the disabling, or if the disabling of the motors is causing the limit.

2
Thanks for your reply Steve. Email sent to PMDX support. I will try a standard G31 probe cycle when I am at the machine tonight.

3
I had some minor success. I tried setting the fast feed to 2 ipm and the slow feed to 1 ipm, as suggested, but still got the "Can't transition from MDI running to stop." message. I then tried the other extreme, fast feed at 50 ipm and slow feed at 45 ipm. With the faster values I was able to get the xy calibration cycle and the probe radius cycle to complete successfully and repeatably. I then tried playing around with the other probing screens and had success with bore probing, but back to the same "Can't transition from MDI running to stop." problem on corner finding. Does anyone have insight to why probing is so sensitive to feed rate during probing?

4
So I have been trying to setup probing with Mach 4 using a contact probe, but I cannot even get the calibration routines to complete without getting the error message: "Can't transition from MDI running to stop." I am using a probe from drewtronics (https://drewtronics.org/s5000led) and a PMDX-424 board on a retrofitted Bridgeport M-Head. I have confirmed that Mach 4 is seeing the probe, as the indicator on the touch module does trigger when I contact something with the probe. The probe itself also has an LED indicator that turns on when contacting something. I am seeing this behavior in both the touch module and the probing screen set. Anyone else run into this problem?

Pages: 1