Hello Guest it is October 20, 2021, 07:40:17 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - manoj2s

Pages: 1
1
Brains Development / How to use I/O from Galil 2143
« on: June 26, 2008, 03:26:48 AM »
Hi Friends

I am having Galil Controller 2143, I have downloaded Galil Plugin. Now i can run Motor using Mach3.

But i want to use I/O from Galil Controller.

Can anyone please advice how should i do it??

Regards,
Manoj

2
Galil / Mach3 + Galil DMC2133
« on: April 04, 2008, 03:03:28 AM »
Hi all,

I am having Galil DMC-2123 controller with onboard AMP 20540 drive & pittman motors. I want to use MACH3 for 2 axis truning job application where i am going to retrofit a OLD manual lath.

I have downloaded MACH3 & pluging for Galil controller, they are communicating very well but my problem is i want to configure AXIS of Galil controller with Mach3 for turn application.

For example i want to used X & Z axis for turn application how can i do it.
Please advice.

Thanks
Manoj

3
General Mach Discussion / Can i use MACH software on Turret Lath
« on: November 20, 2007, 12:16:00 AM »
Hi Friends

Can i use MACH software on Turret Lath

Regards
Manoj

4
General Mach Discussion / Problem with MACH3 Mill
« on: November 16, 2007, 01:47:08 AM »
Hi

I am using MACH3 for hobby cnc stepper motor application.

Since last time i find problem with MACH mill like i can run motor in only forward direction when use reverse direction key then only DRO is updating but motor is not moving.

Could you please advice,

Regards
Manoj

5
General Mach Discussion / Want to built 3 axis engraving
« on: October 26, 2007, 03:04:40 AM »
Hi Guys

I m new bie for CNC things.

I want to built 3 axis engraving machine to engrave name.

Can anybody pls guide me

Specification :

My object size = 750mm long / 350m wide / 200mm hight
Engrave word size (height) = 5 mm to 30mm


Regards
Manoj

6
General Mach Discussion / Re: Please help me
« on: September 13, 2007, 12:18:12 AM »
Hi

When i checked supply voltage across printer port pins they are very small like 3.5v & some times 0.42v.

I am using computer of Intel P2 (2.4Ghz processor , 512 RAM DDR)

regards
manoj




I take it you are using a lead from the printer port. I used an old printer cable which I then cut in two. I identified all the pins with each wire and soldered the 25 wires in order 1 - 25 onto a small piece of copper clad strip board.

If you look in Config/Ports and Pins/Motor Output, you can then specify which pins you want the signal to come out of. These are usually 2 and 3, 4 and 5, 6 and 7 for the first three motors. Do not forget to specify Port 1 in the ports column.

You can test if there is any signal on the pins by connecting a TTL/Cmos logic probe to each pin and trying to jog ( without any cards or anything connected). Pins 2,3,4,5,6,7,8, and 9 are the eight outputs used in the stepper motor page. Pins 10,11,12,13 and 15 are inputs. Pins 1,14,16 and 17 are the other four outputs. Pins 18 to 25 are signal ground - and you will need to connect at least one of these to be able to read the port.

You should get a "pulse" reading on the logic probe if a signal is being output.

You can test your cards simply by tapping a positive or negative wire on the "step" input - the motor attached to the driver should react even if it is only a small movement.

If you are getting some signal out on your printer wire, and your cards are giving some signal to the motor, connect up the wired as you have specified in "ports and pins" and it should work.




7
General Mach Discussion / Re: Please help me
« on: September 11, 2007, 12:46:09 AM »
Hi
Thanks
I will reply you asap.

Regards
Manoj

I take it you are using a lead from the printer port. I used an old printer cable which I then cut in two. I identified all the pins with each wire and soldered the 25 wires in order 1 - 25 onto a small piece of copper clad strip board.

If you look in Config/Ports and Pins/Motor Output, you can then specify which pins you want the signal to come out of. These are usually 2 and 3, 4 and 5, 6 and 7 for the first three motors. Do not forget to specify Port 1 in the ports column.

You can test if there is any signal on the pins by connecting a TTL/Cmos logic probe to each pin and trying to jog ( without any cards or anything connected). Pins 2,3,4,5,6,7,8, and 9 are the eight outputs used in the stepper motor page. Pins 10,11,12,13 and 15 are inputs. Pins 1,14,16 and 17 are the other four outputs. Pins 18 to 25 are signal ground - and you will need to connect at least one of these to be able to read the port.

You should get a "pulse" reading on the logic probe if a signal is being output.

You can test your cards simply by tapping a positive or negative wire on the "step" input - the motor attached to the driver should react even if it is only a small movement.

If you are getting some signal out on your printer wire, and your cards are giving some signal to the motor, connect up the wired as you have specified in "ports and pins" and it should work.




8
General Mach Discussion / Re: Please help me
« on: September 10, 2007, 04:40:41 AM »
Hi Whacko

Thanks for the reply.

i am using normal stepper drive ckt with L298 which accepts steps & direction signal
I am using printer port configuration as mention in Mach3.

Could you please advice me what exactly you want me to elaborate.

Regards
Manoj

9
General Mach Discussion / Please help me
« on: September 08, 2007, 01:37:49 AM »
Hi Friends,

Please help me,

For my hobby CNC project i decided to use MACH3 & stepper motor setup.

Currently i have finished my mechanical framings of Hobby CNC.

Now its time to run Stepper motor on Mach3 but facing problem to it so.
I have design bipolar stepper motor drive using L298 but when i tries
to run using Mach3 & printer port then it fails to work nothing is
happen.

I have preconfigure printer port pins as MACH3 software uses but still
not working.

Can anybody please guide how to resolve this problem.

Regards
Manoj
manoj_sakpal2000@yahoo.co.in

10
Forum suggestions and report forum problems. / Need Help
« on: July 19, 2007, 07:43:42 AM »
Hi

I am new to Mach software but we have developed our Stepper Drive  weith (Enable + Step + Direction) Input.

Can anybody guide us how to Configure this software MACH 3 for our application

Regards, Manoj

Pages: 1