Hello Guest it is December 05, 2021, 10:08:31 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Olavi

Pages: 1 2 »
1
I found out that Mach3 dont try to change existing tool when using auto tool changer (instead of stop spindle option). So I am making script by this way.

2
You should then change M6start macro, through which you can skip all unnecessary movements if loaded tool is the same as commanded tool.
You have right.

Also I am looking for mach4 which skips tool change when it is not needed.

Ty for your answers, ZASto. :)

3
It seems that people are too spoiled. When we had computers running DOS, from floppies, on 8086 processor, all was fine, nowadays, AMD Threadripper with ultrafast SSD is "slow" :D
ZASto is so spoiled. When my grandmom was young, she delivered letters around country with horses and everybody was happy. Nowadays ppl are not happy when getting so many emails. :D

Its not very big deal, I can skip any movements when tool is already loaded, just hitting cycle start twice. I personally think it is a bit strange why not to skip it. But it is ok.

Does same thing happen when using auto tool changer? CNC drops tool and reloads it?

4
Hi Gerry,

Thanks , I am a total novice in this field and trying to learn so please excuse me if I am asking dumb questions .

What if the tool change is asking for the same tool , how does it ignore that and keep cutting until a different tool is required .

As the " Tool Change Macro " Download does not appear to have any code I have had to print screen from the tutorial into paint and print the code which I am now manually typing into Note , and then try to modify to suit .

What I am trying to do is :

M6 Tool Change request ... Ignore if same tool ... Go to change position if tool New Tool is needed at safe height .... Then Do Manual Change and Re - Zero tool " .... enter new tool number  is stored either manually or changed to the tool requested number when cycle start is hit ...( If tool 0 is entered to ignore tool change) not really sure on that one .

I have same question - why Mach3 tries to change tool when required tool is already installed?

I know I can disable M6 at the beginning of job, but I dont want to do that. Is it possible to configure mach to change tool at the begin of job when it is needed only? At moment there are pretty useless movements before job can start. Also my CAD program (Aspire) cant know which tool may be used, so it will add that codeline just in case.

5
Do you want these coordinates are displayed as message or you want some moves at the end of script?

If you want a move to the location at x50.05 y76.25 then you can do something like this:

While IsMoving()
Wend
Code "G0 X50.05 Y76.25"

If you add this part to the end of your script then after you get Message("A = " & roun(angle) & "°") from your script and all moves are done your cnc goes to the given location. Z is not moving.

I am newbie, so dont expect truth. :S

6
VB and the development of wizards / Shorten "File" label
« on: June 03, 2018, 05:08:02 PM »
Hello

My cnc running pc use shared folders from another pc and mach3 displays full local network path + folders + running file. Sometimes File label string is too long to fit into label and most important part of it (file name) is not visible anymore.

Is it somehow possible to shorten file path by cutting off first part of File string in case it is too long?

7
It is clear now left side motor's drive cause it.

8
joeaverage, thank you for your reply, but at the moment it seems that motion card cant cause y-axis malfunction.

About what I tried now ...

 I installed latest version of Mach3. Nothing changed. And I removed latest mkx driver because I cannot it work properly.

Now I am 100% sure that right side is working properly and left side does wrong work. Today I switched Y-axis motors, but nothing changed, still left side makes problem. So motors are correct.

I saw that both y-axis drives getting their signal from same connection from motion card output, so it seems like something goes wrong between motion card output and motor output. I checked wires and all seems good. I suspect that drive cause it.

Today I switched all plugs from left drive to the right drive and from right drive to the left drive. I ran one job but nothing wrong happened while doing this job. Tomorrow I will run it again until I see which side goes wrong now.

Since I need to do some cuts my boss said I should connect both motors to the same drive. Is it ok to do it?

9
I am thankful for each reply, specially if you have experience about that.

I thought about shorter usb cable, existing one is like 2m long. My boss ordered new one. Getting it soon.

I noticed this card have PE connection, but there are no wire connected to the ground. Is it ok to ground it?

Auto tool zero mostly works fine with original version of driver which came on CD, but all errors ever happened appeared time to time. MOstly it is working fine for 1-2 months and then for 1-2 weeks it sucks as fck. It happened few times that spindle is losing its correct position even while program is running.

I thought now also I should check which version of Mach3 is installed or reinstall software. Never know ...

PS! I know about that ********* related with china products. I got my personal experiences with these and all things I ever bought for myself stopped working in 1-2 months. I dont have any mood to order anything from china or hong-kong, waste of time and money.

10
Thank you for reply.

Do you have suggestions which manufacturer to looking for? I have Yako MS-L Servo drives for Y axis -> http://www.yankong.com/EN/index.php/proview-60-26.html At the moment I am not at work to give models of other devices but I can give more info if needed.

One more question - is it possible to change strength of motors so CNC turns off in case some cutted parts move away from their original position (small parts) and goes between something? I know to use tabs, but I cut plywood and it is not so stable to have good tab all the time. And too strong tabs cause too much time to remove or may damage surface of playwoon when removing.
At the moment motors needed to apply too much power to make losing steps and even when it happens it mostly turns off only one motor and all other motors continues their job which is bad.

Pages: 1 2 »