Hello Guest it is June 20, 2021, 09:27:14 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - lerska83

Pages: 1
1
Mach4 General Discussion / Re: Tool table issue
« on: November 07, 2019, 06:33:10 AM »
I been looking this issue myself and after getting flood of responses and suggestions (I know I may have explained this issue quite badly) :) I finally managed to get it to work... I updated to latest Mach and suddenly the issue was gone... So case solved

2
Mach4 General Discussion / Tool table issue
« on: August 23, 2019, 04:03:27 AM »
Hi
I have some strange tool table issue which has driven me crazy. After i have set all tools in my tool table (lathe) everything works great, but after I shut down mach4 and later on open the application again the tool table has reset... example tool 1 i have X value of -50.0450 (in mm) and after i restart mach4 it suddenly becomes -50.0000 and for tool 3 I have set -35.5437 which comes -35.0000 after reset and so on.... I really don't want to write these values every time I start up mach4 and would be interested what is causing this issue?

3
Mach4 General Discussion / Lathe threading issue
« on: April 22, 2018, 02:18:00 PM »
Hi
I been using Mach4 with Pokeys57CNC for my mill, but now that I been trying to get my lathe work with Pokeys57U with external IO for steppers and Mach4 I have some strange issues with threading. I use indexer with pokeys and it reads RPM fine. When I try to make threads (metric) with the canned cycles which is built in mach4 I can't get threads right at all.  If I example put 1.75 for pitch and let it run it will make 1mm threads. (actually whatever pitch I use it will always make the same 1mm pitch threads expect if I use pitches under 1mm then it makes threads with smaller pitch). Does anyone have any idea what could cause this? (oh and sorry for bad writing... I am quite tired as I did try to fix this all day)

4
Mach4 General Discussion / Re: Pokeys57CNC and probing
« on: September 04, 2017, 03:30:00 AM »
Ohh though I have not tried latest version of plugin :D have to test it later when I got time

5
Mach4 General Discussion / Re: Pokeys57CNC and probing
« on: September 04, 2017, 03:28:34 AM »
I have been having some mails with Polabs lately, and we might have found the problem with probing and the fix for it.

Anyone else here getting "Probe interrupted" as the probe doesnt work ?

Yes I am getting still that error.... Though G code probing works somewhat at least and been using that "temporarily" until the probing gets fixed.

6
Hi
Could I also get the driver?

You have done amazing work with it.


7
Mach4 General Discussion / Pokeys57CNC and probing
« on: June 29, 2016, 02:49:16 PM »
Hi

I have been running succesfully pokeys57cnc controller to drive my cnc router, but now that i have been trying to get probing to work i have seriously "hit a wall". Whatever settings i have tried it says either no contact with probe or that probe is obstructed. When i check the machine diagnostics and pokeys own input diagnostig it seems work well and in mach it shows that probe input gets activated when i close the switch (i am using NO switch to test the probing function). I took log of what is happening and will past it here so if anyone can help me to find out what is causing this error.

Code: [Select]
2016-06-29 18:48:54.528 - API: mcCntlEnable(true) called.
2016-06-29 18:48:54.530 - Signal id 1018, (Enable #0), changed from LOW to HIGH.
2016-06-29 18:48:54.541 - Signal id 1019, (Enable #1), changed from LOW to HIGH.
2016-06-29 18:48:54.548 - [PoKeys] Axis enabled changed 1

2016-06-29 18:48:54.552 - Signal id 1020, (Enable #2), changed from LOW to HIGH.
2016-06-29 18:48:54.564 - [PoKeys] Updating enable output signals
2016-06-29 18:48:54.569 - Signal id 1021, (Enable #3), changed from LOW to HIGH.
2016-06-29 18:48:54.583 - [PoKeys] Axis enabled changed 7

2016-06-29 18:48:54.586 - Signal id 1120, (Machine Enabled), changed from LOW to HIGH.
2016-06-29 18:48:54.596 - [PoKeys] Updating enable output signals
2016-06-29 18:48:54.612 - [PoKeys] Axis enabled changed 15

2016-06-29 18:48:54.627 - [PoKeys] Updating enable output signals
2016-06-29 18:48:54.640 - [PoKeys] PoKeys Pulse engine enabled
2016-06-29 18:48:54.652 - [PoKeys] Enabling motion - Buffer with 0 moves is being cleared!
2016-06-29 18:48:54.668 - [PoKeys] Updating motion parameters in device
2016-06-29 18:48:54.706 - All motors marked as still.
2016-06-29 18:48:54.707 - All motors marked as still.
2016-06-29 18:48:54.707 - All motors marked as still.
2016-06-29 18:48:54.707 - All motors marked as still.
2016-06-29 18:48:54.708 - All motors marked as still.
2016-06-29 18:48:54.708 - All motors marked as still.
2016-06-29 18:48:54.708 - All motors marked as still.
2016-06-29 18:48:54.709 - All motors marked as still.
2016-06-29 18:48:54.710 - API: mcMotionSync() called.
2016-06-29 18:48:54.710 - SyncPosition()! Clearing planner.
2016-06-29 18:48:54.710 - [PoKeys] Switching to RUNNING state...
2016-06-29 18:48:59.644 - API: mcCntlGcodeExecuteWait() called. (G0 G90 G40 G80)
2016-06-29 18:48:59.848 - Attempt transition from "Idle" on event "MDI Start" Controller.cpp:1961
2016-06-29 18:48:59.849 - S_IDLE_on_exit
2016-06-29 18:48:59.849 - MACH_STATE_start_mdi
2016-06-29 18:48:59.849 - S_MDI_RUNNING_on_entry
2016-06-29 18:48:59.849 - S_MDI_RUNNING2_on_entry
2016-06-29 18:48:59.851 - Signal id 1114, (Gcode Running), changed from LOW to HIGH.
2016-06-29 18:48:59.966 - Attempt transition from "MDI Running" on event "Stop" GcodeExec.cpp:943
2016-06-29 18:48:59.966 - S_MDI_RUNNING2_on_exit
2016-06-29 18:48:59.966 - Signal id 1114, (Gcode Running), changed from HIGH to LOW.
2016-06-29 18:48:59.967 - S_MDI_RUNNING_on_exit
2016-06-29 18:48:59.967 - MACH_STATE_stop
2016-06-29 18:49:00.035 - S_IDLE_on_entry
2016-06-29 18:49:00.036 - API: mcCntlGcodeExecuteWait() called. (G43 H1)
2016-06-29 18:49:00.241 - Attempt transition from "Idle" on event "MDI Start" Controller.cpp:1961
2016-06-29 18:49:00.241 - S_IDLE_on_exit
2016-06-29 18:49:00.241 - MACH_STATE_start_mdi
2016-06-29 18:49:00.241 - S_MDI_RUNNING_on_entry
2016-06-29 18:49:00.241 - S_MDI_RUNNING2_on_entry
2016-06-29 18:49:00.242 - Signal id 1114, (Gcode Running), changed from LOW to HIGH.
2016-06-29 18:49:00.362 - Attempt transition from "MDI Running" on event "Stop" GcodeExec.cpp:943
2016-06-29 18:49:00.362 - S_MDI_RUNNING2_on_exit
2016-06-29 18:49:00.362 - Signal id 1114, (Gcode Running), changed from HIGH to LOW.
2016-06-29 18:49:00.363 - S_MDI_RUNNING_on_exit
2016-06-29 18:49:00.363 - MACH_STATE_stop
2016-06-29 18:49:00.426 - S_IDLE_on_entry
2016-06-29 18:49:00.428 - API: mcCntlGcodeExecuteWait() called. (G31,0 Z-50,5000 F50,0)
2016-06-29 18:49:00.632 - Attempt transition from "Idle" on event "MDI Start" Controller.cpp:1961
2016-06-29 18:49:00.632 - S_IDLE_on_exit
2016-06-29 18:49:00.632 - MACH_STATE_start_mdi
2016-06-29 18:49:00.632 - S_MDI_RUNNING_on_entry
2016-06-29 18:49:00.633 - S_MDI_RUNNING2_on_entry
2016-06-29 18:49:00.634 - Signal id 1114, (Gcode Running), changed from LOW to HIGH.
2016-06-29 18:49:00.649 - Attempt transition from "MDI Running" on event "Stop" GcodeExec.cpp:994
2016-06-29 18:49:00.649 - S_MDI_RUNNING2_on_exit
2016-06-29 18:49:00.649 - Signal id 1114, (Gcode Running), changed from HIGH to LOW.
2016-06-29 18:49:00.650 - S_MDI_RUNNING_on_exit
2016-06-29 18:49:00.650 - MACH_STATE_stop
2016-06-29 18:49:00.712 - S_IDLE_on_entry
2016-06-29 18:49:00.714 - API: mcCntlEStop() called.
2016-06-29 18:49:00.715 - API: mcCntlEnable(false) called.
2016-06-29 18:49:00.718 - Signal id 1018, (Enable #0), changed from HIGH to LOW.
2016-06-29 18:49:00.733 - Signal id 1019, (Enable #1), changed from HIGH to LOW.
2016-06-29 18:49:00.735 - [PoKeys] Axis enabled changed 14

2016-06-29 18:49:00.744 - Signal id 1020, (Enable #2), changed from HIGH to LOW.
2016-06-29 18:49:00.751 - [PoKeys] Updating enable output signals
2016-06-29 18:49:00.761 - Signal id 1021, (Enable #3), changed from HIGH to LOW.
2016-06-29 18:49:00.779 - [PoKeys] Axis enabled changed 8

2016-06-29 18:49:00.781 - Signal id 1120, (Machine Enabled), changed from HIGH to LOW.
2016-06-29 18:49:00.789 - [PoKeys] Updating enable output signals
2016-06-29 18:49:00.818 - [PoKeys] Axis enabled changed 0

2016-06-29 18:49:00.834 - [PoKeys] Updating enable output signals
2016-06-29 18:49:00.850 - [PoKeys] PoKeys Pulse engine disabled
2016-06-29 18:49:00.864 - [PoKeys] Disabling motion - Buffer with 0 moves is being cleared!

Pages: 1