Hello Guest it is November 27, 2021, 04:34:38 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - wadero

Pages: 1
1
I've been able to solve the problem by making a clean installation AND configuration of Mach 3.....for now.
The problem was not in the file I believe because the problem appeared with several files.
Probably some configuration bit that got out of the corner.

Thanks for offering your help anyway, I hope it stays on it's feet.

2
Seems to be no explanation for this he.
It's a HSR file from solidcam and I have run several dummy runs of it. I can see during the run that the Z-axis goes deeper than the line with the Z-instruction coming by.
In other words the machine doesn't follow the Z-instruction and does it's own way so to speek. I don't see any possible way such thing can happen and according the
massive respons on this no one does.
Only Z-axis, the other 2 behave correct.
DRO  is consistent with position and not with the instruction.
Manual z-position inputs behave correct (z50 z0 z50 z0 z50 z30 z0....)

3
It seems like there is a scale factor involved but all scaling is set to 1. There is no G50 or G51 in the file.

4
General Mach Discussion / Z-axis goes deeper dan indicated by G-code file
« on: December 28, 2014, 01:44:29 PM »
I have a strange problem with Z-axis controle.
When I load in the G-code file everything looks normal, Z-range is between +12 and -18.29 as expected.
When Mach runs the file, Z-axix goes deeper than -18.29, it goes down to -19.********* so I stopped the machine in order not to damage the fixture.
The indication on the Z dro is consistent withZ-axix positions, so it indicates -19.********* as well, so no calibrating problem.
All offsets are 0.
It's a fresh installation ( a few weeks) and the tool is a straight MDF one with square edges.
X and Y seems to be normal.
The same problem occurs with another G-file where it goes over 2mm deeper than it should, again I stopped the machine.
Again DRO indication and Z position are consistent. Retracts are too low so the tool hits allready milled areas on aproaching the end of the job.

5
General Mach Discussion / Re: MACH3 pendant keyboard doesn' t work.
« on: September 28, 2014, 04:51:55 AM »
Thanks Klaus, it's solved.
 I missed the extra "(Dn " and "Up)" buttons on page 50.
Regards

6
General Mach Discussion / MACH3 pendant keyboard doesn' t work.
« on: September 25, 2014, 07:50:01 AM »
I have a USB pendant keyboard which I bought from a Chinese seller who claimed it would work for Mach3.
It emulates jog xyz, jog rate  and a few other functions.
Everything works except jog rate.
When I push "Jograte down" Jograte goes up, and when I push"Jograte up" nothing happens.
Clearly the transmitted codes are incorrect and I cannot find a way to change the MAch3 hotkey codes. Some programs I downloaded (screentweak, machscreen ) always seem to have the wrong version number to enable me to do what I have to do(change hotkeys in Mach3).
The pendant transmits code 221 for "jograte down" and 187 for "jograte up" and I think Mach3 expects code 221 for "jograte up" and 219 for "jograte down" whenI'm not mistaken.
So does anyone know a method to make this work?

Pages: 1