Hello Guest it is March 02, 2024, 04:27:38 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Ironic

Pages: 1
1
Tks for the tip Stirling.

At least no more wasting time.

So if i stick to button scripts, how do i get around the issue (or that it seems to be for me) that DoButton(3) stops the script execution so the instructions after that do not run?

Regards



2
Hi BR549

So i already had the M1000 in init line so with your new code i get TriggerMacro#1001 when mach3 starts or i double press reset.

With your new M1001, with a simple gcode( M3, G01 X100,G01 Y100) i press the probe during the movement but i only see the message when the program ends.

If i instead i assign the code to a button script i does show up in real time.

So trying you original code if i touch the probe it seems to try to run the code on the end of the program but says nothing to feedhold.
If i instead assign it to a button it pauses when i click but then says Terminating script. From the tests i made it seems the DoButton(3) 'Stop also stops the script execution so nothing else after that is runned.

Tricky tricky

Tks

3
Did another debugging test.

If i put your code in a button script it works.

But if i instead in the button script i just put CODE("M1001") nothing happens if it is moving.

It seems i can run button scripts while machine is moving but i cant call macros...

4
Hi

Tks for the help but i am feeling dumb here.

I i think i have done all of that.





In C:\Mach3\macros\Mach3Mill i have M1000 that just has:

Code: [Select]
SetTriggerMacro(1001)
Message "Ready" 

And the Ready prints out when mach3 starts up or i press reset.

 M1001 has the code you suggested.

But nothing happens when the pin goes low (running program or not).

To debug i used your code in a button script and that works.
Do not think it is electric issue, since it work for probe and i can see the pin go low in diag screen.

Regards

5
Hi.

So the thing is can't get this to run.

I have OEM Trig #1 active and associated to a pin.
A macro called M1000 with a single line : SetTriggerMacro(1001)

(M1000 is in the init line of mach3)

And a macro called M1001 with your code.

Anything missing?

Regards




6
Tks

Will try on monday.

Rgds

7
Hi guys.
Been reading this forum for some time now, learned a lot but I need help now that I could not find an answer on my own.

I would like to associate a script to a button. Something similar to E-stop, but that instead would do feedhold, stop spindle and raise the Z axis.
This is to stop program if i think the part is cut all the way trough, but still be able to resume if it is not.

I can do a script that does this, but it will not run if a program is running. I assume you can't run Gcode in a script while the main Gcode is running.

Any thoughts?
Tks

Pages: 1