Hello Guest it is November 29, 2021, 04:45:12 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Durero

Pages: 1 2 3 4 5 6 »
1
Fantastic help Craig.

I really appreciate your detailed posts, perfect for my inexperience with Lua programming & Mach4!

I'll try this out and report back as soon as I can.

Cheers!
Leo

2
I would like to make custom m-codes in my cutting programs that trigger an alert box on the screen which has to be clicked on by the user before the program will continue.

I have two examples in mind:

1.  An alert box close to the start of the cutting program which reminds the user to set Z-zero to the top of the workpiece or to the table.

2.  An alert box which pauses cutting in order for the user to re-clamp the workpiece before continuing cutting.


I've tried searching for how to do this but I'm not finding any lua-scripting examples which trigger an alert box on the screen.

Is this possible?  And can anyone steer me in the direction of where to start?  I've read through the Mach4 scripting manual but there are no hints for how to make an alert box.


Any help would be much appreciated.

Leo

3
Mach4 General Discussion / Re: Advice on how to store RRO between sessions?
« on: November 21, 2017, 01:14:17 PM »
Ah ok that sounds much easier!

Thanks very much for that.  I will try this method first.

Leo

4
Mach4 General Discussion / Re: Advice on how to store RRO between sessions?
« on: November 21, 2017, 02:06:53 AM »
Great - thanks very much for all of that clarification and guidance Craig!

I will give it a go tomorrow when I'm back in the shop.

I never thought to update the register when changing the RRO screen control.  I might try updating on screen unload when Mach4 is closing too, or whichever option I can get working first.

Thanks!
Leo

5
Mach4 General Discussion / Advice on how to store RRO between sessions?
« on: November 21, 2017, 01:31:31 AM »
Still trying to wrap my head around lua programming in Mach4.

So to save my RRO setting between sessions, should I create a register?

Then save the last RRO setting on screen unload?

Then set RRO to the stored rate on first run of the PLC on Mach4 startup?

If anyone has any hints or tips for this it would be greatly appreciated!

I suspect that this is an easy one for many of you.

6
I believe you need a device with analog inputs such as the Pokeys devices.

7
Mach4 General Discussion / Re: Error: Axis 3 commanded while disabled
« on: October 16, 2017, 05:13:53 PM »
Hi Craig,
I've checked very carefully for any A axis moves in screen load and PLC and there are none.

I do have to reference the axes on startup.  Is that what you mean?

I've also checked that A axis is not enabled in homing or limits in Mach4 settings and in ESS settings.

Steve I just tried setting the home in place for the A axis, and the error is still there on startup!

This is a stubborn little bug!

Thanks very much for the suggestions so far :)
Leo

8
Mach4 General Discussion / Re: Error: Axis 3 commanded while disabled
« on: October 16, 2017, 04:32:16 PM »
Yes that's the same thread I included in my post.  I've already fixed the Go To Work Zero problem as stated.

The error is now appearing on startup, not on Go To Work Zero button press.

I've read that entire thread carefully and did not see the problem I am having be mentioned, let alone solved.

9
Mach4 General Discussion / Error: Axis 3 commanded while disabled
« on: October 16, 2017, 04:23:47 PM »
I'm getting this error now on startup of Mach4.

It began when I tried Go To Work Zero for the first time.  I found that error and fixed it in the screen startup script - same as explained in this thread: https://www.machsupport.com/forum/index.php/topic,35600.0.html

So my Go To Work Zero button is fixed and works perfectly, however since then the Axis 3 error keeps appearing on startup.

I have searched everywhere I can think of for some A axis reference that I may have inadvertently awoken when fixing the Work Zero thing but I can't find anything.

Any ideas of how to fix this would be greatly appreciated.

Thank you.
Leo

10
PoKeys / Re: Does Pokeys 57E support more than 4 axis in Mach4?
« on: October 11, 2017, 04:47:56 PM »
Thanks for replying NeoTO, but I'm not using Mach3.

Anyone able to answer this regarding Mach4?

Pages: 1 2 3 4 5 6 »