Hello Guest it is August 18, 2019, 11:59:23 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - gearsoup

Pages: 1 2 3 »
1
General Mach Discussion / Re: Mach3/DB25/BoB issue?
« on: October 16, 2011, 08:44:59 PM »
It lives! woot!
I tied a few things, then I went into the BIOS and changed the LPT port from EEP/ECP to Bi-directional. wadda ya know.

still need me to attach my xml?

2
General Mach Discussion / Re: Mach3/DB25/BoB issue?
« on: October 16, 2011, 07:05:30 AM »
So, it appears that Mach3 is not talking with the printer port. the computer recognizes it, but there doesn't seem to be any communication between the 2. What to do, what to do......

3
General Mach Discussion / Re: Mach3/DB25/BoB issue?
« on: October 15, 2011, 05:16:34 PM »
after reading a bit. I think I numbered the pins wrong. I was going from left to right (looking at the back of the PC) Mach3 documentation shows that top right is Pin 1. So, I guess that changes things a bit.

4
General Mach Discussion / Mach3/DB25/BoB issue?
« on: October 15, 2011, 05:01:41 PM »
This is probably a "no-brainer", but I figured I'd toss it out here and see what I got.

I bought a "new computer HP Compaq DC7600 Desktop PC - Intel Pentium 4 3GHz, 2GB DDR2, 40GB HDD, Combo, Windows XP Pro at TigerDirect.com for my CNC router that I built 9 years ago.

It was running on some very old dinosaur running Windos98 with Master5 software. Yup. Master5. The CNC and PC have been in storage for several years now. I've gotten the urge to seriously start playing with it more.

Anyways, I took the opportunity to upgrade to Mach3 (demo version for now). I went to the Config dialog in Mach and confirmed that the printer address matched what was in the Resource window of the Printer Port dialog (in Window Hardware manager). The resource lists it as 0378-037F. Mach 3 keeps reverting back to 0x378. I assume this is correct?

I configured all 6 pins. There is one step and one direction pin for each motor. I do not have any limit switches or E-Stop switches setup yet. I will get to those later.

My breakout board is a simple PCB, no opto-isolators or anything. I am using pins 2,3,4,5,6,7. X,Y,Z respectively.

So, pins are configured, I've set the steps per inch to 10,000, since that I what I ran on Master5. I press the arrow key to job the machine, and .....nothing happens. It does not jerk, hum, or anything. It just sits there. Yes, there is power to the motors.

I borrowed a rather nice multi-meter from a co-worker, sad part is, I have very little clue where to start and what to look for (also, I've only used a multimeter a couple times in my life, and not for anything much really)

At any rate, I grounded out one lead and inserted the probe tip into each pin of my printer port and got these readings: Pins 1-4 are at 4.51 volts and .25 amps. Pins 5-12 are at 3.40 volts and 0 to .01 amps. Pin 13 is 4.51 and .026 amps. Pins 14-21 are 0 and 0. Pin 22 is .01 and 0. Pins 23-25 are 4.51v and .26A.
None of these values change when I depress a key to "jog" the machine. If I unplug and reconnect the printer cable, my motor will jerk one or two steps it appears/sounds.

If I am in Hardware manager and I uninstall the printer port, the 4.5 volts goes up to 4.85. When i click on "Scan for hardware changes" it drops back down to 4.51volt.

So, I am lost as to where to start and what to do. Any ideas on how to help me out? I am an almost total electrical noob. But, I'm able to comprehend ideas and whatnot...

5
General Mach Discussion / Re: Configuring Mach 3 on new PC
« on: October 15, 2011, 05:01:01 PM »
made a new thread to detail the issue I am dealing with.

6
General Mach Discussion / Re: Configuring Mach 3 on new PC
« on: October 12, 2011, 05:55:48 PM »
Yeah, but I'm a machinist IRL, and there are times when I am sitting at my machine twiddling my thumbs... Would be nice to have something prosuctive to leaf through

7
General Mach Discussion / Re: Configuring Mach 3 on new PC
« on: October 12, 2011, 04:19:28 AM »
oh, wow. very nice. thanks! hmmm, wonder if my printer has enough ink for 106 pages......., lol

8
General Mach Discussion / Configuring Mach 3 on new PC
« on: October 11, 2011, 08:58:22 PM »
About 9 years ago, I built a CNC Router and had it up and running on Master5. Ran rather nice. The machine went into storage for a while, family used it, yadda yadda. I just finished rebuilding it (I made a lot of noob mistakes first time around) and I bought an "off-lease" PC from Tiger Direct. I wanted to use Mach 3 to set up the machine this time around, but to be honest, I have no clue where to start. Port settings, inputs, outputs and motor tuning? WTF did I get myself into?!?!?!?

As I mentioned, this was a full 9 years ago. I "think" I can scrounge up the old PC and maybe hopefully pull the settings off of that. Would this work?

If I need to start from scratch....oh boy, this oughta be fun.....

Little info:

I can't quite recall the makes and models of all the itmes used but what I can recall is this much:

Keling 72 VDC power supply (yeah, 9 years ago, I thought that bigger was always better)

No name BOB. Simple PCB with one whole strip of terminals on it. Currently, there are only 6 wires coming off of it headed to my:

Geckos. Not quite certain what version they were. I bought those used from someone on Art's forum that he had back then.


9
General Mach Discussion / quick question about the demo version of Mach
« on: September 06, 2011, 07:45:06 PM »
Aside from the 500 line limit, is there anything different about Mach3 licensed? Only reason I'm asking is becuase I'm still in the process of building the machine and I was wondering if I'd be able to tune the steppers and test out all my wiring issues with a demo version, or should I buy the license at this stage...


GS

10
Finished Screens / Re: MachMotion's Ultimate Screen 2.0
« on: April 06, 2011, 06:49:02 PM »
Cool, thanks!

Pages: 1 2 3 »