Hello Guest it is August 13, 2020, 05:14:18 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - deepaknarkhede

Pages: 1
1
VB and the development of wizards / push to on and release off button
« on: April 06, 2016, 02:21:21 PM »
dear all,
I am trying to convert Reverse run button as push to on and release off. so that reverse run will be done only while it is pressed and no need to use Pause button again. I tried code like "while button=1" but cant find exact code. I could only add feed lower along with Reverse Run setoemdro(821,10) dooembutton(279) similerly I added FRO Reset to Cycle Start Button. pl help.
deepak

2
General Mach Discussion / coil winder spindle control
« on: January 12, 2015, 07:24:10 AM »
Hello,
I have built small coil winding machine whose wire guide is controlled using x,y and z axis of mach3. The spindle is servo motor controlled on A axis. While winding my g code goes like,

G0 A0Y0
G0A30Y10       layer 1
G0A60Y0          layer 2
G0A90Y10       layer 3
G0A120Y0       layer 4
and so on.
 The problem is at every end spindle stops with defined accn and dccn time which is very time consuming.

How can I continuously run the spindle without stopping at the end of every layer?

pl help.
deepak

3
General Mach Discussion / Re: mach3 on waterjet
« on: December 29, 2014, 12:15:58 PM »
sorry,
Now you can assign button on screen with Run VB script in screen designer.

4
General Mach Discussion / Re: mach3 on waterjet
« on: December 29, 2014, 12:14:07 PM »
first assign output# in ports and pin output. then using menu Operator- VB script editor create file in mach3-macros  with extention .m1s  Use M101 and further. for example M101 to turn on water ,M102 to turn off water etc. the script will go like   Activate signal(1)   and  Deactivate signal(1)
Now y

5
VB and the development of wizards / coil winding machine
« on: December 29, 2014, 11:54:31 AM »
hello,
I am controlling coil bobbin winding machine with mach3. Here machine starts with winding coil ends on bobbin pin and then spindle starts. the layers are formed with required turns. Again coil terminates  at bobbin pin.
Now I have few difficulties . When coil ends with say 100 turns my A axis holds '100' . When going for next coil I have to manually zero A axis, hope fully there is some command for this. Secondly when changing the size the whole program has to be made manually step by step, can it be done like operator will move the axis manually and each point will be saved as program as in MDI Teach.
thanks

6
General Mach Discussion / output control with hotkey
« on: August 14, 2014, 09:35:00 AM »
Hello all,
I know it is a stupid question bu I m stuck up at this point.
I have built oxyfuel cutting machine and working fine. Now I want to add Auto Ignition Button. I wish to use hotkey from keyboard and the function of relay on output no 16 should be such that when I push Hotkey , relay should turn on and when release it should turn off.
please help.
deepak

7
General Mach Discussion / Re: home switch and limit switch problem
« on: July 29, 2014, 07:25:42 AM »
hello,
I have the similar problem. I want MACH3 to reference the machine to Home at beginning. I have connected Home switches for three axes. Now whenever I feel I have lost the position, I need some way by which I can go to home limit and at the trigger of Home  proximity switch, the axis will calibrate to Zero.
pl help.
deepak

8
dear sir,
I have the same problem.
I m working on mach3 demo,  it works fine till I use Reverse Run. When Reverse Run is used sometimes it moves in reverse, other dont. If it reverse after forward cycle start it moves forward but repeats the same circle twice and at the end of circle I get the message Radius to end of arc differs from radius to start on line ##”

deepak

9
General Mach Discussion / pcb drilling machine
« on: November 28, 2012, 06:15:28 AM »
hi
I constructed pcb drilling machine with leadshine driver and stepper motor 2A running on mach3.
I m facing a problem. The Z axis moves as

Z0
G1
Z-3
G0
Z3

It moves as instructed but moves few steps up more. After 20-30 holes Drill gradually goes up and doesnt drill at all.
I tried with Active Low for direction but still it moves upward gradually. I reduced acceleration but didint work.
What could be the reason kindly help.
Thanks

Pages: 1