Hello Guest it is November 30, 2022, 10:25:24 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MegaMoog

Pages: 1 2 3 »
1
Mach4 General Discussion / Re: Add or edit Mach4 Lathe screen
« on: May 06, 2019, 06:51:00 PM »
daniba,

(Is it possible to add a sound to the "Change tool" LED?
A simple "beep" at every impulse would be excellent.)

Did you get the sound to work when tool change led is flashing?
If so how... with details please

Thanks

2
Mach4 General Discussion / Re: Turn Cycles - Taper
« on: March 13, 2019, 06:34:53 PM »
Your Xi should be larger than Xf,
 See attached pic

No guarantees :)

This is what I used for trial.

MM

3
I have been trying different settings in the lathe cycle for threading.
I'm not sure if this is a bug or some setting that just does not want to work.
If I change the Xc ( X Clearance ) from .010" (this will work thru COMPLETE) to .100" the program just hangs near the end n won"t complete the cycle?

I've attached the 2 files for comparison. I did not run either of these thru M4 simulation but ran my lathe using these.


ThanX MM

4
Try this configuration file if other one is corrupt?
Unzip then import from Lathe Cycles Tab...


MM

5
Hi,
Has anybody else had this happen with Mach4 Lathe Cycles?

Dell Desktop
CPU 650@3.2 Ghz
8 Gb ram
64 bit
Windows 10 Pro, Ver1803
...............
Mach4 Hobby 4.2.0.3804, Licensed

...............
PMDX 416
Gecko G540
...............
Turn Cycles

Program runs the OD Cycle, Tool 1010
then runs the Threading Cycle, Tool 1111
it finishes the physical threading OK.....
then near the end of  the program just hangs there..... line with M09.....
It kicks out the Cycle Start/ GCode Button..... Greyed out... (Not sure but I think that is greyed out on any time the Cycle start Button is pressed?)

So I have to hit Disable Button n re-Enable Button n then hit Cycle Start n It will finish / Rewind Program back to beginning.

But if I do not post thread cycle but just turn cycle it will finish n rewind as it should at M30

The attached files are the .tap file.
  The .txt file extension was changed from .ini so it could be uploaded, you will have to change it back to .ini to use in Mach4  Lathe Cycles

Thanks MM

6

Re: Tool Setter ? on SK-66A-KC

Postby Megamoog ยป Fri Aug 03, 2018 3:46 pm
Hello,
Thanks for looking at the schematic even though it did not scan well!

I kinda new/figured out that the (Brown & Orange wires) connect to the same pin outs as the (Red & Grey wires) do!
I just could not see the LED come on with only 5v. I turned off the light above my work bench n pressed the tool setter down n I could see a very dim light.
I might get a 24v power supply n use that for the Tool Setter n Probe. Use some resistors on the home/limit switches for the X, Y, Z, A, & C. (Not that I need the light but I thinks it would be kinda KOOL!) :P
That's one of the reasons I like using the MSM screen in that it has the second pp port on the setting page which helps in setting the pin outs for the connections.
I will be using the pins 2 - 9 and 10 - 15 for inputs on the C10 board via my second pp port.

Now I'm workin on getting the Z axis trammed n will be mounting the A & C axis trunnion... :) :shock:

Time to get back to the Lab n do some experimentin.....!!! 8-)

Thanks n hope this helps somebody thinkin of using one of these or similar units.

Larry

7
Hello,
I'm lookin for some help in setting up my Tool Setter in Mach3.
I have :
Win XP SP3
Mach3 .066 (Licensed)
Using CNC4PC C10 Rev 11.1 board for inputs
I Have a 5v DC power supply, (saw online that 5 to 24 volts will work)
Using the SK-66A-KC Tool Setter with N/O contacts for tool touch (Red & Grey wires) = Works OK
(Blue & Green wires) N/C contacts for Over Travel = Works OK

But I'm curious as to how the (Brown & Orange wires) are to be wired/used? Is there an built in LED that would light up?
I have the wiring diagram (see attachments) but by no means am I an electrician???

ThanX, MegaMoog

8
 :) :) ;)
  ThankZ DaZ...  U da Man... ;)

9
That's more recent than I had. :)
Up to n including 3481
But I was hoping for the Developmental versions... such as 3692


ThanX ger21 :)

10
Does any body know how to get the latest CHANGE LOG for the developmental versions @ the ftp site?
The latest one I found there was for 3383-3377 dated 5-4-2017.

I have downloaded 4.2.0.3692 n installed, but am curious as to what has been changed?
I'm using M4 for my lathe n not sure if there are any updates for that.

ThanX MegaMoog

Pages: 1 2 3 »