Hello Guest it is April 19, 2019, 05:09:50 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Andre007

Pages: 1 2 3 4 5 »
1
Hi All

Its sorted. I have re-checked the touchplate thickness. My touch plate setting thickness was set at 2.0mm , but the real thickness turned out to be 2.28mm. This made all the difference. :)


Thanx to everyone for suggestions and comments.

another happy chappy
andre

2
ok, so i have done the auto tool zero operation. all works fine and the operation completes flawlessly.

No Gcode is loaded yet.

When i type G0 Z0 the tooltip moves down to the workpiece , but keeps a 2mm distance from the stock. Its like the plate on top of the stock is still there.

What i have noticed is that when the auto tool zero completes and the tooltip pull away after the last slow auto tool Zero , the tip pulls away to clear the stock. This looks normal , and i can remember is a setting that is inside the macro that handles the tool zero operation.

All seem to be normal, but the tooltip is still (2mm)away from stock zero when i enter G0 Z0 into the DRO and hit enter.

Thanx
A

3
Hi

I will run this test tonight and see what it does..

Thanx,
andre

4
I also have the fixed plate on the table, and the routine works fine when i run it. Till i find the culprit responsible for the aircuts, i `m gonna have to Zero the z-axis by manually.

Thanx
andre

5
Hi

I`m using the 2010 screenset. All macros supplied and in mm units. A have seen a lot of positive feedback on it, and it works fine and the moves are correct, but when it comes to the cutting part of the 1st depth increment, its above the workpiece.  I suppose in time as it get to the increments , it will eventually strike the workpiece, but not when it starts out.

This problem i never could get fixed. I had to cheat by eyeing the top ZERO on the workpiece. All the cuts i do, is done by eye Zeroing, but it would be nice for it just to work.
I bought the 2010 screenset to get away from editing the scripts , but it seemed that something else ...a setting in Mach3 maybe , is keeping me from getting it right.

My settings im Cambam is negative from ZERO , so -0.05 or -.5 , so it has to go down if + is up

UNLESS the problem lies when i ZERO the machine. My Zero setting is at the home position at the top end of the z-axis. I have been thinking bout this as well.
When i Zero the machine, Zero lies at the top (bout 100mm from the machine worktable). Does the auto zero option Zero the machine then back to the workpiece top , or does it just adjust the difference to work out workpiece Zero ?.

Thanx
A

6
Hi All

My problem is still not fixed. I have installed the 2010 screenset which uses mm. Problem is still that mach3 is cutting air above the workpiece. The only problem i can see is that the plate thickness is not subtracted correctly so the mill can get to the workpiece.

I can get something to cut if i remove the plate and manually zero the mill to the workpiece. This works, but i would like to use the routine . Its difficult to see with the eye when the mill is just touching the workpiece.

THX
A

7
Hi

The standard one that comes with the installation. ... no mods.

TX
A

8
no ideas ANYBODY !

9
Hi All

The script below must have been seen by a lot of users using cnc machines and mach3. A lot of the lines are self explained, but this is the problem i had trying to make this script work for me.
The whole procedure woks fine, and the toolbit moves down , touches the touchplate that is 2mm thick and moves back up. Mach3 tells that machine Z is now ZERO-ed.

The problem i had was this. I had to tell mach3 that my plate was 2.7mm thick and not 2mm in order to get the toolbit to be exactly on the workpiece surface.
Before  the toolbit was always like 1 mm , sometimes 2mm and other times .5 mm above the workpiece surface.
Now i realized that all machines and hardware are different in setup than just inserting the script and expect it to work will not be as easy.

I want to know now, what setting is causing this . My machine is calibrated on the z-axis , so 15mm is 15mm when i use the motor calibration option. Below is the script.

Thanx in advance everyone.
Andre

PlateThickness = 2.0 'Z-plate thickness DRO ' This option i had to change to 2.7mm in order to get it to work properly.

If GetOemLed (825)=0 Then 'Check to see if the probe is already grounded or faulty
DoOEMButton (1010) 'zero the Z axis so the probe move will start from here
Code "G4 P5" ' this delay gives me time to get from computer to hold probe in place
Code "G31 Z-0.5 F5" 'probing move, can set the feed rate here as well as how far to move
While IsMoving() 'wait while it happens
Wend
ZProbePos = GetVar(2002) 'get the axact point the probe was hit
Code "G0 Z" &ZProbePos 'go back to that point, always a very small amount of overrun
While IsMoving ()
Wend
Call SetDro (2, PlateThickness) 'set the Z axis DRO to whatever is set as plate thickness
Code "G4 P0.25" 'Pause for Dro to update.
Code "G0 Z 20.0" 'put the Z retract height you want here
Code "(Z axis is now zeroed)" 'puts this message in the status bar
Else
Code "(Z-Plate is grounded, check connection and try again)" 'this goes in the status bar if aplicable
Exit Sub
End If

10
General Mach Discussion / Re: Mach3 loses home settings
« on: September 28, 2012, 01:48:35 AM »
I click the "ref ALL" button and the axis move all the way to the left and bottom of the machine. Sometimes i have to click the ref all button a few times . When the machine hits the switches , it moves of the switch , just as described by the manual/video. So i`m actually homing the machine.

I must be missing something again. I`l keep trying till i get it.

THX
A

Pages: 1 2 3 4 5 »