Hello Guest it is February 26, 2024, 05:13:42 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - argofanatic

Pages: 1
1
Mach3 and G-Rex / Re: G 100 Auto boot time
« on: May 23, 2007, 03:20:21 PM »
Does that mean you can't get back into the loader program ?
If so, start the GRexLoader program. Unplug the G100, plug it back in, and click on the Find Gecko a couple of times until you get an IP address then click on the launch Firmware Loader button immediately (you only have 3 seconds).

2
Mach3 and G-Rex / Re: G100 found and runs though Firmware not "Run"
« on: April 29, 2007, 06:03:55 PM »
Hi, you definitely need to run the firmware. That's how the plugin will communicate with the GRex.
Unless I'm missing something here, setting the autoboot to zero would launch the firmware without waiting (wait zero seconds).
The challenge could be to get back into GRex with the web interface since the firmware will already be running.

3
Mach3 and G-Rex / Re: GRex motor tuning and general configuration ?
« on: April 11, 2007, 10:40:51 PM »
Hey Mike, thanks again mate!

You're post pointed me to the "Customization WIKI" which documents the VB commands and constants for Mach (you were 100% correct by the way).
Are you sure you're not a "covert" Mach/Grex support guy ? ;)

Marc.

4
Mach3 and G-Rex / Re: GRex motor tuning and general configuration ?
« on: April 10, 2007, 08:22:39 PM »
Excellent!

One more question, if I may.
Would you know what is the G or M codes are to toggle the various outputs ?


5
Mach3 and G-Rex / Re: GRex motor tuning and general configuration ?
« on: April 10, 2007, 06:56:35 PM »
Hi Mike,

That was incredibly useful !
Thanks.  :)

Have you configured the outputs ? I'm going to assume that they use port #1 and pins 2-8.
I'm using a G101 so, I have some soldering to do before I can test things out.

Marc.


6
Mach3 and G-Rex / Re: GRex motor tuning and general configuration ?
« on: April 09, 2007, 05:03:57 PM »
Ok then.
Since I have to figure out this stuff for myself, I'll try and help the next poor soul that comes around looking for answers.

I finally got Mach to recognize the inputs.
The port number needs to be port #1 (for the inputs at least). That works for Mach input pins 9-16 (GRex inputs 1-8).
Ill wire up the other GRex inputs (9-16) and see where they match up.

No joy on the GRex limits. I'll have to test and see if they are hardware limits handled by the GRex itself.
Mach doesn't seem to recognize them, at least not yet.

7
Mach3 and G-Rex / Re: GRex motor tuning and general configuration ?
« on: April 09, 2007, 12:59:49 PM »
 :( Still no joy.

I can get the motors to turn no problem.
Inputs and outputs are really starting to annoy me!

Is there something I am missing in the configuration ?
The G100 monitoring screen shows all my inputs and limits functioning but Mach just doesn't get it.

Here is a sample configuration I am using:
Signal   Enabled     Port#   Pin Number   Active Low   Emulated     Hotkey
X++      Checked     0           9               Checked     Unchecked     0
X--        Checked     0           9               Checked     Unchecked     0
XHome  Checked     0           1               Checked     Unchecked     0


What am I missing here ???
HELP !!!

8
Mach3 and G-Rex / Re: GRex motor tuning and general configuration ?
« on: April 04, 2007, 02:45:07 PM »
Hi Mike,

Yes and no. I've been busy finalizing my wiring so I have a nice clean setup rather than a mess of wires twisted together, so no time spent trying to get things working.
I did notice however that I can change parameters in the motor tuning page and save them for the axis. These parameters take effect if I then type in manual commands for the axis (G0 X25 for example). No luck "dynamically tuning" using the up and dn keys like described in the Mach manual.

I should have some time to work on it this weekend so I might have more to report soon.

No much help coming from this forum, there are GRex users somewhere, ... but where ?

:(

9
Mach3 and G-Rex / GRex motor tuning and general configuration ?
« on: March 18, 2007, 03:24:38 PM »
Hi all, my first post here. (Hopefully not the last)

I'm a CNC newbie and Mach newbie also, so please be patient with me if I ask obvious questions.

I purchased a GRex and spent the last several weekends building power supplies and wiring a test bed together.
Today I actually connected a stepper to my G203V which in turn is connected to my RGex.
I successfully flashed with the most recent firmware (March 10/2007) and can communicate with it.

I downloaded the manual(s) and tried to tune my stepper (not attached to my other hardware yet).
I know that the stepper is wired correctly because if I load one of the supplied GCode samples and run it, the stepper happily spins in both directions!

Following the motor tuning instructions I can't get the motor to spin ?


Here's what I have so far with regards to configuration.

From the Engine Configuration dialog:

Port Setup and Axis Selection
   I left everything in default settings (Nothing enabled).
Motor Outputs
   I enabled X, Y, Z, A, B, C (I will be using them all) and left all other settings at default (Step Pin=0, Dir Pin=0, Step and Dir ports = 0, Both Active high)
Input Signals
   I enabled all the Home and Limit switches and left all other settings at default (Port=0 Pin = 0)
   The GRex monitor screen shows that they are working, but how do I map them in Mach3 ?
Output Signals
   I did not enable anything but I will be using some, again how do I map them in Mach3?
Encoders
   None.
Spindle
   Defaults
Mill Options
   Defaults


Any help configuring my GRex with Mach3 would be greatly appreciated.

Thanks,
Marc.

Pages: 1