Hello Guest it is January 24, 2020, 08:48:44 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - benfly

Pages: 1
1
Oh duh, didn't see it, Thanks much!

2
Awesome BR549, I'd love to see it, Thank you!

3
VB and the development of wizards / Run script when cnc cut finishes
« on: July 14, 2011, 12:58:13 PM »
Hello all and thank you for reading :),
 
I'm interested in having Mach 3 text/sms/message me when it's done cutting my part.  Sometimes it takes forever to cut a part and I'm OK with leaving it to cut on its own for hours (I like to leave the noisy router room and maybe watch a movie or do something in the yard, or eat some food, etc).  I have some good VB programming experience so I'm comfortable with creating a script that emails/texts/sms messages me, I just need to know how to get Mach 3 to invoke/run my script when it finishes cutting. 

Thanks again,
Ben

4
Works in progress / Re: New Router Screen
« on: February 11, 2011, 11:23:33 AM »
Here's a modified version of my other screen set for a single Z axis router.

 I haven't really tested it, but I think everything is working.

There is no toolpath on the Run screen. The reason for this is that CPU usage is about 75% lower without the toolpath on the screen, and when your cutting, you're usually looking at the machine, not the screen. This should make this screen run better on slower PC's than the standard screens.

Unzip all the .png files to Mach3\Bitmaps\Router\ and put the Router.set file in the mach3 folder. It's setup for spindle to use Output 1 and Coolant Output 2.

Let me know if there are any issues and I'll fix em up.

http://home.comcast.net/~cncwoodworker/CNC/Mach3/Screens/M3Router.zip

Also, here's the Real Draw Pro files if anyone wants to modify the Screens (you'll need RealDraw Pro).

http://home.comcast.net/~cncwoodworker/CNC/Mach3/Screens/M3Router_RealDraw_Pro.zip





So, how do I change from inches to mm in this screenset?

5
G-Code, CAD, and CAM discussions / Millimeter, mm, inches problem
« on: January 04, 2011, 06:21:49 PM »
So, any one else have problems creating a millimeters profile?  I've tried several things in order to get Mach 3 to stay in mm once I restart it.  It always loses my settings.  The two places I've messed with are in the native units from the config menu, and the units in the settings tab.  Mach 3 seems to remember that I've set these two things (or just one) to millimeters, but when I exit and come back in my DRO reads in inches or even sub-inches.  Any ideas?  I've clicked 'save fixture settings' after I exit Mach 3 and I've clicked Save Settings in the config menu after I've edited anything, all to no avail.

I'm willing to switch to EMC 2, I actually have it all ready to go on my machine but I can't get it to communicate properly with my motors whereas Mach 3 picked it right up. anyone have experience with EMC 2?

Thanks in advance for any help.

benfly

Pages: 1