Hello Guest it is August 13, 2020, 04:01:13 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TheLaserShop

Pages: 1 2 »
1
General Mach Discussion / Re: Trouble with the iMach Pro pendant
« on: January 24, 2010, 07:59:15 PM »
4.7V is more than plenty for a high leve - as good as you'll get, in fact.  Are you getting a good *low* level?

Regards,
Ray L.

I take that back. The breakout boards require 12 to 30v to activate an input. No wonder the board Leds are so dim. All my limits and axis solenoids are 24v so that hasnt been a problem. To be clear, the outputs (every axis/mode wire) from the iMach are a postive voltage, is that correct?

2
General Mach Discussion / Trouble with the iMach Pro pendant
« on: January 24, 2010, 02:59:41 PM »
Using Mach3 with a dspMC controller w/Mach Motion breakout boards. Boards are a 5 to 24v input range. I have a solid 5v going to the iMach but it is only outputting 4.7 volts to the pins. They barely light up. On my Mach screen I can see the Leds go on and off as I turn the selects on the iMach pendant. The "Action Button" will not trigger the Led on the Mach screen though I can see it toggling, very dimly lit on the breakout board. The estop lights up nothing. I know I have the ports/pins setup correctly but I'm not sure what I'm doing wrong. I have the OEMs setup as per the wire colors and as per Ray's macropump. Is there a better way I could install this? Using a mini ATX so I do not have an extra PCI slot for the iMach LPT card. Haven't even got to the actual MPG setup yet. Any suggestions?
RonO

3
No , it only uses the dspmc "C:\Mach3\Mach3.exe /p dspMC". I dont have any other xml's anymore.

4
Hi Ron,
If you want, send me your DSPMC xml file and the Mach3 xml file which would either be the Mach3mill  as the default or if you made a custom profile, that one.

I will take a look and see if it is anything obvious.

Mike


Theres a question. I thought it only accessed the dspmc.xml file. Thats the only one I have ever saved to.

5
I can get my servo motors tuned pretty good in Axis Works but when I start Mach 3 they act totally different and out of tune. I have checked and double checked everything. I Make sure the velocity and acceleration is all the same as I used in axis works. I have uploaded the xml file multiple times. My PIDS have to be sky high to operate in Mach 3 verses what was good in Axis Works. I can manually inspect the XML and the settings are what I saved in Axis Works and there isn't a problem. I go back to Axis Works and all runs smooth as is. I just dont know what I'm doing wrong.

For example I set my X axis PID in Axis Works at P 250 and D 1800. Scale is 1 and I is 0. Runs good in Axis Works and zeros every time. I save and close the program. I check the xml to make sure its saved and start Mach3. Jogging nearly shakes the machine at a variety of velocities. Its not just that particular setting. Whatever setting just does not act the same under Mach 3. What am I not doing right?

RonO

6
I can get my servo motors tuned pretty good in Axis Works but when I start Mach 3 they act totally different and out of tune. I have checked and double checked everything. I Make sure the velocity and torque is all the same as I used in axis works. I have uploaded the xml file multiple times. My PIDS have to be sky high to operate in Mach 3 verses what was good in Axis Works. I can manually inspect the XML and the settings are what I saved in Axis Works and there isn't a problem. I go back to Axis Works and all runs smooth as is. I just dint know what I'm doing wrong.

7
General Mach Discussion / Re: Question about the iMach pendant
« on: January 12, 2010, 10:38:22 AM »
Do you have my macropump driver for it?

Regards,
Ray L.

Show me...

8
General Mach Discussion / Re: Question about the iMach pendant
« on: January 11, 2010, 10:11:33 PM »
Thinking about getting one. I have the dspmc motion so I don't use the printer port. Will the imach work with the PC's printer port or do you have to buy the one they offer? The PC is a mini atx and the only pci port available has a video card already. Are these easy to set up and get working?
Thanks, RonO

The iMach can be made to work with any parallel port, the only functionality you'll lose is the E-stop, which you can wire up separately.  I'm running mine through a Modbus board, and just provided a separate connector for the E-stop.  I'm VERY happy with mine!  It's a great pendant for the money.

Regards,
Ray L.

Once again thanks for your help and input Ray. One more iMach SOLD!!

9
General Mach Discussion / Question about the iMach pendant
« on: January 11, 2010, 09:23:38 PM »
Thinking about getting one. I have the dspmc motion so I don't use the printer port. Will the imach work with the PC's printer port or do you have to buy the one they offer? The PC is a mini atx and the only pci port available has a video card already. Are these easy to set up and get working?
Thanks, RonO

10
dspMC/IP Motion Controller / Any SurfCAM 7 users?
« on: January 09, 2010, 06:12:32 PM »
dspMC mach 3. Looking for a surfcam 7 post. help...

Pages: 1 2 »