Hello Guest it is June 24, 2019, 04:22:04 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ClaudioArrau

Pages: 1
1
General Mach Discussion / Re: 3.3 volts of parallel port
« on: December 25, 2009, 10:22:43 AM »
 ;D Figured out at last.

For everyone that will come across the same problem :
My driver has 2 options, use directional signal (ON), or use the DR as the 2nd pulse (OFF). (via dip switch)
I found 2 datasheets mentioning the above ON-OFF differently!

1st try: ON and laptop. --- The stepper didnt move at all. It made some sounds. The voltage level was tricking the driver.
2nd try: OFF and laptop. --- The stepper moved one way only. I unplugged the DR signal and hardwired it to 5volts and ground. I now know why it didnt worked; that was because OFF means pulse trigged. The transition was missing.
3rd try: ON with desktop pc. --- ON is the correct and means DR as direction level signal. Combined with a pci parallel port, it works
4th try: ON with laptop. --- -//- ...  it works again  >:D wtf ?

These are the "grouped" tries. In between i added to the bread board some NPN transitors ti make it work, but the results were the same


Hope this information helps.

2
General Mach Discussion / Re: 3.3 volts of parallel port
« on: December 25, 2009, 09:11:38 AM »
i am back with no luck  >:(

I used a parallel port via PCI port. The output of that is 0v for LO and 4.87v for HI.
The output of the uln2803 is 0.75 and 4.1 volts

If anyone can help, that is appreciated :(

3
General Mach Discussion / 3.3 volts of parallel port
« on: December 24, 2009, 10:15:30 PM »
Hello everyone, Merry Xmas to all
This is my first time that i buy a cnc system. Got it in parts (from many countries) and now i am trying to make it work.
I am using a laptop. Unfortunately the breakout board hasnt arrived yet
First things first. The driver is the Q2HB88M
It is optocoupled, and as "interface" i use a unl2803. It has 2.7K input resistance and it is mainly for TTL signal. I use +5 volts from a USB. No resistors/transistors etc, just the ic itself with a 10uF capacitor across the power lines.

Problem: I hooked a stepper to the driver. From mach3 mill i can turn the stepper using up and down keys, but whatever i press, it turns in one direction only.
It simply rejects the DiRection signal. Note that when i press UP it moves. When i press DOWN, the state of DR changes.... but the motor moves like previously.
The low value is 0.8 volts and the high is 4.something. I will post the exact values tomorrow !

Any ideas ? Tommorow i'll hook a PCI cart to a PC and see if that parallel port works
 ???

Thanks for any advice.

Pages: 1