Hello Guest it is August 11, 2020, 03:13:58 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - SpaceCat

Pages: 1
1
General Mach Discussion / Re: 4-th Axis running bad
« on: April 09, 2010, 01:36:53 PM »
Hello,

I have only the 4th stepper motor conevted without the rotary axis ready yet, so the setting is 5.5555 for step/...  ((200step*10 microstep)/ 360) = 5.5555... and this is correct

Tried to remove al G64 in code and also CV function turned off.

In mach and motor tuning Velocity = 367020 Acceleration = 94500

Code looks like :
(Just a stupid test of milling on a cylinder with rotational lead in..


     ( TOOLPATH RANGE )
     ( XminX-50. )
     ( XmaxX0 )
     ( YminY0 )
     ( YmaxY50. )
     ( ZmaxZ50. )
     ( ZminZ-49.72 )
(" VerktygsTyp :  BALLNOSED ")

G1 G49 G40  G17 G80 G50 G90
G21 (mm)
G1Z50. F500

     ( G43 = L√§ngdkompensering p√• )
     (  Toolpath : 1 )
G1 G43G0X0Y50. A0 T1 H1 F3000
X-.28Y49.34 A1.96
X-.56Y48.68 A3.91
X-.85Y48.03Z49.99 A5.87
X-1.13Y47.37 A7.82
X-1.41Y46.71Z49.98 A9.78
X-1.69Y46.05Z49.97 A11.73
X-1.98Y45.39Z49.96 A13.69
X-2.26Y44.74Z49.95 A15.64
X-2.54Y44.08Z49.94 A17.60
X-2.82Y43.42Z49.92 A19.55
X-3.1Y42.76Z49.9 A21.51
X-3.38Y42.11Z49.89 A23.46
X-3.67Y41.45Z49.87 A25.42
X-3.95Y40.79Z49.84 A27.37
X-4.23Y40.13Z49.82 A29.33
X-4.51Y39.47Z49.8 A31.28
X-4.79Y38.82Z49.77 A33.24
X-5.07Y38.16Z49.74 A35.20
X-5.35Y37.5Z49.71 A37.15
X-5.63Y36.84Z49.68 A39.11
X-5.91Y36.18Z49.65 A41.06
X-6.19Y35.53Z49.61 A43.02
X-6.47Y34.87Z49.58 A44.97
X-6.75Y34.21Z49.54 A46.93
X-7.03Y33.55Z49.5 A48.88
X-7.31Y32.89Z49.46 A50.84
X-7.59Y32.24Z49.42 A52.79
X-7.87Y31.58Z49.38 A54.75
X-8.15Y30.92Z49.33 A56.70
X-8.43Y30.26Z49.28 A58.66

2
General Mach Discussion / Re: Constant Velocity problem with 4th axis
« on: April 08, 2010, 03:44:10 PM »
Hi, Same problem as I have... Any idees ?

/R

3
General Mach Discussion / 4-th Axis running bad
« on: April 08, 2010, 03:36:33 PM »
Hi, new here but been using Mach for many yrs. I have Build a new welded steel machine and this is performing absolutely great with Gecko drive. I can run the machine smooth and quick with good accurancy.

Now i am building a rotational axis and have just connected the 4th motor into Mach3. After Creating a 4 axis toolpath in PowerMILL i have test runned this in the machine. Now the machine moves smooth when XYZ movement, but if a A-axis movement the machine starts to stop at every block, this makes my machine jumping around..

Is it possible to tun simultaniously 4 axis quick and smooth in Mach-3 ? 

I normaly machine with a feedrate at max 2500mm/min, but machine handles up to 3500mm/min in feed. I tried to change lookahead, G64, and alot of settings, but machine runns about the same..

Any idee?


Machine travels 300x300x300mm and is build with 80x80 steel frame. Using THK linear rails makes this very stable. I have machined in CoCr without any prob, so it is a nice machine..
BR/R

Pages: 1