Hello Guest it is August 14, 2020, 01:42:59 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - hightechkey

Pages: 1 2 3 4 5 6 »
1
PoKeys / About threading and noise problem for Pokey 57CNC
« on: September 12, 2017, 12:11:43 PM »
Dear Sir
I have plan to change my mach3 parallel port control cnc lathe with Pokey 57CNC controller. I have some questions about this pokey controller.

First one is threading function. My old  parallel port control is using index pulse signal for threading and spindle feedback. Is the pokey controller support this function with Mach3 software (Not Mach4)?

Second one is Noise problem. There are a lot of noise effect to the controller and computer when the machine is running (especially Spindle VFD running). Is the pokey controller include noise filter for IO port?

Thanks..
HighTechKey

2
General Mach Discussion / My machine stop while running a program
« on: September 22, 2016, 02:00:41 AM »
I have some problem with my mach3 control lathe machine. My machine stop while running a program. The reset button is blinking but the cycle start led is still on. In my knowledge, the cycle start led will stop when the reset button is blinking. But sometimes, my program finished and some time this same program have occur this problem. My software version is Version R3.042.056. There are 2 parallel ports in my control system. Please give me some advice what should I do to solve this problem.
Thanks..
Hightechkey

3
General Mach Discussion / Charge pump problem
« on: February 04, 2015, 03:43:19 AM »
Dear Sir
I have some problem about the charge pump. My machine has charge pump using port 2 pin17. This charge pump relay stop working while running the program. My software version is 3.043.056 and kernal speed is 35kHz. Please give me some advice for this problem..
High Tech Key

4
General Mach Discussion / Port2 Pin 2-9 cannot use as input signals
« on: January 15, 2015, 03:24:40 AM »
Dear Sir

I have some problem about parallel port 2 address configure. I want to use Hand wheel input pin for Port 2 Pin (2-9). But these (2-9) pins cannot use perfectly as input signal. My problem is as follow..

My port 2 address is 'c010' and the software cannot recognize the pin (2-9) as input. So I change the port 2 address to 'c000' and test again. There are the same problem. So I change the port2 address to 'c010' again and test again. This time the port2 pins (2-9) are working as input and the handwheel can work well. But I restart my mach3 computer and test again with handwheel. I face the same problem. If I change port2 address two times (change c000 and then c010), the problem is ok.

So I need to change port2 address two times when I always start my machine. How can I solve this problem. Please give some advice for this problem. Thank a lot..

Hightechkey

5
Hello Sir..
I have two machine with your controller. One machine use an rotary encoder for spindle feedback and this machine is running well now. But I have no encoder for next machine and I try to use index pulse circuit for spindle feedback. So I connect index pulse signal in one of the input pin in your controller and I set index input signal in mach3 input setting. But this system isn't work. So, I want to know can I use Index signal for Spindle feedback with your controller? Please give me some advice.. Thank Sir..
High Tech Key

6
General Mach Discussion / Re: FRO % zero setting for brain
« on: April 05, 2013, 05:25:04 AM »
Thank all of you.. I can use my feedrate switch well now.. Both of your brain can work well and I use the simple one now.. Thank again Hood, cncalex and stirling..
High Tech Key

7
General Mach Discussion / Re: FRO % zero setting for brain
« on: April 04, 2013, 09:13:57 AM »
Dear Hood
I really appreciate your help.. I am looking forward your reply and brain.. Thank.
High Tech Key

8
General Mach Discussion / Re: FRO % zero setting for brain
« on: April 04, 2013, 03:50:58 AM »
Yes just only two condition is work well here.. But I have 11 condition in my brain and that is not OK.. I write down the sequence that I want in my brain. FRO DRO or Rapid FRO DRO may be OK.. What do you recommend which DRO is more suitable for this feed rate brain.. This sequence is the same with Digital.. Here are the sequence..

Switch Position (0) ---- FRO=0
OEM Trigger 10 ----- No Operation
OEM Trigger 11 ----- No Operation
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- No Operation

Switch Position (1) ---- FRO=10
OEM Trigger 10 ----- Invert
OEM Trigger 11 ----- No Operation
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- No Operation

Switch Position (2) ---- FRO=20
OEM Trigger 10 ----- No Operation
OEM Trigger 11 ----- Invert
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- No Operation

Switch Position (3) ---- FRO=30
OEM Trigger 10 ----- Invert
OEM Trigger 11 ----- Invert
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- No Operation

Switch Position (4) ---- FRO=40
OEM Trigger 10 ----- No Operation
OEM Trigger 11 ----- No Operation
OEM Trigger 12 ----- Invert
OEM Trigger 13 ----- No Operation

Switch Position (5) ---- FRO=50
OEM Trigger 10 ----- Invert
OEM Trigger 11 ----- No Operation
OEM Trigger 12 ----- Invert
OEM Trigger 13 ----- No Operation

Switch Position (6) ---- FRO=60
OEM Trigger 10 ----- No Operation
OEM Trigger 11 ----- Invert
OEM Trigger 12 ----- Invert
OEM Trigger 13 ----- No Operation

Switch Position (7) ---- FRO=70
OEM Trigger 10 ----- Invert
OEM Trigger 11 ----- Invert
OEM Trigger 12 ----- Invert
OEM Trigger 13 ----- No Operation

Switch Position (8) ---- FRO=80
OEM Trigger 10 ----- No Operation
OEM Trigger 11 ----- No Operation
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- Invert

Switch Position (9) ---- FRO=90
OEM Trigger 10 ----- Invert
OEM Trigger 11 ----- No Operation
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- Invert

Switch Position (10) ---- FRO=100
OEM Trigger 10 ----- No Operation
OEM Trigger 11 ----- Invert
OEM Trigger 12 ----- No Operation
OEM Trigger 13 ----- Invert

Thank you so much for your help..
High Tech Key

9
General Mach Discussion / Re: FRO % zero setting for brain
« on: April 04, 2013, 01:33:36 AM »
Dear Hood..
I can't solve the problem like your idea in your screen shoot.. I wrote all of the condition of input in one brain file and test. The FRO value output is only change 0 and 100. And I don't understand about your brain because there is no AND function and there must be many output for some position. I want to write 0 to 10 position of switch in only one brain file. Please advice me more. Thank you reply and please explain me more detail..
High Tech Key

10
General Mach Discussion / Re: FRO % zero setting for brain
« on: April 03, 2013, 10:50:49 AM »
Dear Hood..
My feed rate switch has still error in my brain.. My mach3 version is 057 now.. I change 066 version to 057 version because of your advice. I explain about my problem. I wrote the brain for this 4 inputs (11 point) rotary switch. Firstly, I wrote my brain for all inputs condition in only one brain file. But the brain didn't work well. I printed screen shoot for this brain view. This brain can work for 5 group of input and the other left input group is unstable. I send this brain file and two screen shoot brain view for this condition.. Please see and advice me..

I try another method for this switch. I divided 3 brain files and test. In this time, the feed rate up position set the FRO value correctly. But some of the down condition, the value change feed rate 0 in some position of between two brain files.. I also attach these three brains. One of my machine can work well with these three brains files. But my mach3 version for this machine is 022 and I don't use zero feedrate position in this machine.. Please advice me.. Thank you so much..

High Tech Key

Pages: 1 2 3 4 5 6 »