Hello Guest it is November 25, 2020, 05:55:05 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Len-Tikular

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 »
1
Mach4 General Discussion / Success with LightBurn - Mach4
« on: September 03, 2020, 11:43:05 AM »

Mach4 and Lightburn GRBL3 Gcode.
After a bit of changes to the GRBL3 Gcode produced by Lightburn I finally achieved the results shown.

GRBL sends 'S' to to turn laser on and of.
Any 'S' followed by a number' I.e S57 means turn laser on at 57%. This simply needs replacing with M62P20
An 'S' number followed by a 0 means lase off. And needs replacing with M63P20
When you wish to create filled text like the letter 'O' shown be sure to tell Lightburn that your text is 'Line and fill'

Here is a small part of the code I used.
; LightBurn 0.9.16 George's WIFICARD
; GRBL-M3 (1.1e or earlier) device profile, current position
; Bounds: X0 Y0 to X71.17 Y43
G00 G17 G40 G21 G54
G91
; Image @ 6000 mm/min, 70% power
m2003 (LASER_VECTOR_PWM_PERCENTAGE=75)
m2003 (LASER_VECTOR_FREQUENCY=20000)
m2003 (LASER_VECTOR_GATE_DELAY=0.5)
m2003 (LASER_VECTOR_GATE_DURATION=0.5)
M2004
M62P20 F100.0
T1M06
S200M03 F100
G94 M63P20 
M8
M5
G0X4.98Y4.52
; Layer C00
M3
G1X6.1F100M62P20
G1X2.03M63P20
G1X3.56M62P20
G1X5.59M63P20
G1X1.01M62P20
G1X2.03M63P20



I hope this is of some help to others.

George

2
Mach4 General Discussion / Lightburn Software
« on: September 02, 2020, 01:52:38 PM »
Is anyone using Lightburn to generate Gcode that will run on Mach4 ?

Many thanks.

3
Mach4 General Discussion / Re: Material not cutting.
« on: August 18, 2020, 04:18:38 PM »
Hi Tweekie, I attempted to modify your PP to add

G01 X0 Y0 Z1 F250
m2003 (LASER_VECTOR_PWM_PERCENTAGE=45)
m2003 (LASER_VECTOR_FREQUENCY=20000)
m2003 (LASER_VECTOR_GATE_DELAY=0.5)
m2003 (LASER_VECTOR_GATE_DURATION=0.5)
m2004 (This will Enable the Vector Laser)
G01 X1 Y1 Z1
M62 P20   (This will turn ON the Laser Gate and PWM with the next motion command)

And also need to change all M62 and M63 to P20

Can you help

I'm getting the message
Expected 'Begin section' or 'End Section' to terminate current section on line 72 of the file.
C:\users\My modified pp location.
M2003 ( Laser-vector-PWM-Percentage =75)

4
Mach4 General Discussion / Re: Material not cutting.
« on: August 18, 2020, 12:48:51 PM »
Well Tweekie, I persevered and did manage to cut successfully clean through some 3mm Plywood. I was dead dead chuffed. I also did a wee bit of test engraving to see how things came out. I'm quite pleased with the result. Your PP works great, I modify feed rate and laser power and add the 5 M200 macro's.  You set it up for Port1 so I have to change that also. Maybe I can edit your PP to do all this automatically.

Couldn't have done it without yours and everyone else's help. Many thanks

George

5
Mach4 General Discussion / Material not cutting.
« on: August 17, 2020, 02:02:55 PM »
Even after 4 passes my 3mm plywood has not been cut through. Laser power is set to 45%  Mach4 wont allow me to set the laser higher than 45% the file runs ok but the laser does not turn on!  Laser draws 4.5 at 3.5Amps feed was varied between 100 and 1000mm with the same result. Can anyone help please.

10Watt+ Endurance laser.


(Start of GCode for simple box)
G01 X0 Y0 Z1 F250
m2003 (LASER_VECTOR_PWM_PERCENTAGE=45)
m2003 (LASER_VECTOR_FREQUENCY=20000)
m2003 (LASER_VECTOR_GATE_DELAY=0.5)
m2003 (LASER_VECTOR_GATE_DURATION=0.5)
m2004 (This will Enable the Vector Laser)
G01 X1 Y1 Z1
M62 P20   (This will turn ON the Laser Gate and PWM with the next motion command)
G01 X25 Y1
G01 X25 Y25
G01 X1 Y25
G01 X1 Y1
G01 X25 Y1
G01 X25 Y25
G01 X1 Y25
G01 X1 Y1
G01 X25 Y1
G01 X25 Y25
G01 X1 Y25
G01 X1 Y1
G01 X25 Y1
G01 X25 Y25
G01 X1 Y25
G01 X1 Y1
M63 P20   (This will turn OFF the Laser Gate and PWM with the next motion command)
(Move to the next position, and then start a new laser cut if desired...)

6
Mach4 General Discussion / Re: Mach4 Simple Auto z touch
« on: August 12, 2020, 12:04:45 PM »
Thanks Katz, I didn't see that section in the config/installation guide. Point me in the right direction please.

Thanks

George

7
Mach4 General Discussion / Mach4 Simple Auto z touch
« on: August 12, 2020, 05:06:02 AM »
I'm looking for a simple procedure to Auto zero my Z axis when an M6 tool change is executed.

My mach3 setup had an extra button on the screen for this.

Thanks

George

8
Mach4 General Discussion / Re: PWM and Mach4 Hobby setup
« on: August 06, 2020, 02:26:55 PM »
All set up now and the Machine seems to be responding. Any chance of a sample piece of code/file.

Thanks

George

9
Mach4 General Discussion / Re: PWM and Mach4 Hobby setup
« on: August 06, 2020, 11:00:16 AM »
OK!

That's good advice.

Thanks

George

10
Mach4 General Discussion / Re: PWM and Mach4 Hobby setup
« on: August 06, 2020, 09:22:50 AM »
Your image looks great Tweakie, So here's what I will do, I read the article on setting up the laser settings in the ESS. Looks fairly straight forward so I will do that today. I'l l then add your PP. I shall purchase Aspires add on for creating laser work, images cutouts etc and try it.

It is my feeling that Aspire have written pp's for direct download to half a dozen different machines, bespoke machines are not supported, this I understand. I cannot see why it wont work going through a Mach4 PP such as yours.

It looks to be very good piece of software so I'll try it. For the sake of 40 quid, well.....

Regards

George

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 »