Hello Guest it is February 23, 2024, 08:03:45 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jonny quest

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 »
1
I'm having a hard time finding information on what Mach3 does with the B axis for inverse time feed? XYZA are working fine, but my B axis is gaining and or losing steps depending on how many toolpaths are used.

This is a trunnion 5 axis machine

2
General Mach Discussion / Re: 5 axis simultaneous
« on: April 06, 2023, 11:18:18 PM »
i have it figured out, but don't know how to fix it.

I have toolpaths that are inverse feed and standard indexed moves in same program.

i get this error when I try to jog after program is run "F word is missing with inverse time g1 move , block = G91G1 A0.0010"

The rotary axis only moves in a jog if I spin pendant fast. So, during program run I think when feedrate is low it doesn't move when it's supposed too.

When it switches back and forth it wrecks havoc on toolpath moves and loses and or gains steps.

3
General Mach Discussion / Re: 5 axis simultaneous
« on: March 26, 2023, 11:04:48 AM »
Maybe I should ask this question.

Has anybody used Mach3 in a 5 axis trunnion setup, and it's worked exactly as intended?

4
General Mach Discussion / Re: 5 axis simultaneous
« on: March 13, 2023, 02:26:56 PM »
R3.043.062 is my version of Mach3

5
General Mach Discussion / Re: 5 axis simultaneous
« on: March 09, 2023, 03:16:08 PM »
Still trying to figure this out.

I believe 3.042 version. Not buy machine for a few days.

Backlash is disabled for B axis. B axis doesn't need Backlash compensation. I have tried it both ways, Backlash comp on and off .same problem.

A word Mach3 issue. A axis is zeroed. A axis has Backlash comp on. If Backlash window is opened,  then closed... the A axis will show half the Backlash setting steps in DRO with no movement or anything done.

Could my issue be a bug in my version of Mach?

6
General Mach Discussion / Re: 5 axis simultaneous
« on: February 15, 2023, 04:26:13 PM »
My post processor uses inverse time feed G93.

I know it's not a backlash problem.

It may be loosing steps because of acceleration issues changing direction? I know it's not loosing steps because of cutting forces or binding

7
General Mach Discussion / Re: 5 axis simultaneous
« on: February 10, 2023, 07:30:44 PM »
Thanks for tip. I'll if I have time to try that tomorrow

8
General Mach Discussion / 5 axis simultaneous
« on: February 09, 2023, 04:18:09 PM »
Standard XYZ Trunnion A and B rotary.

If I cut in indexed 5 axis mode, cuts perfect.

If I cut in 5x simultaneous mode, my B axis is off at end of program.  I don't use homing, I just use center of trunnion and make sure A is flat an B is square to X axis.

I'm 99% sure B isn't loosing steps, it's not a backlash problem.

One weird phenomenon is after program ends, I type Z10 in mdi, then X0Y0A0 in mdi and it moves at f50 which is what previous program calls. When I type B0 it's feedrate is like f1.... so type f50 B0 to return that to 0 position.

What should I be looking for?

9
G-Code, CAD, and CAM discussions / Re: G40.1
« on: December 30, 2021, 12:17:26 PM »
I'm using Mach3 version R3.043.062 with Madcam 5 axis.

I'm having a problem with toolpath looking correct in cad, but when I try and cut part it is off by about .25" just to one side. The location It's trying to cut is off by this amount. The cutter diameter I'm using is .25".

I have G40.1 in my post processor. Should I remove this entirely from my post processor?

Looking for suggestions, been fighting this for quite awhile.




10
General Mach Discussion / Re: Cutting wrong dimensions in only one spot
« on: November 01, 2019, 11:46:37 AM »
I would turn CV on and off with the check box in MACH3 config only.

The post processor is still the same.  Should I remove a string in post?

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 »